Arianna

Forum Replies Created

Viewing 22 posts - 1 through 22 (of 22 total)
  • Posted in:
  • 14. Oktober 2018 at 11:28 #38598

    I’ve been away from home for months.
    Now I’m back and I restart my Rasp… but I don’t remember where the kodi logs are!

    9. Juli 2018 at 14:49 #36497

    No! If I click on Start Kodi, it starts!
    Simply AUTOSTART doesn’t work.
    I have to start Kodi manually every time I restart my raspberry.

    29. Juni 2018 at 10:27 #36408

    yes, I tried it in different ways 🙁

    25. Juni 2018 at 15:50 #36349

    I use HDMI as default.
    But my Raspberry comes with LCD display (unused for now)

    23. Juni 2018 at 22:53 #36326

    My device is a Raspberry PI 3, not B+.
    But with the other image, m2p_rpi_default_244_wps_ap_expand.img with Raspbian Jessie doesn’t work too.

    22. Juni 2018 at 9:01 #36310

    I used „Max2Play Raspberry Pi ALL incl. 3B+ (SD-Card Image based on Raspbian Stretch)“ (m2p_stretch_rpi_245.img.zip)
    Before this I used the version with Debian Jessie and I had the same problem

    19. Juni 2018 at 18:50 #36261

    Yes! The device load desktop

    18. Juni 2018 at 11:23 #36232

    I didn’t change autostart.conf manually. I only checked the kodi value in the file.
    I tried with xbmc=1 manually in the file and it doesn’t works.
    It’s very strange: this is the second time I try with a new image, but it happened same thing.

    11. August 2017 at 19:47 #30576

    thanks!

    10. August 2017 at 16:52 #30559

    I read this: https://www.max2play.com/en/how-tos/how-to-max2play-voice-control-with-apple-voice-assistant-siri/
    but I can’t find Plug-in Voice Control Donwload!
    Where is it?

    Thanks

    Edit: It’s the wrong name in the How To. It’s Plugin Speech Control, not Plug-in Voice Control 😛

    28. Dezember 2016 at 0:25 #25279

    You think it is too complicated? 🙁

    13. Oktober 2016 at 21:33 #23414

    So, can’t I use HDMI and LCD Display together? 🙁

    none try this https://www.youtube.com/watch?v=d2ouG1VmD88 ?

    17. September 2016 at 13:33 #23077

    2) 7′ LCD display and HDMI don’t work together! I had thought to set Kodi over HDMI and Jivelite over 7′ LCD display. But only display I choose like primary work! If I use VNC I see Kodi on HDMI and Jivelite on VNC!

    Any news?
    I don’t solve it 🙁

    8. September 2016 at 20:24 #22938

    But…On hostname NIGHT I’ve two problem:
    1) No audio from Kodi. Squeezelive use bluetooth (pulseaudio) and it works. In Kodi I set (System->Setting->Audio to HDMI), but nothing! My primary display is HDMI.

    Solved with this in config.txt:

    hdmi_mode=5
    hdmi_group=1
    hdmi_drive=2
    hdmi_force_hotplug=1
    lcd_rotate=2
    #display_default_lcd=1
    hdmi_safe=1

    2) 7′ LCD display and HDMI don’t work together! I had thought to set Kodi over HDMI and Jivelite over 7′ LCD display. But only display I choose like primary work! If I use VNC I see Kodi on HDMI and Jivelite on VNC!

    I’m doing various tests

    8. September 2016 at 19:25 #22937

    Hello Heiner!
    I was referring to a display Adafruit 2.8.
    I solved by changing the starting time of vnc.

    I remind you that I don’t speak English very well, so maybe I express myself badly… Excuse me!

    Now this is may situation:
    raspberry

    But…On hostname NIGHT I’ve two problem:
    1) No audio from Kodi. Squeezelive use bluetooth (pulseaudio) and it works. In Kodi I set (System->Setting->Audio to HDMI), but nothing! My primary display is HDMI.
    2) 7′ LCD display and HDMI don’t work together! I had thought to set Kodi over HDMI and Jivelite over 7′ LCD display. But only display I choose like primary work! If I use VNC I see Kodi on HDMI and Jivelite on VNC!

    Any tips?

    4. September 2016 at 2:01 #22860

    Me again.
    And still a problem.
    I enabled jivelite autostart.
    When I turn off my raspberry, webapplication says jivelite is running, but the display remains on startx desktop.
    To start I have to stop by the web application and then restart it.
    Why?

    Thanks.

    2. September 2016 at 1:50 #22836

    After many (so many) times, I was able to get the audio (USB & BT) configured, wifi, jasper (I only tested the tts, not stt) etc etc
    So I made an image to not start over every time.

    Now I still have two one problems:
    1) fails to install anything that comes from Git (in general with https port 443)
    Connect to github.com (github.com) | 192.30.253.112 |: 443 ... failed: No route to host.
    I have no proxy and nameserver in resolv.conf is ok (8.8.8.8 & 8.8.4.4)

    SOLVED.
    I found changes on the interfaces file (???)
    2) if I install Rpi display for adafruit 2.8 the screen remains blank
    SOLVED.
    a) There was a link behind the display that had broken away
    b) In max2play wabapplication I always read „RPi-Display Touchscreen Setup“.
    This is because in rpitouchdisplay/controller/Setup.php there is:
    `private function getAddonVersion(){
    if(strpos($this->getConfigFileParameter(‚/boot/config.txt‘, ‚dtoverlay‘), ‚rpi-display‘) !== FALSE || strpos($this->getConfigFileParameter(‚/opt/max2play/options.conf‘, ‚display‘), ‚7inch‘) !== FALSE){
    $this->view->installed = true;
    }else{
    $this->view->installed = false;
    }
    return true;
    }`
    with only rpi-display and 7inch. Missing pitft28r

    In if condition, I added: strpos($this->getConfigFileParameter('/boot/config.txt', 'dtoverlay'), 'pitft28r') !== FALSE ||

    Sorry for the English, just to explain what I’m doing:

    4 raspberry , 5 rooms.
    In every room there is a raspberry with squeezelite (the server is on a PC).
    Only one raspberry has multisqueeze to run on two rooms (one with bluetooth speaker)
    In one room, raspberry will also work with kodi.
    I add a picture that is better than how I write in English
    Red color is that I have yet to.
    And, as I said, for now, I tested only tts, not stt

    Raspberry schema

    After I will be happy to share with you my plugin.

    • This reply was modified 6 years, 3 months ago by  Arianna.
    • This reply was modified 6 years, 3 months ago by  Arianna.
    • This reply was modified 6 years, 3 months ago by  Arianna. Reason: solved route problem
    • This reply was modified 6 years, 3 months ago by  Arianna. Reason: solved diaply problem
    31. August 2016 at 14:12 #22782

    Hello Heiner.
    Thank you for reply.
    I’m trying to restart from an empty SD card on an old raspberry B+
    12 hours to compile ahahahahah …and has not yet finished 😛

    I would a very light version of „Siri“.
    „What is the weather like?“ „Are there new mail?“ etc etc

    Notes:
    in your install_jasper.sh
    I changes
    wget https://phonetisaurus.googlecode.com/files/is2013-conversion.tgz
    with
    wget https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/phonetisaurus/is2013-conversion.tgz

    and after:
    cd phonetisaurus-0.7.8/
    cd src
    sudo make
    cd ..
    sudo cp phonetisaurus-0.7.8/phonetisaurus-g2p /usr/local/bin/phonetisaurus-g2p

    with
    cd is2013-conversion/
    cd phonetisaurus/
    cd src
    sudo make
    cd ..
    sudo cp is2013-conversion/phonetisaurus-g2p /usr/local/bin/phonetisaurus-g2p

    • This reply was modified 6 years, 3 months ago by  Arianna.
    30. August 2016 at 17:52 #22771

    For Speech Control:
    – Espeak now work (obviously I must specify parameter for audio card. Don’t work on „default“)
    – Jasper, with –local parameter works. –local for text recognition.
    Now if I test PocketSphinx with pocketsphinx_continuous -inmic yes
    this start, but after I get
    Warning: Could not find Mic element
    Warning: Could not find Capture element

    Probably I must specify soundcard. How?

    Thanks

    Added:
    When I try to start Speech Control from web interfaces, I get:
    „Install Jasper, Google STT, ESpeak TTS
    Qualcosa è andato storto con l’ultimo tentativo di installazione – cancellare il file di installazione e riprovare“

    Moreover… Google STT???
    It’s commented in script install_jasper.sh!

    • This reply was modified 6 years, 3 months ago by  Arianna. Reason: Added info
    30. August 2016 at 16:40 #22769

    this about speech control?
    I think the problem isn’t hardware. I found error in installation script (as inexistent url, moreover my raspberry, with max2play image, doens’t reach github for some problem with 443 port)

    I installed manually jasper, espeak, phonetisaurus… now I get

    *******************************************************
    *             JASPER - THE TALKING COMPUTER           *
    * (c) 2015 Shubhro Saha, Charlie Marsh & Jan Holthuis *
    *******************************************************
    ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.bcm2835.pcm.front.0:CARD=0'
    ALSA lib conf.c:4259:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:4738:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM front
    ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
    ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
    ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
    ALSA lib confmisc.c:1286:(snd_func_refer) Unable to find definition 'cards.bcm2835.pcm.surround51.0:CARD=0'
    etc etc
    

    infact cards.bcm2835.pcm.front.0:CARD=0 isn’t card to use! Where i must configure it???

    For Bluetooth:
    1.) Which Raspberry Pi do you use? So I can see you if you use the onboard bluetooth of the Raspberry Pi 3 or a bluetooth dongle and a wifi dongle.
    Raspberry 2, so I use a dongle BT (I specify in another post)

    2.) Which power supply? (2A or 2.5A)
    In this moment 2A. But I test with 2.5A too and even with an alimented hub usb

    3.) Is something on the usb ports of the Raspberry Pi?
    I tested with only bt and with an hub usb too. Using ethernet, so I remove wifi dongle

    4.) Is it the already the current Version of Max2Play? (Max2Play Version 2.35)
    2.35

    5.) Could you also share the debug information of the speech control menu? You can find it at the buttom of the site.

    #### JASPER Installed ####
    1 
    
    #### ESPEAK Installed ####
    1 
    
    #### POCKETSPHINX Installed ####
     
    
    #### JASPER Running ####
     
    30. August 2016 at 15:42 #22765

    none?
    Speechcontrol doesn’t work?

    27. August 2016 at 19:58 #22674

    Hello!
    I have a Raspberry 2 (no Bluetooth onboard), so I use a dongle.
    With a clean image of Raspbian Jessie, I have no problem.
    With max2play, I installed Bluetooth plugin. Scan not found nothing.
    So, I check Debug output and…
    It doesn’t find any bluetooth dongle???

    #### Bluetooth Installation ####
     
    
    #### Bluetooth Dongle ####
     
    
    #### PACMD LIST | grep active ####
    	active port: <analog-output>
    	active profile: <output:analog-stereo>
     
    
    #### PACMD LIST | grep sink ####
    Default sink name: alsa_output.0.analog-stereo
    		module.description = "When a bluetooth sink or source is added, load module-loopback"
    		module.description = "Automatically restore the default sink and source"
    		module.description = "When a sink/source is removed, try to move its streams to the default sink/source"
    	name: <module-always-sink>
    		module.description = "Mantiene sempre almeno un sink caricato anche se è nullo"
    		module.description = "When a sink/source is idle for too long, suspend it"
    		module.description = "Load filter sinks automatically when needed"
    1 sink(s) available.
    	sinks:
    0 sink input(s) available.
     
    
    #### X-SERVER RUNNING ####
    1 
    
    #### PULSEAUDIO RUNNING ####
    1 S  1000  3005     1  1  80   0 - 23704 -      ?        00:00:00 pulseaudio
    1 S  1000  3026     1  0  80   0 -   475 -      ?        00:00:00 start-pulseaudi
     	

    ssh result:

    [email protected]:~# /etc/init.d/bluetooth status
    â bluetooth.service - Bluetooth service
       Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
       Active: active (running) since sab 2016-08-27 21:49:11 CEST; 4min 36s ago
         Docs: man:bluetoothd(8)
     Main PID: 3622 (bluetoothd)
       Status: "Running"
       CGroup: /system.slice/bluetooth.service
               ââ3622 /usr/lib/bluetooth/bluetoothd
    
    ago 27 21:49:11 Orange bluetoothd[3622]: Bluetooth daemon 5.23
    ago 27 21:49:11 Orange bluetoothd[3622]: Starting SDP server
    ago 27 21:49:11 Orange systemd[1]: Started Bluetooth service.
    ago 27 21:49:11 Orange bluetoothd[3622]: Bluetooth management interface 1.10...d
    Hint: Some lines were ellipsized, use -l to show in full.
    [email protected]:~# hcitool scan
    Device is not available: No such device
    [email protected]:~#
    
    
    • This reply was modified 6 years, 3 months ago by  Arianna. Reason: add ssh result
    • This reply was modified 6 years, 3 months ago by  Arianna.
Viewing 22 posts - 1 through 22 (of 22 total)