kodi autostart

Tagged: ,

This topic contains 17 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • 13. Juni 2018 at 18:57 #36189

    Hello!
    I checked „Autostart Kodi (Video)“, but It doesn’t start until I click manually on the button.
    Why?

    My autostart.conf:

    # Autostart Config File for Loading Services by Cronjob under User odroid
    # to edit cronjob login as odroid and "crontab -l"
    # Cronjob loads start_audioplayer.sh 
    # 1 = autostart, 0 = no autostart
    squeezelite=1
    shairport=0
    xbmc=0
    Max2PlayNetworkLookup=1
    squeezeslave=0
    jivelite=0
    autostartxserver=1
    kodi=1
    ympd=0
    mpd=0
    bluetooth=1
    
    18. Juni 2018 at 10:47 #36231

    Hi Arianna,

    If you manually did this manually please either try changing xbmc to 1 or burn a new image and only use the tick for Kodi autostart.

    18. Juni 2018 at 11:23 #36232

    I didn’t change autostart.conf manually. I only checked the kodi value in the file.
    I tried with xbmc=1 manually in the file and it doesn’t works.
    It’s very strange: this is the second time I try with a new image, but it happened same thing.

    19. Juni 2018 at 11:03 #36253

    Do you have an output after booting? Does the device load the desktop?

    19. Juni 2018 at 18:50 #36261

    Yes! The device load desktop

    21. Juni 2018 at 13:37 #36292

    Which image did you download and what device are you using?

    22. Juni 2018 at 9:01 #36310

    I used „Max2Play Raspberry Pi ALL incl. 3B+ (SD-Card Image based on Raspbian Stretch)“ (m2p_stretch_rpi_245.img.zip)
    Before this I used the version with Debian Jessie and I had the same problem

    22. Juni 2018 at 15:26 #36315

    I just tested with RPi 3B+ and a new Stretch Image and the autostart worked. What device are you using?

    23. Juni 2018 at 22:53 #36326

    My device is a Raspberry PI 3, not B+.
    But with the other image, m2p_rpi_default_244_wps_ap_expand.img with Raspbian Jessie doesn’t work too.

    25. Juni 2018 at 15:48 #36348

    Do you perhaps have another HDMI cable or screen to make sure this is not causing the issue? As mentioned, I cannot recreate this error on any test device.

    25. Juni 2018 at 15:50 #36349

    I use HDMI as default.
    But my Raspberry comes with LCD display (unused for now)

    29. Juni 2018 at 9:29 #36400

    was your screen on when you boot the pi? if not, this might be the issue.

    29. Juni 2018 at 10:27 #36408

    yes, I tried it in different ways 🙁

    9. Juli 2018 at 12:51 #36492

    very odd, so the boot sequence loads on the screen, the desktop is established, but clicking start on the web interface for Kodi does not start Kodi in the desktop? And this occurs even with an image where you have not done anything yet?

    9. Juli 2018 at 14:49 #36497

    No! If I click on Start Kodi, it starts!
    Simply AUTOSTART doesn’t work.
    I have to start Kodi manually every time I restart my raspberry.

    11. Juli 2018 at 15:59 #36537

    Got it, please check the Jivelite menu if you have not to make sure there is not autostart set there.

    Also, what does the debug info log of Kodi say and what is the last lines in the boot sequence?

    14. Oktober 2018 at 11:28 #38598

    I’ve been away from home for months.
    Now I’m back and I restart my Rasp… but I don’t remember where the kodi logs are!

    15. Oktober 2018 at 9:39 #38613

    Hi Arianna,

    Please check the bottom of the Kodi menu in Max2Play, there’s a field called „debug info“.

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

Register here