Mounting Diskstation share

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Mounting Diskstation share

Tagged: 

This topic contains 4 replies, has 2 voices, and was last updated by  davidc premium 3 days, 14 hours ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 11. Oktober 2021 at 13:41 #51735

    Hi

    I’ve watched the video on this but I still can’t get it work. I have created a user/password on the DS and entered these in the ‚Options‘ field following the template but when I click ’save‘ it tries for a long time before failing and then I see:

    Failed to query password: Timer expired Password for [email protected]//192.168.0.113/video: mount error(95): Operation not supported Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error(95): Operation not supported Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error(95): Operation not supported Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    I do have a console on another browser tab where I see several of these:

    Broadcast message from [email protected] (Mon 2021-10-11 13:18:06 CEST):
    Password entry required for ‚Password for [email protected]//192.168.0.113/video:‘ (PID 11864).
    Please enter password with the systemd-tty-ask-password-agent tool:

    This suggests it’s trying to mount the share as root on the DS??? I tried starting NFS on the DS but that lead me to a load of fresh errors.
    I can access the share via Windows Explorer where it is \\192.168.0.113\video

    11. Oktober 2021 at 14:06 #51736

    Ah, I had to add ‚,vers=3.0‘ after the password

    11. Oktober 2021 at 16:39 #51737

    I thought it was sorted but no. It was working but …

    This mounting screen seems odd. Each failed attempt is retained and the only action available is to delete. Deleting the failed ones also unmounts the successful one since the correct mount point was specified in the failed attempts. So, I tried to remount it using what worked last time (username,password,vers=3.0) but it fails with error 95 again. That’s when it eventually times out – minutes later.
    When it fails it says ‚entry deleted‘ but it’s not – it is still visible hence the need to remove them manually

    A bit annoying as was all working and I was just trying to tidy up.

    12. Oktober 2021 at 12:54 #51738

    Hi David,

    I’m sorry that mounting is causing problems. Recently, many here in the forum have had different problems with it – mostly due to the new DSM version 7.0.
    Maybe their experiences will help you. Here are the latest threads on the same topic (some are in german though):

    Dateisystem – Mounten von Pfaden – Einbinden von Dateien von Synology DSm/

    Another Synology Mounting Problem

    Squeezebox Server Konfig. falsch

    In the two German threads, nfs was used for mounting. The solution to the problem was to specify the path correctly in this form:

    IP-Address://Path (Path example: volume1/Music/)
    /mnt/share
    nfs

    Sometimes it also helped to change the NFS version in the Diskstation settings and share the music files with „Everyone“. They have also left out the other options (user, password etc) for NFS sharing.

    For more information, I recommend you also read our wiki article on mounting: https://www.max2play.com/en/wiki/mounting-an-external-drive/

    12. Oktober 2021 at 14:52 #51739

    Hi Mario, thanks for the reply.

    I gave up trying to do it through the web interface but was successful using the the command line. I did need the ‚vers=3.0‘ in the options. I also enabled SMB3 on the diskstation = I suppose those two go together?. I have also added entries to fstab but I’ve no idea yet if they will work.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here