Another Synology Mounting Problem

Max2Play Home Forums Max2Play as Squeezebox (Player / Server) Another Synology Mounting Problem

Viewing 16 posts - 1 through 16 (of 16 total)
  • 23. Dezember 2016 at 3:17 #25189

    I am posting my problem as a new thread as I had no response when I posted on the other Synology thread by Tobias

    Please help me if you can !

    I am new to raspberry Pi , NAS and all things networking so please feel free to make the most basic of suggestions.

    I installed a raspberry Pi 3 as Squeezebox Server a couple of weeks ago. It works great , temporarily set up a USB external hard drive to test and I got that figured out no problem. Got the premium license to try the wifi access point and turned that on . That works fine although not very high bitrate.

    I just installed a new Synology NAS (216J) on my home network for permanent redundant music and music storage. As I mentioned above I know nothing about NAS devices and very little about networking in general. I can see the NAS in windows on home PC and laptops. Was able to access the NAS through those devices via the DSM web app and also was able to map a network drive. Also was able to access the NAS with my android phone using the Synology app using the quickconnect feature.

    When trying to mount the drive :
    I see the”//diskserver/music” folder when I hit the ” show network devices ” botton in max2play web interface

    I tried a couple of ways to mount it:




    I actually got the drive to mount using the top two inputs above but when I went in to the slimserver web interface settings and tried to navigate to the folder /mnt/share and run a scan there are no files. When I browse the folder is empty.

    Now today it mounted once and as per the other day the folder appears empty.

    Now it will not even mount.

    I get errors like

    “Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error: could not resolve address for diskserver: Unknown error Retrying with upper case share name mount error(6): No such device or address Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Mountpoint NOT added! Please refer to the description below!

    This is driving me crazy so any help would be appreciated.


    26. Dezember 2016 at 4:57 #25236

    I have discovered that if I do not include the „//“ at the start when inputting the ip address for the nas in max2play that I can successfully mount the share. The problem is that it does not show up in the folders when I try and add it in the slimserver web interface. The /mnt/share folder is empty.
    Any ideas ?

    31. Dezember 2016 at 4:53 #25326

    Hello technical support people at max2play? Are you out there ?? hoping you are on a xmas break!

    Seems like my questions fall on deaf ears in this forum but I continue to post about my problem as there is no where else to go it seems for technical support for the max2play OS.

    I added a „http:“ in front of the

    and the share seemed to mount . I tried with the options filled in per the help instructions using my user name and password and also tried with no options. In both cases the share mounts but as per all of my previous attempts there is no access in kodi or slimserver.

    Without access to the NAS it is rather useless for my intended application.

    Once again any help would be appreciated.

    2. Januar 2017 at 13:55 #25355

    Just a bump. I’m having the same problem with the same error messages trying to mount my Asustor NAS

    4. Januar 2017 at 15:20 #25500

    Any technical support people on this?

    4. Januar 2017 at 18:00 #25523


    I got as response from Heiner on the other synology mount thread that I originally posted my problem on so I copied my details into that thread if they want to use that one to keep the synology issues in one place. So far I have not received any significant assistance beyond “ watch the video“ which I suspect you have also already done at least once and resetting the max2play to the original settings. You may want to try that if you did not do that yet. I had already tried that before posting so those suggestions were no help for me and my NAS files are still not accessible. Hoping we will get some more help soon.

    4. Januar 2017 at 18:39 #25529

    Thanks for the response airh
    Yep tried everything including changing permissions and ownership of the files on the NAS.
    Guess a tech support person will come by sooner or later….

    11. Januar 2017 at 18:14 #25797

    Hi Ross and Steve,
    So sorry about the late response. We are still working on getting up to date on all technical requests since Christmas. Thank you for your patience.

    Please check your share and how you specified the login data (username and pw). Try accessing the share from a PC, the same procedure is used and the same input should work on Max2Play’s interface. http should not be included in the input. Please check the IP address of your diskstation to make sure you have selected the right one. This is the most ideal input for the share to be recognized. Please create another user than „admin“ or „guest“ and assign it its own password. We have a diskstation here at work and actually have not encountered any of these issues before, so we are especially interested in what is causing your errors.

    11. Januar 2017 at 22:06 #25800

    I followed your instructions and created the new user “ max2play“ on the diskstation and it worked !!


    This mounted and worked when I accessed through the squeezebox server interface.

    Then I tried another mount, to access my video folder on the NAS


    This also loaded but in squeezebox server I can see only one folder “ music“ .The video folder is not visible. I think I need to create separate folders on the pi to give separate targets ie /mnt/share/music and /mnt/share/videos to give each share a proper path. Is this what is required or should it have worked the way I did it ?

    16. Januar 2017 at 15:29 #25952

    It would make sense to create individual shares for both. Otherwise, both are in the same directory.

    16. Januar 2017 at 16:39 #25960

    Ok so how does one create additional subfolders on the pi ie. /mnt/share/music or /mnt/share/video ?

    16. Januar 2017 at 16:50 #25964

    Hi airheader911,
    The help section of the Filesystem/Mount menu is very helpful on that:
    Mountpoint on Max2Play (for usage in Squeezebox Server or XBMC): /mnt/mountdir/ Mountpoint must be a subdirectory in /mnt/ OR /media/ and will be generated, if it is not existing.

    3. Oktober 2021 at 13:58 #51698

    Dear Heiner,

    Looks like there is a compatibility problem again beetween Filesystem/Mount menu of Max2Play and my Synology DS216J after the update to DSM version 7.

    Everything was working fine under DSM 6, but since the update to 7, im now unable to access my music files stored on my Synology anymore…..very annoying.

    I have followed all the advices you gave to airheader911 in the forum previously and also created a new user “ max2play“ on the diskstation, but when I try to mount a new folder for file sharing with the followin command ( //Ds216j/music/HiRes /mnt/HiResMusic cifs user=max2play,password=squeezebox,iocharset=utf8,sec=ntlm,vers=1.0) , i always get this same error:

    mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) mount error(13): Permission denied Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Ajout du point de montage impossible ! Veuillez vous référer à la description ci-dessous

    PS: i also tried to replace //Ds216j with //local_ip_adress but it doesnt work either.

    I have been googeling and trying some different parameters for weeks now, but nothing seems to work unfortunately…. I would really appreciate if you give me the solution to acces again to my .FLAC files stored on my Synology NAS.

    Best Regards,


    5. Oktober 2021 at 15:07 #51708

    Hi Attilio,

    Since the update to DSM 7, some of our users have the same problem. Please try the following:

    In your Diskstation, go to Control Panel > File Services > SMB > Advanced Settings > Others and enable NTLMv1 authentication.

    Does the access work again afterwards?

    5. Oktober 2021 at 21:39 #51713

    Thanks MarioM for the feedback.

    In the meantime, I continued to fight with the beast and finally managed to make it work by simply changing:

    //Ds216j/music/HiRes /mnt/HiResMusic cifs user=max2play,password=squeezebox,iocharset=utf8,sec=ntlm,vers=1.0


    //Ds216j/music/HiRes /mnt/HiResMusic cifs user=max2play,password=squeezebox,iocharset=utf8,_netdev

    Now I can finally see again my mounted lossless folders in the Squeezebox server, but it still seems to be laggy when I stream my music… I have now to clarify if some setting has changed in my network (which was working fine under DSM 6) or if it is related to the ‚_netdev‘ setting instead of ’sec=ntlm,vers=1.0’… Maybe you have an advice about it? What does change when I use ‚_netdev‘ in the Options field?

    I will also try your proposal and let you know.


    7. Oktober 2021 at 12:50 #51728

    Hi Attilio,

    _netdev ensures that network mounts are connected even if the system’s network access was not active at the time the system attempted to mount during boot. I guess the mount worked now because you removed the sec=ntlm and vers=1.0 options.

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

Register here