[UPDATE BUG FIX] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE BUG FIX] Bluetooth Addon BETA

This topic contains 464 replies, has 104 voices, and was last updated by  awalsh99 premium 5 months, 2 weeks ago.

Viewing 30 posts - 301 through 330 (of 465 total)
  • 14. Dezember 2017 at 11:51 #32938

    HALLELUJAAAA!i formatted sd,reinstalled max2play with all the plugin i need,disabled wifi,lms plugin for upnp,updated kernel and it s working from more of 12hours without problems!!later i ll try with wifi too! And after days and days to try make it work,now it works…..and allo boss dac arrived this morning!i hope all will ok after the dac installation!! But now for first i ll burn the image for backup my sd

    15. Dezember 2017 at 11:05 #32957

    Hi guys,

    We have now made some progress in isolating the issue. Unfortunately, it seems to be directly connected to the Raspberry Pi 3’s built-in Bluetooth module. We tested with a dongle and with built-in, and the dropouts only occurred with the built-in module. It also does not seem to be connected to pulse audio as we also tested a different Bluetooth audio solution based on ALSA. So for people looking to implement Bluetooth as a permanent player instance, a Bluetooth dongle is probably necessary for continuous playback over two and a half hours.

    However, we have added a new feature to our newest beta of the Bluetooth plugin that indicates such a dropout that might occur after 180 minutes that shows you whether your device needs to be restarted. Obviously, we will also keep looking into this matter and will try to add the ALSA implementation for Bluetooth in a future release as well.

    Thank you all for your support, your detailed error reports and your dedication 🙂

    16. Dezember 2017 at 15:33 #32990

    Hi,

    I had issues when streaming music from my nexus 5X to a raspberry pi 3 (audiophonics). The bluetooth connection could only last a couple of seconds (while it was working fine with a UE bluetooth speaker).

    An update to android 8.1 partly solved the issue (the connection was lasting a few minutes).

    Then I found out that the dhrone raspdac display script (installed from the audiophonics plugin) was eating more than 10% of CPU time.
    Now that the display script is deactivated, bluetooth streaming seems to work fine (did not try for hours).
    I will try to install another script, but I’m already happy with the result 🙂

    2. Januar 2018 at 18:41 #33187

    Hello,

    i have a Questen.

    I have a Squeezelite Server on a VM and a Squeezelite Client. This Client is connect with a Bluetooth-Speaker.

    Can i sync the volume between the Squeezelite Server and the Bluetooth-Speaker?

    Thanks for your Help and a Happy new Year.

    5. Januar 2018 at 14:07 #33258

    Hi guys,

    @letsyl:

    We have indeed found out by now that the Bluetooth issues are connected to the Pi’s management of its built-in BT module. If there is too much of a load on the system, dropouts are more likely to occur. The same goes for WiFi. the Pi prioritizes the BT connection behind other processes which can lead to issues in BT playback. The easiest solution would be to get a BT dongle. We have run test with both dongle and built-in and only the latter ever drops out.

    @gamelive2017:

    Unfortunately, hardware volume control is only possible with (most) HAT sound cards on our OS.

    5. Januar 2018 at 19:25 #33264

    Hallo Heiner,

    na da war mein Tipp mit dem Bluetooth Dongle wohl goldrichtig 🙂

    VG
    Stefan

    8. Januar 2018 at 16:52 #33303

    Jep! Wir mussten nur absolut sichergehen, bevor wir die Vermutung bestätigen und Leute zu einer Peripherie raten 😉

    14. Januar 2018 at 21:19 #33412

    No sound from Squeezebox Boom from my Android phone

    I ordered a license today in order to share sound from my Motorola G5 plus to my LMS. I was very happy to see Max2Play offers this option.

    So I went ahead:

    • I have followed the setup as explained in the video.
    • I have a Raspberry 2B with a bluetooth dongle that works and pairs with my phone. It allowed me to enter a code and it pairs successfully.
    • I first had sound shared through Deezer on my phone, and it was played through my HDMI connection (although it had some problems keeping pace with my phone).
    • I installed the Bluetooth support for Squeezebox Server, and the favourite in my Boom was added and it says „currently playing“

    Problem is: I do not have sound!

    I think it is not
    the bluetooth connection:

    In the Desktop Bluetooth GUI I can see that the connection is getting quite some traffic, so I assume the connection is working.

    It is not the Boom itself:
    If I switch to another favourite on my Boom, it does play sound. Another Boom does not play sound either through the favourite.

    I did change to pulse audio under audioplayer/shairport, to play sound through the internal soundcard. After that I also did not have sound anymore through HDMI, also not when switching.

    I use Version 2.45.

    Can someone please help?

    Thanks

    #### Bluetooth Installation ####
    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 00:09:DD:10:66:76 ACL MTU: 192:8 SCO MTU: 64:8
    UP RUNNING
    RX bytes:30709912 acl:112012 sco:0 events:134 errors:0
    TX bytes:3447 acl:93 sco:0 commands:29 errors:0

    #### DEVICE [Moto G (5… (522)]0 ####
    [80:58:F8:58:3A:A3]
    Name: [Moto G (5… (522)]0
    Alias: [Moto G (5… (522)]0 [rw]
    Address: 80:58:F8:58:3A:A3
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [OBEXObjectPush, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, HeadsetAudioGateway, PANU, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb, 7fbe865e-518b-462a-b31b-90acf6a472fc, 936da01f-9abd-4d9d-80c7-02af85c822a8, e3cccccd-33b7-457d-a03c-aa1c54bf617f]

    #### PACMD LIST | grep active ####
    active port: <analog-output>
    active profile: <output:analog-stereo>

    #### PACMD LIST | grep sink ####
    Default sink name: null
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    module.description = „When a bluetooth sink or source is added, load module-loopback“
    module.description = „Automatically restore the default sink and source“
    name: <module-always-sink>
    module.description = „Always keeps at least one sink loaded even if it’s a null one“
    module.description = „When a sink/source is idle for too long, suspend it“
    module.description = „Load filter sinks automatically when needed“
    name: <module-null-sink>
    module.description = „Clocked NULL sink“
    3 sink(s) available.
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    driver: <module-null-sink.c>
    sinks:
    1 sink input(s) available.
    sink: 0 <null>
    module-stream-restore.id = „sink-input-by-application-name:ALSA plug-in [squeezelite]“

    #### X-SERVER RUNNING ####
    1

    #### PULSEAUDIO RUNNING ####
    1 S 1000 991 1 6 80 0 – 28236 – ? 00:02:09 pulseaudio
    1 S 1000 1507 1 2 80 0 – 44383 – ? 00:00:49 pulseaudio
    0 S 1000 1819 1 0 80 0 – 18662 – ? 00:00:00 pulsebluetooth

    #### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####
    Usage: /var/www/max2play/application/plugins/bluetooth/scripts/pulsebluetooth [-d]
    -d Enable DEBUG output

    #### PACMD LIST-CARDS | DEBUG COMPLETE ####
    1 card(s) available.
    index: 0
    name: <alsa_card.0>
    driver: <module-alsa-card.c>
    owner module: 7
    properties:
    alsa.card = „0“
    alsa.card_name = „bcm2835 ALSA“
    alsa.long_card_name = „bcm2835 ALSA“
    device.bus_path = „/devices/virtual/sound/card0“
    sysfs.path = „/devices/virtual/sound/card0“
    device.string = „0“
    device.description = „bcm2835 ALSA“
    module-udev-detect.discovered = „1“
    device.icon_name = „audio-card“
    profiles:
    output:analog-mono: Analog Mono Output (priority 100, available: unknown)
    output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
    off: Off (priority 0, available: unknown)
    active profile: <output:analog-stereo>
    sinks:
    alsa_output.0.analog-stereo/#1: bcm2835 ALSA Analog Stereo
    sources:
    alsa_output.0.analog-stereo.monitor/#1: Monitor of bcm2835 ALSA Analog Stereo
    ports:
    analog-output: Analog Output (priority 9900, latency offset 0 usec, available: unknown)
    properties:

    16. Januar 2018 at 11:35 #33471

    Hi guys,

    I just want to reiterate the current status of Bluetooth for all new users and readers here:

    – The Raspberry Pi 3 Bluetooth module can cause dropouts when the Pi has a high load (mostly occurs after ca. 3 hours of playback)

    – A Bluetooth dongle solves this issue and lets you use a Bluetooth connection for non-stop playback via LMS or Max2Play Audio Player
    (we sucessfully tested and recommend a Bluetooth V4.0 USB dongle)

    – This solution does not change individual’s Bluetooth speaker sleep mode. If you want to use it for 24/7 activity, make sure that it keeps itself paired.

    18. Januar 2018 at 17:18 #33525

    I bought a Bluetooth 4 dongle. Still it does not produce sound on the channel that was created in my favorites. Once I start playing music through my phone the throughput in the Bluetooth connection is increasing (visible in the status bar). So it must be something with how sound is shared to the connected Squeezebox.

    Does anyone has a suggestion?

    22. Januar 2018 at 21:25 #33605

    Hi guys! I come back to text just to try to resolve a little little problem with bluetooth! I vbegin to say that actually all is perfect with my configuration, i buied license for 1 year and i want say u THANKS FOR YOUR WORKS! With bluetooth is all ok, connection never falls, my bluetooth is always paired even and if i turn off it, the next day it s still paired..all perfect! Just one thing, little but bored: each time i push play on a song there are 10 seconds of disturbed sound, and then it sounds perfectly! There is a way to resolve this problem? It s the only problem i have now with max2play..and it s just on bluetooth!Clearly if i play music by all boss i dnt have this problem.
    Tnx guys for ur answers

    25. Januar 2018 at 13:05 #33638

    Hi antonio,

    Do you use the LMS or standalone BT solution?

    25. Januar 2018 at 13:40 #33642

    I use lms!what is this bt standalone?!i do everything with lms

    25. Januar 2018 at 14:02 #33643

    Hi Heiner,

    I use LMS. Setup with a favorite in my Boom. Still no sound coming from it, although bluetooth is transferring data. Any idea?

    Cheers.

    26. Januar 2018 at 17:05 #33681

    Hi guys,

    Thanks for the quick replies. I will set up a tester with the BT channel and try to recreate your issue.

    Is the BT speaker’s entry in the web interface green on both your devices? Also, did you check out the youtube video and follow instructions? If so, did your setup deviate in any way from these steps?

    31. Januar 2018 at 1:39 #33764

    I managed to get it working. I just installed max2play again from scratch. I followed the instructions in the video. Great stuff. Thanks.

    31. Januar 2018 at 12:17 #33770

    Hi teggenligger,

    Thanks for the follow-up, glad you got it working. 🙂

    18. März 2018 at 15:34 #34511

    Hey all
    Trying to connect to a Bluetooth speaker which although is visible I’ve been unable to pair.
    I’m using a Raspberry PI 2 (Version 2.45), with a Vitalitim B01 Bluetooth 4.0 USB Low Energy Micro Adapter Dongle.
    Here is the report from the Bluetooth Setup Page with the DEBUG Information:

    Connecting to: 00:E0:4C:E5:94:51
    Agent registered
    Device: SoundCore mini (00:E0:4C:E5:94:51)
    Confirm passkey: 369057 (yes/no)? Trusted: 0 -> 1
    [00:E0:4C:E5:94:51]
    Name: SoundCore mini
    Alias: SoundCore mini [rw]
    Address: 00:E0:4C:E5:94:51
    Icon: audio-card
    Class: 0x240404
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: []
    YOU PROBABLY NEED TO RESTART your AUDIOPLAYER (e.g. Squeezelite) to get it to work with Bluetooth!

    DEBUG Information
    #### Bluetooth Installation ####
    #### Bluetooth Dongle ####
    hci0: Type: BR/EDR Bus: USB
    BD Address: 00:1A:7D:DA:71:13 ACL MTU: 310:10 SCO MTU: 64:8
    UP RUNNING
    RX bytes:9460 acl:1 sco:0 events:135 errors:0
    TX bytes:1405 acl:0 sco:0 commands:89 errors:0

    Any help appreciated 🙂

    Cheers, Paul

    20. März 2018 at 14:34 #34557

    Hi Paden,

    Is there an option on the soundcore for pairing? Please try that and also click „connect“ again after it shows up green.

    24. März 2018 at 18:49 #34715

    Hi Heiner, many thanks for the reply.
    There isn’t an option on the speaker for pairing,
    However I have tried to pair both my phone & tablet without success.
    In max2play:
    Scan For Bluetooth Devices
    Following Bluetooth Devices found: XXX
    Connect
    Bluetooth Pairing Request code received on device
    Request confirmed on device
    Connection fails
    Do you think it might be a dongle issue?

    Cheers, Paul

    26. März 2018 at 15:58 #34744

    Hi Paul,

    To be sure, your phone tablet were also not able to pair with the speakers or not able to pair with Max2Play? The latter would be logical as we have not included pairing input devices via BT in our newest Stretch image.

    26. März 2018 at 22:14 #34767

    Hello again Heiner
    To clarify, I was able to successfully pair with the speaker from both my phone & tablet.
    When attempting to pair max2play with both phone & tablet, although each were visible, connection was not possible.
    I did not try pairing in the opposite direction i.e. from my phone or tablet.

    Cheers, Paul

    28. März 2018 at 10:16 #34834

    Hi Paden,

    Pairing with phone or tablet is only possible in our Jessie build of Max2Play. The new image currently only supports output devices like speakers.

    Sorry about the inconvenience. The bluetooth protocol varies with each device. So we can only speak to the ones we use for testing here with certainty. While the pairing seems to not work, you were apparently able to connect with the speakers you use. So please try testing playback with the bluealsa output in your audioplayer and see if this enables pairing.

    28. März 2018 at 11:23 #34839

    @heiner: Perhaps you can publish a list of your test devices incl. the compatibility test results?

    Thanks
    Oli

    28. März 2018 at 14:23 #34844

    Hi Oli,

    Thanks for the feedback.

    The two speakers we primarily used for testing were our JBL Go and a Bluetooth DOSS Box that we got from a customer for further testing.

    28. März 2018 at 22:46 #34851

    Thanks for your continued support Heiner.
    „you were apparently able to connect with the speakers you use“ – to clarify, I was not able to connect from the max2play software although the speaker was visible (unless this is what you mean).
    I will try testing playback with the bluealsa output as you suggest.
    Are there any other Bluetooth devices I could attempt to connect to for test purposes?

    Cheers, Paul

    29. März 2018 at 9:39 #34861

    My reference to „connected“ was in regard to your output log:

    Name: SoundCore mini
    Alias: SoundCore mini [rw]
    Address: 00:E0:4C:E5:94:51
    Icon: audio-card
    Class: 0x240404
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1

    Any bluetooth speaker should work with the Stretch Image, really.

    Clicking „connect“ after the first connection attempt might also do the trick.

    29. März 2018 at 17:41 #34906

    Thanks Heiner, will do as you suggest at the weekend 🙂
    Am currently using version 2.45 on a Raspberry PI 2, is the Stretch image compatible with this device?

    Cheers, Paul

    1. April 2018 at 14:18 #34924

    Hello again Heiner, no joy I’m afraid 🙁
    Here’s the process I followed

    Scan for Bluetooth devices

    Following Bluetooth Devices found: SoundCore mini 00:E0:4C:E5:94:51: Connect

    Connecting to: 00:E0:4C:E5:94:51
    Agent registered
    Device: SoundCore mini (00:E0:4C:E5:94:51)
    Confirm passkey: 691538 (yes/no)? Trusted: 0 -> 1
    [00:E0:4C:E5:94:51]
    Name: SoundCore mini
    Alias: SoundCore mini [rw]
    Address: 00:E0:4C:E5:94:51
    Icon: audio-card
    Class: 0x240404
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: []
    YOU PROBABLY NEED TO RESTART your AUDIOPLAYER (e.g. Squeezelite) to get it to work with Bluetooth!

    Squeezelite Advanced Options edited so that Soundcard Audio Output is: bluetoothspeaker

    Debug Information
    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8, Copyright 2012-2015 Adrian Smith.
    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT DSD
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o bluetoothspeaker -a 80:4::
    SHAIRPORT_PARAMETER=-d bluetoothspeaker
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    GMEDIARENDER_ALSA_DEVICE=plug:plugequal
    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    plugequal – Equalizer for plughw:0,0
    bluetoothspeaker – Max2Play bluetooth speaker
    default:CARD=sndrpihifiberry – snd_rpi_hifiberry_amp, – Default Audio Device
    sysdefault:CARD=sndrpihifiberry – snd_rpi_hifiberry_amp, – Default Audio Device
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    #### SHAIRPORT (SYNC) VERSION ####
    2.2.4-openssl-Avahi-ALSA-soxr
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    However I’m unable to restart Squeezelite:
    Trying to launch … NOT successful Click here to show detailed information
    [13:14:43.538497] test_open:294 playback open error: Input/output error
    [13:14:43.538945] output_init_common:381 unable to open output device

    Hopefully this may give you a clue as to the problem.

    Cheers, Paul

    • This reply was modified 2 years, 8 months ago by  Paden.
    3. April 2018 at 14:13 #34948

    Hi Paul,

    Could you get your hands on another BT speaker, to rule out a general defect in your Pi?

Viewing 30 posts - 301 through 330 (of 465 total)

You must be logged in to reply to this topic.

Register here