[NEW UPDATE] Spotify Connect Server – beta available!

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) [NEW UPDATE] Spotify Connect Server – beta available!

This topic contains 126 replies, has 36 voices, and was last updated by  Heiner Moderator 3 years, 2 months ago.

Viewing 30 posts - 61 through 90 (of 127 total)
  • 20. Mai 2017 at 14:40 #28963

    I just installed a fresh copy of Max2Play to test and……It works like a charm!!!
    GREAT WORK!!!

    Watch out though, cause when starting first time it can be very loud (so turn down your speakers at first 😉
    I use it with my digiberry DAC+ on my RPI2
    Now if it can be managed from my Raspberry Touchscreen it would be like a dream come through (for real) and combined with multiroom…well, it would bring Max2Play back on number1 for me personally..

    Anyway i can help implement this so we can use it with touchscreens? LMS is out of the windows for me then, especially if there is another way to use webradio. I would love that combo and won’t be needing more that way…

    • This reply was modified 3 years, 6 months ago by  ZeroZorro.
    21. Mai 2017 at 8:29 #28967

    Hi guys
    Been looking at this today and my sound card for squeezelite via a hifiberry is equaliser for plugin 1,0,
    But the output option in the spotify connect plug in is equal equal or plugin 0,0,

    How do I get an option that matches on both?

    Cheers

    21. Mai 2017 at 14:39 #28970

    Hi

    Plugin auf die aktuele Stable installiert, Spotify Username und Kennwort eingetragen, auf Server starten gedrückt

    „error: option ’name‘ is missing“

    Einen Namen eingetragen

    „error: Option ’name‘ given more than once.
    Usage: /opt/spotifyconnect/librespot [options]“

    auf die neuste Beta geupdatet, dasselbe Probem

    SpotifyConnect per FTP komplett entfernt (aus /opt und /opt/max2play) und die entsprechenden Einträge aus der Playerconfig entfernt und nochmal alles von vorne. Hat aber auch nix geholfen

    • This reply was modified 3 years, 6 months ago by  std.
    22. Mai 2017 at 11:10 #28987

    Hi guys,

    I’m happy you are actively testing already. And, of course, that some of you already got it running.

    To the ones with issues: Please post your debug log from the bottom of the web interface menu and detail our errors.

    @atinkler: Please check for your options in Squeezelite, they should be the same as in SpotifyConnect and you should be able to select the same output.

    @std: Please try a new image and start from the newest beta. You also require an active premium account which is the „name“ you need to enter.

    22. Mai 2017 at 19:09 #29009

    @heiner:
    Will you support mherger to get spotify connect running thru LMS (i.e. implementing spotify connect as a plugin in LMS)?
    That would be really great!

    Regards

    Rheinlaender

    22. Mai 2017 at 19:11 #29011

    Hello Heiner.

    Unfortunately they are not the same.

    Squeezelite has 0,1, and the connect client only offers 0,0

    22. Mai 2017 at 22:42 #29014

    To confirm the top options in Spotify connect are
    Equal- Equal
    Plugequal – equalizer for pluginhw:0,0,

    And in squeezelite

    Equal- Equal
    Plugequal – equalizer for pluginhw:1,0,

    23. Mai 2017 at 10:27 #29021

    @rheinlaender: It’s already happened 🙂

    We successfully tested MHerger’s new authentication for the LMS Spotify plugin and it works like a charm.

    Here is our topic on it.
    And here’s my post on the slimdevices board.

    @atinkler: Please try re-selecting your sound card (first select none, then reboot, then re-select) and rebooting.

    23. Mai 2017 at 11:28 #29026

    Ok. And by none so you mean equal equal or can I turn the whole selection off? Not near there device so be good to know for when I have access

    Cheers

    23. Mai 2017 at 12:21 #29028

    In the Raspberry Settings sound card selection, select „none“, reboot, select your card, reboot, check the sound card options again.

    23. Mai 2017 at 18:51 #29038

    Fantastic feature,trying to make it work.In my nexus 5 i can see other devices and there is my raspberry,but… in the nexus 7 no.Cant imagine help.
    Thanks for your great job.
    Solved sorry .Spotify option where not the same in both devices as i thought

    • This reply was modified 3 years, 6 months ago by  daviddepiston.
    23. Mai 2017 at 21:48 #29041

    OK i have it working which is great but the volume level is VERY VERY loud vs the output of the Hifiberry amp. Any way to set the output lower to match the Squeezelite output?

    23. Mai 2017 at 22:07 #29042

    And how rude of me… Thanks for the work here guys. Great to see a connect integration

    24. Mai 2017 at 11:28 #29045

    No problem, great to hear that it works well. We will look into the volume issue.

    Edit: We looked into it, and currently, the plugin does not support any hardware volume control: https://github.com/plietar/librespot/issues/140

    For now, you can adjust the slider of your sound card volume accordingly, before launching Spotify Connect 😉

    24. Mai 2017 at 14:09 #29055

    I got some strange behavior in the Spotify Plugin.
    For whatever reason the plugin pre-fills the command line options with the following

    –device plug:equal -C 1067oGOxNUq

    Interestingly the string 67oGOxNUq belongs to my Spotify password (changed meanwhile).
    When I delete the options and save the settings it gets re-filled again.

    Re-installing the plugin and removing associated folders via ssh does not help either.

    25. Mai 2017 at 10:20 #29061

    Great work! It works very well!

    29. Mai 2017 at 11:26 #29095

    Hi guys,
    great to hear the positive feedback! We are currently working on an official plugin page and more documentation.

    @modtastic:
    Please try a fresh image and see whether you can reproduce this error. Also, please share the debug info of the plugin. But make sure no login credentials are included in the log 😉

    31. Mai 2017 at 12:06 #29134

    First off, let me say I am very happy with Max2play. Coming from Volumio, I love both the versatility and stability. I gladly purchased a license!
    Since a couple of days, the (beta) plugin for Spotify Connect gives me an error message. I tried with three different Premium accounts within our Spotify Family subscription, all with the same result.
    Screenshot of the error message:
    Error screenshot

    It seems the issue is related to issue #185 of Librespot: https://github.com/plietar/librespot/issues/185

    Is it possible to create a new (beta) version of the plugin using the latest Librespot sources?
    And could I update Librespot myself? I can find a file „librespot“ in „/opt/spotifyconnect/“. Do I need to compile the Librespot sources, and update this file? Or would that break stuff?

    31. Mai 2017 at 16:14 #29143

    Hello there,i have got the same problem SergeR has, the only diferrence is that mine worked until i updated the spotify app.Thank you for everything.

    2. Juni 2017 at 7:19 #29185

    I played around a bit, and replacing the file „librespot“ in the folder „/opt/spotifyconnect/“ wity the latest version from https://github.com/herrernst/librespot/releases fixed the issue for me!

    2. Juni 2017 at 15:00 #29216

    Tried SergeR solution and it worked,thank you very much.

    2. Juni 2017 at 15:09 #29218

    Same for me: after replacing librespot file i have no lonver isues with disconnections anymore! Getting better and better 😉

    2. Juni 2017 at 23:54 #29221

    Spotify users with the Family plan at home will probably run into the same issue I have; only the user for whom you’ve entered the credentials in the configuration will be able to use Spotify Connect.
    For example my wife cannot even see the option for Max2play in her Spotify apps (tested on Windows and iOS). I can connect without issue.

    I’m able to somewhat reproduce the behaviour with Volumio; when entering my Spotify account’s credentials my wife cannot connect. When I leave the Spotify credentials empty, we can both connect.

    Alas, in the (beta) version of the Spotify Connect plugin for Max2play the Spotify credentials are mandatory.
    Perhaps the next version will enable to omit the credentials, so any user can connect?

    6. Juni 2017 at 12:26 #29256

    Hi guys,

    Thanks for the active discussion and feedback. We will look into the librespot update.

    @serger: The login is necessary for the Connect player to run properly. If you want the more versatile option, try the new LMS plugin by Herger that seems to be working greatly: https://www.max2play.com/en/forums/topic/new-hope-for-spotify-lms-plugin

    7. Juni 2017 at 18:28 #29348

    FYI The Plugin page is online 😉
    Link: Spotify Connect Plugin

    #YEAH

    • This reply was modified 3 years, 5 months ago by  ZeroZorro.
    8. Juni 2017 at 11:22 #29364

    Something is still wrong on my end…
    I started with a fresh image of M2P and installed the spotify connect plugin.
    Looking a the debug the authentication with spotify worked…however librespot still gives me the error Required option ’name‘ missing

    #### Librespot Output ####
    INFO:librespot: librespot 1a42c31 (2017-03-26). Built on 2017-06-05.
    INFO:librespot::session: Connecting to AP „sto3-accesspoint-a3.ap.spotify.com:4070“
    INFO:librespot::session: Authenticated as „MYUSERNAME_HERE“ !
    INFO:librespot::session: Country: „DE“
    INFO:librespot::audio_backend::alsa: Using alsa sink

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing.
    Usage: /opt/spotifyconnect/librespot [options]…

    8. Juni 2017 at 12:03 #29380

    Hi modtastic,

    Sorry about the inconvenience. We made a quick fix for some Spotify Connect issues. If you are having trouble logging in, please:
    – Update your device in Settings/Reboot and reboot it
    – Click „reinstall“ in the Spotify Connect plugin
    – Log in again with your usual credentials

    8. Juni 2017 at 12:30 #29385

    Thank you for the quick response, Heiner.

    Unfortunately I still get the same librespot error…

    8. Juni 2017 at 17:52 #29424

    Had the same issue, but deactivating after reboot, reinstalling and rebooting again did the trick for me. So Spotify Connect works again, but Spotify plugin does not at the moment cause i cant activate it anymore. Maybe it’s also blocked by Spotify like Librespot was?

    8. Juni 2017 at 21:21 #29431

    I have the same problem as Serge did in post above #29134

    I am not able to update the file he said worked for him at the moment and the reinstall doesnt seem to fix it. Is a fixed for this issue planned?

    Cheers

    EDIT – re downloaded from the site and reinstalled – after a few attempts got it working again – thanks all

    • This reply was modified 3 years, 5 months ago by  Atinkler.
Viewing 30 posts - 61 through 90 (of 127 total)

You must be logged in to reply to this topic.

Register here