[NEW UPDATE] Spotify Connect Server – beta available!

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) [NEW UPDATE] Spotify Connect Server – beta available!

This topic contains 126 replies, has 36 voices, and was last updated by  Heiner Moderator 3 years, 2 months ago.

Viewing 30 posts - 91 through 120 (of 127 total)
  • 12. Juni 2017 at 11:43 #29501

    @modtastic: Please also try reinstalling the plugin.

    @zerozorro: Did you have the same error as modtastic? Also, which Spotify plugin are you referring to? The new one by MHerger or the triode?

    12. Juni 2017 at 13:39 #29516

    You can skip/delete/strike my latest comment:
    I am so embarrassed…while testing this Spotify Connect i got 1 RPI with volumio and 1RPI with max2play setup.
    The Spotify Plugin not working (now it does) was from the Volumio team #oops
    On Max2play I prefer only Spotify Connect for now before trying to get a joined setup with Spotify Plugin (triode/Mherger)

    13. Juni 2017 at 11:32 #29530

    I have been re-installing / re-imaging multiple times now. No luck on my end.

    Going on holiday now and will check-in later.

    19. Juni 2017 at 11:21 #29596

    @modtastic: Just to be sure, please check to see whether your premium license with Spotify is still active. The plugin only works with an active premium account.

    21. Juni 2017 at 18:36 #29664

    Hello,
    When I try to install the spotify connect service, the first time I click, I get this message:
    An error occurred during the last installation attempt - Erase installation files and try again

    If I start again, the installation starts and I have this:

    Install Spotify Connect Started
    Install-Script for Spotify Connect Server
    --2017-06-21 18:33:24-- https://github.com/herrernst/librespot/releases/download/v20170605-39012ba/librespot-linux-armhf-raspberry_pi.zip
    Resolving github.com (github.com)... 192.30.253.113, 192.30.253.112
    Connecting to github.com (github.com)|192.30.253.113|:443... failed: No route to host.
    Connecting to github.com (github.com)|192.30.253.112|:443... failed: No route to host.
    Archive: /opt/max2play/cache/librespot.zip
    End-of-central-directory signature not found. Either this file is not
    a zipfile, or it constitutes one disk of a multi-part archive. In the
    latter case the central directory and zipfile comment will be found on
    the last disk(s) of this archive.
    unzip: cannot find zipfile directory in one of /opt/max2play/cache/librespot.zip or
    /opt/max2play/cache/librespot.zip.zip, and cannot find /opt/max2play/cache/librespot.zip.ZIP, period.
    chmod: cannot access ‘/opt/spotifyconnect/librespot’: No such file or directory
    finished - Now Click here to Reload Page
    
    Installation finished 
    

    An idea of ​​the problem?

    21. Juni 2017 at 20:12 #29666

    I sure do have a Premium account.

    Will continue testing in the next days…

    9. Juli 2017 at 11:58 #29859

    Nobody to guide me about my problem ?

    10. Juli 2017 at 17:52 #29876

    Hi tom,

    Sorry about the late response. Your installation was faulty, I would recommend you try using a fresh image. You can make a back-up of your current one in case it is not the source of the error. As mentioned, this plugin is still in its beta phase. Please try again if it does not work the first time.

    15. Juli 2017 at 11:14 #29919

    hello there everyone, spotify connect does not work again.Could spotify be blocking it or something? Spotty works great by the way.

    19. Juli 2017 at 15:55 #29967

    Hi david,

    We tested the plugin and did receive two faulty login requests. However, those were issues on the end of Spotify. The Login should work again now without any alterations to your setup. Please try it out and tell us what happens.

    19. Juli 2017 at 17:16 #29980

    Hi everybody,

    We now edited the plugin to accommodate any changes in librespot. To get this changed version, just:

    – Go to „Settings/Reboot“
    – Install the Spotify Connect plugin again as you did already with the URL from our website:
    http://shop.max2play.com/media/downloadable/currentversion/spotifyconnect.tar
    – Click „Reinstall“ on the Spotify Connect page
    – Reboot, you’re done! 🙂

    Anonymous
    20. Juli 2017 at 12:45 #30004

    Hallo Heiner,
    die Option „–name Myspot“ bei den Spotify-Optionen wird nicht akzeptiert.

    „Myspot“ würde dann in Spotify angezeigt werden.

    Momentan wird der Name ds Pis hier „Max2play“ angezeigt.

    … aber der ist ja eigentlich schon für Shairport vergeben.
    Mann kann dann beide Ressourcen auf dem Telefon nicht mehr so richtig auseinanderhalten.

    mfg horst

    20. Juli 2017 at 14:39 #30015

    Hallo Horst,

    Danke für die Info.

    Jedoch sollte die Spotify-Steuerung und die AirPlay-Steuerung eigentlich doch immer auf verschiedenen Programmen erfolgen, oder gibt es da eine Überschneidung?

    Anonymous
    20. Juli 2017 at 17:27 #30020

    Hallo Heiner,
    einmal kann ich unabhängig vom Abspielprogramm (Spotify oder z.B. Foobar) einstellen, wo abgespielt wird
    Spotify : Iphone / Max2play & Spotify Connect / Max2play (hier ist Euer Airplay gemeint)
    Foobar: Iphone / Max2play (hier ist Euer Airplay gemeint)

    Die normale Airplaytaste (neben BT & WLAN) findet Max2play nicht.

    Im Gerätemenü von Spotify erscheint dann: Spotify : Iphone / Max2play & Spotify Connect / ggf Spotify auf dem PC
    .. mit der Frage: Wo soll abgespielt werden ?

    Wenn man einmal bei Airplay war, geht es nicht wieder zurück usw.
    Vielleicht solltet Ihr in der WEB-Oberfläche zeigen, welcher Player gerade die Soundkarte bindet.
    .. oder man löscht nach 10 s ohne Signal die letzte Verbindung.

    mfg Horst

    22. Juli 2017 at 22:50 #30045

    I cant seem to get the Spotify Connect plugin for M2P to work. I can not see M2P in spotify app (only with airplay)

    The plugin has started correctly. I get the message on the top of the page:
    Trying to launch … successful with ID 4635

    The Debug log show the follwing:
    #### Librespot Output ####
    INFO:librespot: librespot cc9dba8 (2017-03-26). Built on 2017-07-17. Build ID: 8zQE3Bpb
    INFO:librespot::session: Connecting to AP „gew1-accesspoint-b-wwbl.ap.spotify.com:4070“
    INFO:librespot::session: Authenticated as „dongilles“ !
    INFO:librespot::session: Country: „NL“
    INFO:librespot::audio_backend::alsa: Using alsa sink

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing.
    Usage: /opt/spotifyconnect/librespot [options]

    Options:
    -c, –cache CACHE Path to a directory where files will be cached.
    –disable-audio-cache
    Disable caching of the audio data.
    -n, –name NAME Device name
    -b, –bitrate BITRATE
    Bitrate (96, 160 or 320). Defaults to 160
    –onstart PROGRAM
    Run PROGRAM when playback is about to begin.
    –onstop PROGRAM
    Run PROGRAM when playback has ended.
    -v, –verbose Enable verbose output
    -u, –username USERNAME
    Username to sign in with
    -p, –password PASSWORD
    Password
    –disable-discovery
    Disable discovery mode
    –backend BACKEND
    Audio backend to use. Use ‚?‘ to list options
    –device DEVICE Audio device to use. Use ‚?‘ to list options
    –mixer MIXER Mixer to use

    I tried giving it a other name by typing
    -n, –name test in the Command Line Options part of the plug in. But then I get an other error:

    #### Librespot Output ####
    error: Option ’name‘ given more than once.
    Usage: /opt/spotifyconnect/librespot [options]

    I am still really new to this, can someone help me?

    24. Juli 2017 at 17:29 #30101

    Hi dongilles,

    I just used a fresh install to test it again, successfully.

    Please try deactivating all other players momentarily to rule them out as sources of error.

    25. Juli 2017 at 21:03 #30155

    Got it working again, thank you Heiner and everyone who work in this.Great job.

    • This reply was modified 3 years, 4 months ago by  daviddepiston.
    27. Juli 2017 at 12:56 #30204

    Hi david,

    Thanks for the kind words, we appreciate it. 🙂

    3. August 2017 at 20:41 #30404

    Hi All,

    I tried to use the plugin but when I start a song the service stops.

    I get the error below:

    `INFO:librespot::session: Connecting to AP „gew1-accesspoint-b-f6v1.ap.spotify.com:4070“
    INFO:librespot::session: Authenticated as „username“ !
    INFO:librespot::audio_backend::alsa: Using alsa sink
    INFO:librespot::session: Country: „NL“
    INFO:librespot::player: Loading track „Red Earth & Pouring Rain“
    INFO:librespot::player: Track „Red Earth & Pouring Rain“ loaded
    librespot: pcm_params.c:170: snd1_pcm_hw_param_get_min: Assertion !snd_interval_empty(i)' failed.

    So, does someone knows what the issue is?

    I’m using an USB soundcard and that is working correctly with squeezelite.

    4. August 2017 at 10:28 #30424

    Hi Bassie,

    When using other players on this device, like Squeezelite, make sure that these players do not exclusively block or mute the sound card. Add ‚-C 10‘ to the Squeezelite commandline settings in advanced options on the Audioplayer tab, to tell Squeezelite to disconnect from the soundcard after 10 seconds if nothing is playing and make sure to remove the ‚-Q‘ option. Otherwise, the volume will be set to 0 when Squeezelite is paused.

    Make sure to ‚Disable IPv6‘ in Raspberry Pi Settings (if not disabled yet).

    4. August 2017 at 13:14 #30438

    Hi Heiner,

    I have the following line filled in the command line of squeezelite:

    -C 10 -o hw:1,0

    Because I use an USB soundcard I have to add ‚-o hw:1,0‘ and I ticked ‚use USB DAC‘.
    But do I have to add the same for this plugin?, so it knows that it has to use the USB DAC?

    Bij the connect plugin I have the standard output device selected ‚equal -equel‘.
    Should I need to change this output device?

    Thanks for your help.

    7. August 2017 at 11:15 #30465

    Hi Bassie,

    Please select the sysdefault output device in Spotify Connect. You do not have to add any command line options to the Spotify player.

    11. August 2017 at 18:55 #30575

    Hi Heiner,

    Thanks, that worked!

    Just a new question.

    When I start a song via Spotify connect, the song is starting at max sound.
    Is there away to make it start at 10% or something like that?

    Also at the lowest volume in sporify via spotify connect, the sound is to loud.
    Is there away to add more steps in the volume control?
    Or can I start the sound at lower stenght that it is now (in stead of 0-100% to 0-50% from normal)?

    Thanks in advance.

    Bassie

    14. August 2017 at 15:48 #30615

    Hi Bassie,

    We checked some possible solutions for this, but unfortunately the librespot implementation does not have a proper fix for this yet. Once there is one out there, though, we will use it right away.

    If you have a sound card with hardware volume control, you can set the default in our sound card menu to 50 %. This is currently the only way start Spotify Connect at a low volume.

    2. September 2017 at 11:27 #31083

    I made short tutorial video on my youtube channel, on how to install the plugin. I did this previously also for the Volumio Spotify connect plugin so it seemed fair to have also a video to show similar functionality in Max2play. Great to see that Max2play put so much effort in bringing this functionality also to their platform!

    So far I have tested the Spotify connect beta plugin on a raspberry pi zero (running Max2play Version Beta-170523) and a zero W (running Max2play Version 2.43) and have following issues:

    – The intial volume when you switch to max2play Spotify connect device is at max. (I understand that this a librespot issue)
    – Spotify connect devices disappearing over time, while the Spotify connect service is still running on the device. It seems that is when this
    system stay idle for some time the connection with the Spotify connect server is lost. I have checked if squeezelite was active and interfering but this was not the case. Stopping and restarting the Spotify connect service via the WebUI, resolved the issue, but is inconvenient if you just want to play something using spotify.

    4. September 2017 at 14:57 #31119

    Hi Megantonneke,

    First of all, thanks for the effort and for the detailed feedback.

    We will add the video to our Max2Play community playlist.

    We will also look into the second issue in detail and try to look for a creative solution to the first one.

    7. September 2017 at 23:17 #31186

    Hello,
    thank you for your great work on the Spotify Connect plugin! I recently switched from Volumio to Max2Play because the Max2Play Spotify Connect plugin is much more responsive in my setup. However, I would like to report/ask for your help on two minor things:

    1) In my setup the Spotify Connect player starts the selected playlist or album automatically from the beginning when it reaches the end — although no repeat function is active. Is there any way to fix this? I run the latest version of Spotify on Mac OS Sierra in case this matters.

    2) The Spotify Connect service on my Raspberry PI 3/Hifiberry DAC+ box sometimes seems to shut down when the device is not used for a day or so. It starts working again after restarting it using the web interface, but I would of course like to avoid that. Any way to fix this?

    Thanks & best regards

    Antti Autio
    Oulu, Finland

    8. September 2017 at 13:04 #31211

    Hi Antti,

    First of all, thanks for making the switch to us 🙂

    1) This is probably related to your Spotify client. Please try out whether the same issue occurs with anothr app.

    2) This is an issue that is being worked on in the librespot solution we are incorporating. You can click the reinstall button to get the latest update of librespot, however the fix is still a work in progress and some unexpected shutdowns might still occur.

    8. September 2017 at 15:21 #31213

    Hi, thank you for your quick reply!

    1) On the unexpected repeat problem: I can reproduce it with both Spotify app running on Macbook and Spotify app running on Android smartphone so probably not a Spotify client issue. Spotify autoplay setting is off in both.

    2) Thanks, I’ll update to the latest version and see what happens!

    Best regards

    Antti

    11. September 2017 at 10:55 #31255

    Can Spotify Connect be installed on an Odroid U3?

    I installed the extension then this is what I get when I try to Install and Setup the Spotify Connect Service

    Install-Script for Spotify Connect Server
    No Current Release Found! Using v20170717!
    –2017-09-11 09:44:59– https://github.com/herrernst/librespot/releases/download/v20170717-910974e/librespot-linux-armhf-raspberry_pi.zip
    Resolving github.com (github.com)… 192.30.253.112, 192.30.253.113
    Connecting to github.com (github.com)|192.30.253.112|:443… failed: No route to host.
    Connecting to github.com (github.com)|192.30.253.113|:443… failed: No route to host.
    Archive: /opt/max2play/cache/librespot.zip
    End-of-central-directory signature not found. Either this file is not
    a zipfile, or it constitutes one disk of a multi-part archive. In the
    latter case the central directory and zipfile comment will be found on
    the last disk(s) of this archive.
    unzip: cannot find zipfile directory in one of /opt/max2play/cache/librespot.zip or
    /opt/max2play/cache/librespot.zip.zip, and cannot find /opt/max2play/cache/librespot.zip.ZIP, period.
    chmod: cannot access ‘/opt/spotifyconnect/librespot’: No such file or directory
    finished – Now Click here to Reload Page

    Installation finished

Viewing 30 posts - 91 through 120 (of 127 total)

You must be logged in to reply to this topic.

Register here