Hens

Forum Replies Created

Viewing 8 posts - 1 through 8 (of 8 total)
  • Posted in:
  • 12. Januar 2017 at 18:19 #25828

    Moin Didi,
    vielen Dank für deine Antwort. Genau die Lösung teste ich seit dem Wochenende. Ich wollte hier nur keinen Erfolg vermelden, bevor ich mir nicht sicher bin. Und ich kann sagen, dass es die funtkionell beste Lösung ist, die ich bisher in Zusammenhang mit dem LMS und Spotify hatte. Bin mehr als begeistert.

    Grüße,Jens

    4. Januar 2017 at 1:04 #25448

    Bei mir im Haushalt gibt es nur ein Apple-Gerät und das ist ein defektes MacbookPro von meiner Freundin. Ich habe es gerade mal recherchiert und ich bin auf keine Möglichkeit gestoßen, die Spotify-Wiedergabe von einem ungerooteten Android-Device über Airplay an den LMS zu streamen. Daher ist die Airplay-Variante leider keine Lösung, auch wenn es durchaus attraktiv klingt. Trotzdem Danke für den Hinweis!
    Also weiter auf dem Alten Weg: Ich habe mir nun noch einmal den Logfile des Triode-Plugins angeschaut. Dieser Eintrag kommt häufig vor:
    [23:57:41.420385] log_message:81 log: 22:57:41.420 E [ap:4210] ChannelError(0, 1, playlist)
    [23:57:51.760055] log_message:81 log: 22:57:51.760 E [ap:4210] ChannelError(0, 1, playlist)
    [23:59:26.417876] log_message:81 log: 22:59:26.417 E [ap:4210] ChannelError(0, 1, playlist)
    Dummerweise kann ich damit nichts anfangen. Weiß zufällig jemand, welche Aussage dieser Eintrag im Logfile hat?

    Grüße,
    Jens

    • This reply was modified 5 years, 6 months ago by  Hens.
    3. Januar 2017 at 23:34 #25441

    Moin, danke für die Antwort. Ja, eine ähnliche Lösung schwebte mir auch schon vor, allerdings als Stream über das Bluetooth-Plugin von Max2Play. Hat die Airplay-Idee irgendwelche Vorteile?

    So ich habe in der Zwischenzeit etwas probiert und bin etwas weiter gekommen, aber eigentlich wieder da, wo ich am Anfang, als ich diesen Thread eröffnet habe auch schon war. Ich habe meinen „Mix der Woche“ in der Spotify-App aus den Playlists entfernt. Nun laden die Playlists im LMS wieder schnell. Leider findet noch immer keine Synchronisation der Playlists zwischen dem Spotify-LMS-Plugin und Spotify selbst statt. Wenn ich Playlists über den LMS verändere, wird die Veränderung nicht an Spotify weitergeben. Verändere ich eine Playlist über eine Spotify-App (Win oder Android), kommt die Veränderung nicht beim LMS an. Nur wenn ich den Ordner /var/lib/squeezeboxserver/cache/spotifycache/Users/ des LMS leere und den LMS neu starte, übernimmt er die Playlisten ein einziges Mal aus dem Spotify-Account. Danach findet dann wieder kein weiterer Abgleich statt.

    Ehrlich gesagt kann ich mir nicht vorstellen, dass ich der Einzige bin, der dieses Problem hat.

    Grüße,
    Jens

    3. Januar 2017 at 22:07 #25436

    So, nach längerer Zeit bin ich nun wieder dazu gekommen, mich mit dem Thema Max2Play und Spotify zu beschäftigen. Ich kriege es leider nicht rund zum Laufen. Das Problem ist, dass der Aufruf der Spotify-Playlists ewig dauert. Wenn ich auf „Wiedergabelisten“ unter Spotify im LMS klicke, dauert es 20-30 Sekunden, bis mir meine Playlists angezeigt werden. Wähle ich eine aus, so dauert es wieder 20-30 Sekunden, bis die Songs erscheinen.

    Ich habe vorher
    … Max2play komplett neu auf einer SD-Karte installiert, ich nutze in diesem fall einen Raspi 3.
    … Max2Play konfiguriert und den LMS 7.9 Nightly installiert
    … das Triode-Plugin installiert und die Zugangsdaten eingegeben. Der Test funktioniert wunderbar.

    Wenn ich Interpreten bei über Spotify im LMS suche, funktioniert dies auch richtg schnell und völlig problemos.

    Aber ohne die einfache Nutzung der Playlists ist die Nutzung von Spotify doch sehr eingeschränkt, da man ja auch die sonstige eigene Musikbibliothek von Spotify nicht über den LMS einsehen kann.

    Hat irgendwer eine Idee?

    Viele Grüße,
    Jens

    10. September 2016 at 13:41 #22974

    Moin Wayne23, tatsächlich nutze ich an jedem Gerät einen Stick von LogiLink. Mir ist allerdings aufgefallen, dass auch ein anderer Zusammenhang häufig zu den Verbindungsproblemen führt:
    Einige Player trenne ich nach der Benutzung vom Strom und schalte Sie bei Bedarf wieder ein (ja, mit aktiviertem SD-Karten-Schutz). Wenn diese Player mit anderen Playern zur Synchronisation gekoppelt waren, zeigten die anderen Player das Fehlerhafte verhalten, wenn ich die Musik (manchmal Tage später) wieder eingeschaltet habe. Seitdem ich alle Player immer am Stromnetz habe, taucht das Problem fast gar nicht mehr auf. Da ja auch der Raspi3 einen relativ geringen Energieverbrauch hat, kann mein ökologisches Gewissen mit dieser Lösung einigermaßen leben.
    Trotz allem kommt es ganz selten immer noch zu Problemen. Ich werde also mal darüber nachdenken, aud die Creative-Soundkarten umzusteigen. Daher vielen Dank für den Hinweis!

    Viele Grüße,
    Hens

    10. September 2016 at 13:32 #22973

    Danke für die Antwort. Auch eine komplette Neuinstalltion der gesamten SD-Karte für den LMS hat das Problem bei mir nicht gelöst. Wieder wurden die Playlists nicht synchronisiert. Ich habe dann das neuere Spotify-Plugin SpotifyFamily von Triode und Richie Zed installiert. Hier werden die Playlists synchronoisiert. Ich kann die Playlists dann allerdings nicht über Squeeze Ctrl verändern, was früher auch ging. Das muss ich nun immer über die Spotfy-App erledigen. Sobald ich Zeit habe, werde ich noch einmal das normale Triode-Plugin installieren und ausprobieren. Sollte sich etwas Neues ergeben, werde ich es hier posten.

    Grüße,
    Jens

    21. April 2016 at 23:10 #19898

    Moin,
    ich habe mehrere Pi im Netz, einer davon ein Pi3. Auf diesem habe ich das Bluetooth-Plugin installiert, dass auch relativ gut funktioniert hat, wenn man davon absieht, dass die Wiedergabe nicht wirklich synchron mit den übrigen Geräten läuft. Hier haben die Einstellungen im LMS zwar eine Verbesserung gebracht, das Problem aber nicht ganz gelöst. Nun habe ich Multisqueeze hinzuinstalliert und einen Player mit Ausgabe auf Pulse und einen mit Ausgabe auf die USB-Soundkarte eingerichtet. Auch das funktiniert ganz gut, bis auf ein Problem: Wenn ich die Bluetoothausgabe mit einem anderen Player im Netzwerk synchronisiere, beschleunigt die Wiedergabe über Bluetooth manchmal plötzlich die Wiedergabegeschwindigkeit, die Songs werden schneller. Kann man das irgendwie in den Griff bekommen, z.B. über das Feintuning zur Synchronisierung in den Einstellungen des LMS?

    21. April 2016 at 19:36 #19896

    Hallo Heiner,
    vielen Dank für die Rückmeldung. Vielleicht trifft der erste Fall zu, wobei ich mir eigentlich sicher bin, dass ich die einzelnen Player immer in der App „ausgeschaltet“ (ich meine nicht heruntergefahren) habe. Ich glaube eigentlich auch nicht, dass es an der WLAN-Verbindung liegt, denn dann sollte das Problem doch immer auftreten und nicht nur nach einer längeren Standby-Zeit, oder? Ich habe jetzt mal in den Player-Einstellungen die Streaming-Methode auf „Streaming über Proxy“ gestellt. Seitdem ist das Problem nicht mehr aufgetreten.

Viewing 8 posts - 1 through 8 (of 8 total)