bisesik

Forum Replies Created

Viewing 22 posts - 1 through 22 (of 22 total)
  • Posted in:
  • 20. Oktober 2018 at 22:45 #38709

    Not at all. All for community 🙂

    But. There is one issue with that waveshare driver. As I mentioned in another thread (about visualization plugin lost\not works), this driver leads to eth0 dissapearing after its installation. If during installation you was on the cable at that time you will be needed to connect to RPi via AP-mode or USB-keyboard, to switch to another tty (ALT+F6, for example) and continue that way to boot up the player. But the solution is simple actually: raspi-config -> 2.Network Options->N3 Network interface names predictable->No->OK->Finish->Reboot now. After that eth0 will came alive again:)
    It will be very useful if you will take it into account too within your wish to add solution for waveshare LCD as option to max2play. Thank you!

    • This reply was modified 3 years, 7 months ago by  bisesik.
    20. Oktober 2018 at 20:40 #38708

    The problem was in waveshare 3.5 LCD. After installation of drivers from waveshare.com, eth0 interface dissapears. I got error: „Cannot open access to console, the root account is locked. See sulogin(8) man page for more details. Press Enter to continue“ because there was no eth0 in system after driver installation. BTW – it is very often error related with this waveshare LCD. The problem was in waveshare 3.5 LCD. After installation of drivers from waveshare.com, eth0 interface dissapears. I got error on OS initiate: „Cannot open access to console, the root account is locked. See sulogin(8) man page for more details. Press Enter to continue“, as I understand, it happens because there was no eth0 in system after driver installation. BTW – it is very often error related with this waveshare LCD.
    „raspi-config / network name alias NO“ – fix it.

    May be raspi-config / „desktop autologin“ is really a necessary step when installing this driver, which I have neglected? I skipping this very first step every time. Apparently in vain. Need to check…

    19. Oktober 2018 at 20:17 #38704

    after new installation I see that visualization works normal from eth0…

    19. Oktober 2018 at 17:51 #38702

    Honestly, I have never seen that Visualization works while connecting through eth0 (wlan disabled). I do not know how exactly but apparently these things has some hidden interrelation?..

    • This reply was modified 3 years, 7 months ago by  bisesik.
    19. Oktober 2018 at 13:06 #38698

    /etc/network/interfaces changed manually, after no sucess through web-interface.

    Have done as you said, no sucess – no visualizations, radio works

    https://ibb.co/bsYm6L
    https://ibb.co/cikG6L

    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback

    #auto eth0 # managed by ifplugd
    iface eth0 inet static
    address 192.168.0.50
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    #hwaddress ether 1a:64:b6:bf:36:37

    #allow-hotplug wlan0
    #auto wlan0
    iface wlan0 inet static
    address 192.168.0.51
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    netmask 255.255.255.0
    #pre-up wpa_supplicant -B w -D wext -i wlan0 -c /opt/max2play/wpa_supplicant.conf
    #post-down killall -q wpa_supplicant

    • This reply was modified 3 years, 7 months ago by  bisesik.
    19. Oktober 2018 at 5:20 #38685

    Hello Heiner.
    My config is on RPi3B and 3.5LCD.
    Can you help to figure out why visualization stops showing if I use LAN instead of WLAN (no matter dhcp or static)?

    Once I connect RJ45 to RPi, after rebooting visualization stops showing.

    etc/network/interfaces stays unchangeable in both situations:

    ####################################################
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback

    #auto eth0 # managed by ifplugd
    iface eth0 inet static
    address 192.168.0.50
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    #hwaddress ether 1a:64:b6:bf:36:37

    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet static
    address 192.168.0.51
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    netmask 255.255.255.0
    pre-up wpa_supplicant -B w -D wext -i wlan0 -c /opt/max2play/wpa_supplicant.conf
    post-down killall -q wpa_supplicant
    ##########################################

    I showed the simplest situation without any additional changes. But my goal is to use static LAN only without wlan at all. But once I unchecking „Load WiFi interface“ – it goes to losting both „visualizations“. Internet radio works, but visualizations gone.

    17. Oktober 2018 at 14:09 #38661

    Hello, Heiner. Seems, that you see something different than me.

    Now I see this
    https://ibb.co/jtNQVf
    Yesterday my post was here, but after editing it is gone.
    But there was this one:
    Hello.

    I have done it right now (based on m2p_stretch_rpi_245.img). Steps are included driver installation for Sharewave 3.5 LCD (I have bought this one: https://www.aliexpress.com/item/for-Raspberry-Pi-3-Model-B-3-5-Inches-Touch-Screen-Display-Monitor-480×320-LCD-Kit/32837597848.html )

    $ wget https://www.waveshare.com/w/upload/1/1e/LCD-show-180817.tar.gz
    $ tar xvf LCD-show-180817.tar.gz
    $ cd LCD-show
    $ chmod +x LCD35-show
    $ ./LCD35-show

    #after installing of packages and automatic rebooting LCD works, but it is needed to change Driver#

    $ sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf
    #replace the line Driver „fbturbo“ with Driver „fbdev“, then ctrl+o, ctrl=x#
    $ sudo reboot

    #After that desktop\jivelite should work#

    Regarding jivelite skin for 480×320 resolution:

    $ cd /opt/jivelite/jivelite/share/jive/applets/SetupWallpaper
    $ sudo rm SetupWallpaperApplet.lua
    $ sudo rm SetupWallpaperMeta.lua
    $ sudo rm strings.txt
    $ sudo wget https://github.com/ralph-irving/jivelite/raw/master/share/jive/applets/SetupWallpaper/SetupWallpaperApplet.lua
    $ sudo wget https://github.com/ralph-irving/jivelite/raw/master/share/jive/applets/SetupWallpaper/SetupWallpaperMeta.lua
    $ sudo wget https://github.com/ralph-irving/jivelite/raw/master/share/jive/applets/SetupWallpaper/strings.txt
    $ sudo mkdir /tempimage
    $ cd
    $ sudo wget http://downloads.sourceforge.net/project/picoreplayer/beta/pcp-jivelite_wav35skin.tcz
    $ sudo mount -o loop pcp-jivelite_wav35skin.tcz /tempimage
    $ cd /tempimage/opt/jivelite/share/jive
    $ sudo cp -a applets /opt/jivelite/jivelite/share/jive/
    $ sudo reboot

    #After that you can choose „WAV 3.5 in LCD Skin“ in Settings\Screen\Select Skin #

    • This reply was modified 3 years, 7 months ago by  bisesik.
    17. Oktober 2018 at 10:29 #38653

    where is my post???

    30. Mai 2018 at 14:31 #35976

    There are grounds to consider that wifi (and its powering) is a source of unnecessary interference, affecting the sound quality. Well, and secondly, there is a desire to shove the rpi with LCD into the metal case along with the DAC and use it exclusively locally (as a regular CDP, you know..) but if it is needed – to have possibility of RJ45 connection. Well all I need\want is to have a hard solution without a network especially wifi. I understand that the easiest way is to configure it firstly through web-interface, but after that to set it without lan\wlan. That is why… Can you help and say what exactly should I config beforehand. I can access to rpi (terminal) directly with KB\Mouse. The main problem now for me is that jivelite (LMS) not see the player\library. I have read here ( https://www.max2play.com/en/forums/topic/configuring-jivelite-and-squeezebox-on-a-raspberry-pi-3-without-external-network/ ) that I need to add the remote library in LMS as 127.0.0.1 and to edit /etc/hosts somehow. But what exactly should be done – I don’t know for sure. Can you help with it? Thx.

    • This reply was modified 3 years, 12 months ago by  bisesik.
    • This reply was modified 3 years, 12 months ago by  bisesik.
    29. Mai 2018 at 16:33 #35961

    Thank you Heiner. I know about AP-mode, but is it possible to avoid wlan and lan at all?

    24. Mai 2018 at 10:51 #35857

    Have tried. No success, Error „/etc/rc.local Compatibility“ occurs even with two separate PSUs ([email protected][email protected])

    24. Mai 2018 at 10:47 #35856

    Hi Heiner
    That error occurs even when LCD display is connected only. I think, PSU is good enough ([email protected]). But I will try to power LCD from its separate microUSB, will post later.

    BTW, how to attach img file from my PC here?

    16. Mai 2018 at 21:45 #35731

    Well… After installing of LCD_driver, this error came back. However it not takes much time and occurs before jivelite for less than a second. It is very strange though, but the booting time is ok anyway now.

    16. Mai 2018 at 18:54 #35729

    Just tried to do it again from scratch (new installation) and got the „Right“ messages like you shown!
    For statistics: have changed internet channel to fast one (My Android-phone with LTE used as AP for max2play).
    Error is gone, will try to configure the whole system according my needs again and will post here later…

    • This reply was modified 4 years ago by  bisesik.
    16. Mai 2018 at 15:33 #35726

    This error occur only after I enabling USB sound card.

    Everytime I got this messages after installation (yellow text):

    This installer for USB-Hiface Soundcards installs the latest Kernel official Kernel with Kernel Headers, compiles a modified module and sets this module (snd-usb-hiface) to autostart – this might take a while…

    Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
    Reading package lists…
    make -C /lib/modules/4.14.24-v7+/build SUBDIRS=/opt/snd-usb-asyncaudio modules
    Makefile:8: recipe for target ‚default‘ failed
    finished – reboot needed!

    What should I try?..

    15. Mai 2018 at 19:49 #35712

    Well, again.
    Today I repeated from scratch. During all the process of installation none of any USB devices was plugged to rpi at all.
    My steps was next:
    1. Burning of „m2p_stretch_rpi_245.img“ through Win32DiskImager to micro SD card.
    2. Connection to WiFi Access Point with SSID „max2play“
    Configuration through web-interface:
    3. Load WiFi interface (indicated my home SSID).
    4. Raspberry settings -> Choose Soundcard to load on boot (device tree overlay)-> USB Soundcards (Northsta…)->save
    5. Settings/Reboot -> reboot
    And again I am getting similar error during every booting after:

    I think this is some kind of global issue and will be repeated on the same rpi3B+m2p_2.45?..

    p.s. Later I have enebled Jivelite and Squeezebox Server, but nothing changed anyway of course with that error (etc/rc.local Compatibility). After that I have tried apt –fix-broken install and apt-get upgrade\update – no success too

    • This reply was modified 4 years ago by  bisesik.
    14. Mai 2018 at 19:17 #35684

    Sorry, I meant… it was after re-install and before I have chosen USB DAC in the settings.

    14. Mai 2018 at 13:44 #35670

    As I mentioned in my 3-rd message here, even without any USB plugged into Rpi – the same problem, that is why I guess it is not kind of powering issue…

    14. Mai 2018 at 11:31 #35665

    Heiner, population Survey is the most efficient way, agree! 🙂
    But what about main problem I have till now (first message)? What file exactly should I check and show to help you eliminate my problem?
    Thx!

    9. Mai 2018 at 17:54 #35635

    The reason is very simple – to make the whole system more professional look like. From the very starting of the system initialization all I need is just to see what I really need without unnecessary screens\text\desktop\etc. Push the button, wait some time (some logo during booting is OK though) and see working place – Jivelite. I guess it is the understandable wish for… The Meloman, for examle. Or is there no point in such willing? 🙂

    9. Mai 2018 at 11:23 #35614

    Tried again. No success. The same problem even without DAC plugged in rpi3B. Step between OK and Problem is:
    Raspberry settings->USB Soundcards…->save->reboot

    • This reply was modified 4 years ago by  bisesik.
    8. Mai 2018 at 12:48 #35587

    Hi Heiner,

    I am using Rpi3B and 2.45. I re-installed m2p, without external DAC it works as it should without falls. I will try your recomendations regarding separate powering of USB DAC, I will report later.
    BTW, is it possible somehow to prevent desktop showing on starting and after booting text on next step show Jivelite immediately without desktop picture?
    p.s. I have tried some hints and have hide booting text at all – there was three „running“ points only in the center of screen before desktop shows up, but I want to skip desktop after that and to show Jivelite immediatelly. Can you give me… I don’t know… some url about it or may be you know the exact solution? Thank you!

Viewing 22 posts - 1 through 22 (of 22 total)