Visualisations not working?

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Visualisations not working?

This topic contains 11 replies, has 4 voices, and was last updated by  bisesik premium 1 year, 11 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 18. Mai 2017 at 12:23 #28912

    OK, I have this fantastic max2play working on a pi3 with a rpi 7 display and Allo boss dac.
    All working well. I have an issue with the Visualisations, they appear, but do not move or modulate to the audio. Any thoughts, I have also done a clean install..

    I welcome any help

    David

    18. Mai 2017 at 12:40 #28915

    Hi mrfunk,

    Have you enabled the Visualizer and VU-Meter in Jivelite by adding „-v“ to the command line options of Squeezelite (Audioplayer tab of Max2Play-Webinterface -> Advanced Settings) ?

    Best Regards,
    Mohammad Mbydeen

    18. Mai 2017 at 13:19 #28917

    Yes, must be enabled, as they appear?

    22. Mai 2017 at 11:39 #28992

    Hi mrfunk,

    You may need to rest Jivelite settings, please have a look on the below thread:

    https://www.max2play.com/en/forums/topic/visualisations-in-jivelite/#post-20905

    Best Regards,
    Mohammad Mbydeen

    28. Mai 2017 at 1:09 #29084

    I tried the reset , still not working.

    here is where I have put the „-v“
    -o hw:CARD=BossDAC -V Digital -a 80:4:-v::

    7. Juni 2017 at 12:16 #29327

    Hi mrfunk,

    Sorry about the late reply.

    The end of your parameter line might be the issue. Please try this command line instead (verbatim):

    -o hw:CARD=BossDAC -V Digital -v

    19. Oktober 2018 at 5:20 #38685

    Hello Heiner.
    My config is on RPi3B and 3.5LCD.
    Can you help to figure out why visualization stops showing if I use LAN instead of WLAN (no matter dhcp or static)?

    Once I connect RJ45 to RPi, after rebooting visualization stops showing.

    etc/network/interfaces stays unchangeable in both situations:

    ####################################################
    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback

    #auto eth0 # managed by ifplugd
    iface eth0 inet static
    address 192.168.0.50
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    #hwaddress ether 1a:64:b6:bf:36:37

    allow-hotplug wlan0
    auto wlan0
    iface wlan0 inet static
    address 192.168.0.51
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    netmask 255.255.255.0
    pre-up wpa_supplicant -B w -D wext -i wlan0 -c /opt/max2play/wpa_supplicant.conf
    post-down killall -q wpa_supplicant
    ##########################################

    I showed the simplest situation without any additional changes. But my goal is to use static LAN only without wlan at all. But once I unchecking „Load WiFi interface“ – it goes to losting both „visualizations“. Internet radio works, but visualizations gone.

    19. Oktober 2018 at 9:58 #38688

    Hi bisesik,

    Did you manually edit any config files or make any other extraordinary changes to Max2Play?

    Have you tried removing autostart from Jivelite, removing autostart from WiFi interface, deleting your SSID and PW, saving and rebooting with ethernet connected?

    19. Oktober 2018 at 13:06 #38698

    /etc/network/interfaces changed manually, after no sucess through web-interface.

    Have done as you said, no sucess – no visualizations, radio works

    https://ibb.co/bsYm6L
    https://ibb.co/cikG6L

    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback

    #auto eth0 # managed by ifplugd
    iface eth0 inet static
    address 192.168.0.50
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    #hwaddress ether 1a:64:b6:bf:36:37

    #allow-hotplug wlan0
    #auto wlan0
    iface wlan0 inet static
    address 192.168.0.51
    gateway 192.168.0.1
    dns-nameservers 192.168.0.1
    dns-nameservers 8.8.8.8
    netmask 255.255.255.0
    #pre-up wpa_supplicant -B w -D wext -i wlan0 -c /opt/max2play/wpa_supplicant.conf
    #post-down killall -q wpa_supplicant

    • This reply was modified 1 year, 11 months ago by  bisesik.
    19. Oktober 2018 at 17:51 #38702

    Honestly, I have never seen that Visualization works while connecting through eth0 (wlan disabled). I do not know how exactly but apparently these things has some hidden interrelation?..

    • This reply was modified 1 year, 11 months ago by  bisesik.
    19. Oktober 2018 at 20:17 #38704

    after new installation I see that visualization works normal from eth0…

    20. Oktober 2018 at 20:40 #38708

    The problem was in waveshare 3.5 LCD. After installation of drivers from waveshare.com, eth0 interface dissapears. I got error: „Cannot open access to console, the root account is locked. See sulogin(8) man page for more details. Press Enter to continue“ because there was no eth0 in system after driver installation. BTW – it is very often error related with this waveshare LCD. The problem was in waveshare 3.5 LCD. After installation of drivers from waveshare.com, eth0 interface dissapears. I got error on OS initiate: „Cannot open access to console, the root account is locked. See sulogin(8) man page for more details. Press Enter to continue“, as I understand, it happens because there was no eth0 in system after driver installation. BTW – it is very often error related with this waveshare LCD.
    „raspi-config / network name alias NO“ – fix it.

    May be raspi-config / „desktop autologin“ is really a necessary step when installing this driver, which I have neglected? I skipping this very first step every time. Apparently in vain. Need to check…

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here