Jivelite freezes…

This topic contains 20 replies, has 2 voices, and was last updated by  Heiner Moderator 4 months, 3 weeks ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • 6. Mai 2018 at 9:37 #35523

    Hi, guys. I have a problem – the system is freezes on the second minute after booting for a minute, then jivelite is available again.
    I am using external USB DAC (this one: http://jlsounds.com/i2soverusb.html)
    To better explain problem, please see my video (freezes on 1:01) : https://www.youtube.com/watch?v=6vEyZaWYS18

    Thank you in advance, Ivan.

    8. Mai 2018 at 10:14 #35571

    Hi Ivan,

    Which Pi and what version of Max2Play are you using? If the USB DAC has a high power consumption, please consider running it on a powered USB HUB to rule out insufficient power as a source of error. Try removing the DAC and booting the system without to make sure this is not the case.

    8. Mai 2018 at 12:48 #35587

    Hi Heiner,

    I am using Rpi3B and 2.45. I re-installed m2p, without external DAC it works as it should without falls. I will try your recomendations regarding separate powering of USB DAC, I will report later.
    BTW, is it possible somehow to prevent desktop showing on starting and after booting text on next step show Jivelite immediately without desktop picture?
    p.s. I have tried some hints and have hide booting text at all – there was three „running“ points only in the center of screen before desktop shows up, but I want to skip desktop after that and to show Jivelite immediatelly. Can you give me… I don’t know… some url about it or may be you know the exact solution? Thank you!

    9. Mai 2018 at 11:23 #35614

    Tried again. No success. The same problem even without DAC plugged in rpi3B. Step between OK and Problem is:
    Raspberry settings->USB Soundcards…->save->reboot

    • This reply was modified 5 months, 1 week ago by  bisesik.
    9. Mai 2018 at 12:22 #35619

    Hi bisesik,

    I do not think this is easily possible as Jivelite is built to work in the framework of this desktop output.

    What reasons are there for this tweak?

    9. Mai 2018 at 17:54 #35635

    The reason is very simple – to make the whole system more professional look like. From the very starting of the system initialization all I need is just to see what I really need without unnecessary screens\text\desktop\etc. Push the button, wait some time (some logo during booting is OK though) and see working place – Jivelite. I guess it is the understandable wish for… The Meloman, for examle. Or is there no point in such willing? 🙂

    14. Mai 2018 at 10:05 #35662

    Hi bisesik,

    If this is a development request, you can post it in our development forum and if other people agree with you and also want this feature, we will look into possible solutions.

    14. Mai 2018 at 11:31 #35665

    Heiner, population Survey is the most efficient way, agree! 🙂
    But what about main problem I have till now (first message)? What file exactly should I check and show to help you eliminate my problem?
    Thx!

    14. Mai 2018 at 13:32 #35669

    Did the powered USB HUB not solve the problem?

    14. Mai 2018 at 13:44 #35670

    As I mentioned in my 3-rd message here, even without any USB plugged into Rpi – the same problem, that is why I guess it is not kind of powering issue…

    14. Mai 2018 at 16:12 #35676

    However, in your second post you wrote without external DAC it works as it should without falls

    14. Mai 2018 at 19:17 #35684

    Sorry, I meant… it was after re-install and before I have chosen USB DAC in the settings.

    15. Mai 2018 at 19:49 #35712

    Well, again.
    Today I repeated from scratch. During all the process of installation none of any USB devices was plugged to rpi at all.
    My steps was next:
    1. Burning of „m2p_stretch_rpi_245.img“ through Win32DiskImager to micro SD card.
    2. Connection to WiFi Access Point with SSID „max2play“
    Configuration through web-interface:
    3. Load WiFi interface (indicated my home SSID).
    4. Raspberry settings -> Choose Soundcard to load on boot (device tree overlay)-> USB Soundcards (Northsta…)->save
    5. Settings/Reboot -> reboot
    And again I am getting similar error during every booting after:

    I think this is some kind of global issue and will be repeated on the same rpi3B+m2p_2.45?..

    p.s. Later I have enebled Jivelite and Squeezebox Server, but nothing changed anyway of course with that error (etc/rc.local Compatibility). After that I have tried apt –fix-broken install and apt-get upgrade\update – no success too

    • This reply was modified 5 months ago by  bisesik.
    16. Mai 2018 at 14:02 #35720

    Hi bisesik,

    Did the error occur before you selected USB sound card as well?

    Also, did you get the following yellow text after waiting approx. 5 min. of installation:

    This installer for USB-Hiface Soundcards installs the latest Kernel official Kernel with Kernel Headers, compiles a modified module and sets this module (snd-usb-hiface) to autostart – this might take a while…

    ….
    …..
    (Reading database … 100%
    (Reading database … 78651 files and directories currently installed.)
    Preparing to unpack …/raspberrypi-kernel-headers_1.20180417-1_armhf.deb …
    Unpacking raspberrypi-kernel-headers (1.20180417-1) …
    Setting up raspberrypi-kernel-headers (1.20180417-1) …
    make -C /lib/modules/4.14.24-v7+/build SUBDIRS=/opt/snd-usb-asyncaudio modules
    make[1]: Entering directory ‚/usr/src/linux-headers-4.14.34-v7+‘
    CC [M] /opt/snd-usb-asyncaudio/chip.o
    CC [M] /opt/snd-usb-asyncaudio/pcm.o
    LD [M] /opt/snd-usb-asyncaudio/snd-usb-hiface.o
    Building modules, stage 2.
    MODPOST 1 modules
    CC /opt/snd-usb-asyncaudio/snd-usb-hiface.mod.o
    LD [M] /opt/snd-usb-asyncaudio/snd-usb-hiface.ko
    make[1]: Leaving directory ‚/usr/src/linux-headers-4.14.34-v7+‘
    finished – reboot needed!

    16. Mai 2018 at 15:33 #35726

    This error occur only after I enabling USB sound card.

    Everytime I got this messages after installation (yellow text):

    This installer for USB-Hiface Soundcards installs the latest Kernel official Kernel with Kernel Headers, compiles a modified module and sets this module (snd-usb-hiface) to autostart – this might take a while…

    Hit:1 http://mirrordirector.raspbian.org/raspbian stretch InRelease
    Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
    Reading package lists…
    make -C /lib/modules/4.14.24-v7+/build SUBDIRS=/opt/snd-usb-asyncaudio modules
    Makefile:8: recipe for target ‚default‘ failed
    finished – reboot needed!

    What should I try?..

    16. Mai 2018 at 18:54 #35729

    Just tried to do it again from scratch (new installation) and got the „Right“ messages like you shown!
    For statistics: have changed internet channel to fast one (My Android-phone with LTE used as AP for max2play).
    Error is gone, will try to configure the whole system according my needs again and will post here later…

    • This reply was modified 5 months ago by  bisesik.
    16. Mai 2018 at 21:45 #35731

    Well… After installing of LCD_driver, this error came back. However it not takes much time and occurs before jivelite for less than a second. It is very strange though, but the booting time is ok anyway now.

    24. Mai 2018 at 10:33 #35847

    Hi bisek,

    What power supply are you using and what other devices are connected to your Pi? This might be a power issue.

    24. Mai 2018 at 10:47 #35856

    Hi Heiner
    That error occurs even when LCD display is connected only. I think, PSU is good enough ([email protected]). But I will try to power LCD from its separate microUSB, will post later.

    BTW, how to attach img file from my PC here?

    24. Mai 2018 at 10:51 #35857

    Have tried. No success, Error „/etc/rc.local Compatibility“ occurs even with two separate PSUs ([email protected][email protected])

    25. Mai 2018 at 14:08 #35883

    Hi bisesik,

    The error is inconsequential and should not impede on your system and especially not on Jivelite.

    Please try putting out Jivelite on another screen to make sure this is a global error with your installation.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.

Register here