atmfrank

Forum Replies Created

Viewing 8 posts - 1 through 8 (of 8 total)
  • Posted in:
  • 24. Februar 2020 at 4:06 #48062

    I pretty much gave up on the GMusic plugin in 2018. Version 0.6 worked temporarily, but 0.7.1 is still broken. I am running the latest LMS on Max2Play Debian. Looks like it doesn’t want to compile, so it’s possible the plugin code is faulty. I followed all the steps posted here and in the README.md from the distro several times. This is what I get consistently:

    [20-02-23 20:00:17.4251] main::init (387) Starting Logitech Media Server (v7.9.3, 1580910396, Thu Feb 6 04:14:58 CET 2020) perl 5.024001 – arm-linux-gnueabihf-thread-multi-64int
    [20-02-23 20:00:18.8487] Slim::bootstrap::tryModuleLoad (285) Warning: Module [Plugins::GoogleMusic::Plugin] failed to load:
    Error — py_eval raised an exception at /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1/Inline/Python.pm line 177.
    BEGIN failed–compilation aborted at /usr/share/squeezeboxserver/Plugins/GoogleMusic/GoogleAPI.pm line 74.
    Compilation failed in require at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Settings.pm line 20.
    BEGIN failed–compilation aborted at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Settings.pm line 20.
    Compilation failed in require at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Plugin.pm line 24.
    BEGIN failed–compilation aborted at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Plugin.pm line 24.
    Compilation failed in require at (eval 892) line 1.
    BEGIN failed–compilation aborted at (eval 892) line 1.

    18. Juli 2019 at 6:42 #46353

    Hello Heiner.

    There is a read option, but on a Windows machine, it will only read the contents of /boot and not the content of / which is actually the more interesting part.

    Getting back to using the „Imageburner“ plugin, it’s confusing as hell and doesn’t seem to achieve what I like to accomplish.
    I like to be able to create an exact clone of the /boot and / partitions and be able to boot the exact same image from that cloned SD.
    Using the SD Imager plugin and creating an „image copy“ on a spare SD results in nothing more than a kernel panic because it can’t mount /.

    Will it be able to do that and if so, how?

    Best greetings, -frank

    17. Juli 2019 at 6:19 #46337

    What am I missing here? WinDiskImager 1.0 doesn’t read anything. It only wants to write an image file to a disk/SD card, not the other way around.

    thx

    16. Dezember 2018 at 3:26 #42772

    Hey Guys.
    Same problem here, or new a problem. I see repeat entries:

    Starting Squeeze2cast: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CastBridge/Bin/squeeze2cast-armv6hf -Z -I -f /var/log/squeezeboxserver/castbridge.log -x /var/lib/squeezeboxserver/prefs/castbridge.xml

    Retarting Squeeze2cast after crash: /var/lib/squeezeboxserver/cache/InstalledPlugins/Plugins/CastBridge/Bin/squeeze2cast-armv6hf -Z -I -f /var/log/squeezeboxserver/castbridge.log -x /var/lib/squeezeboxserver/prefs/castbridge.xml

    Squeeze2cast also doesn’t create castbridge.xml. Tried various options from the Logitech Squeezebox forum (phillipe_44).
    Running latest OS provided by M2P, Logitech Media Server Version: 7.9.2 – 1544453860, Chromecast Bridge (v 1.7.4). I also tried 1.7.5 from the repo.

    Checked permissions, which seem to be correct.

    Any thoughts what might be going on?

    29. Oktober 2018 at 19:19 #41750

    Hallo Heiner und Team.

    Here is some more information, I have a working installation of LMS 7.92 and GMusic plugin vers. 0.60, which I installed earlier from the external repo and not via the „special plugin“ method. Vers. 0.60 remains at this version and doesn’t auto-update. The problem is from a fresh install of M2P/LMS/GMusic, which shows up as vers. 0.70 as the only option. I had a hard time finding the older 0.60 version, using known repos for a manual install.

    The working installation is on a RPI3B (Allo DigiOne) and the failing is on a RPI3B+ (Allo Piano 2.1). Unsure if that matters or not.

    Gute Arbeit und viele Grüße, -frank

    28. Oktober 2018 at 20:04 #41737

    Hey Guys.

    Followed all the instructions here. Beta version M2P, LMS 7.9 nightly, special GMusic plugin install. Result is negative (from the LMS log file):

    Can’t locate Inline.pm in @INC (you may need to install the Inline module) (@INC contains: /var/lib/squeezeboxserver/cache/InstalledPlugins /usr/share/squeezeboxserver/CPAN/arch/5.24/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.24/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/5.24.1/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.24.1/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/5.24/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.24/arm-linux-gnueabihf-thread-multi-64int/auto /usr/share/squeezeboxserver/CPAN/arch/arm-linux-gnueabihf-thread-multi-64int /usr/share/squeezeboxserver/CPAN/arch/5.24 /usr/share/squeezeboxserver/lib /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/share/squeezeboxserver/CPAN /usr/share/squeezeboxserver /usr/sbin /etc/perl /usr/local/lib/arm-linux-gnueabihf/perl/5.24.1 /usr/local/share/perl/5.24.1 /usr/lib/arm-linux-gnueabihf/perl5/5.24 /usr/share/perl5 /usr/lib/arm-linux-gnueabihf/perl/5.24 /usr/share/perl/5.24 /usr/local/lib/site_perl /usr/lib/arm-linux-gnueabihf/perl-base) at /usr/share/squeezeboxserver/Plugins/GoogleMusic/GoogleAPI.pm line 73.
    BEGIN failed–compilation aborted at /usr/share/squeezeboxserver/Plugins/GoogleMusic/GoogleAPI.pm line 73.
    Compilation failed in require at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Settings.pm line 20.
    BEGIN failed–compilation aborted at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Settings.pm line 20.
    Compilation failed in require at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Plugin.pm line 24.
    BEGIN failed–compilation aborted at /usr/share/squeezeboxserver/Plugins/GoogleMusic/Plugin.pm line 24.
    Compilation failed in require at (eval 806) line 1.
    BEGIN failed–compilation aborted at (eval 806) line 1.

    [18-10-28 10:56:39.1718] Slim::Utils::PluginManager::load (323) Error: Couldn’t load Plugins::GoogleMusic::Plugin

    10. Mai 2017 at 4:10 #28773

    Hallo Mohammad.

    I followed your advice and put a little trust in the M2P team. Have to say, you folks have figured out a few things. I got the Google Music part working now, but only after I did a complete re-install of the LMS server and plugin. No, I didn’t use a 3rd party plugin before. After the re-install, I signed in again to Google Music with my credentials and a registered Google ID. Helpful to know that you need to use the „Google Framework ID“ as presented by the „Device ID“ Android app.

    Remaining issues:

    1) LMS server is binding itself to the wlan0 interface. Why? I have both eth0 and wlan0 running. Right now, LMS is skipping the music stream like crazy. When I stop the stream, network buffering seems to catch up and play the stream cleanly for 2-3 minutes before it starts stuttering again. Very annoying. I know I can shut down wlan0 and restart LMS, which is what I will start next. Hope to have LMS bind to eth0 and see if that stops the stuttering. Either way, my wifi connection at home is excellent, so I think something else is the problem.

    (edited): skipping continues with LMS bound to eth0. So it’s not a network interface problem. Appears to be happening with G Music streams and with the local library and NAS streams, but it took 6-7 minutes for the NAS stream to start skipping.

    2) Sampling rate remains at 44.1 kHz, no matter what I try. I opted for the CLI option -r 192000 under „Advanced Edit“ in the Squeezelite configuration and the tried the LMS setting in Player/Audio/Bitrate Limiting = 192000. Neither option produces 192000. My DAC handles 384kHz PCM if needed, but I’ll be happy with 192k.

    If you have a recommendation on these two issues….that would be great.

    Beste Grüße, -frank

    • This reply was modified 3 years, 6 months ago by  atmfrank.
    • This reply was modified 3 years, 6 months ago by  atmfrank.
    • This reply was modified 3 years, 6 months ago by  atmfrank.
    7. Mai 2017 at 4:18 #28737

    Here is an update:

    Rebooted several times, enabled Squeezelite. In LMS under Player I now see max2play and Squeezeplay. The library scanner for the CIFS mount is also doing it’s job now. Songs appear to be streaming now, I see activity on the DAC (PCM 44.1K sampling) and I get sound for stream from the local library and Radio. Was another reboot the cause why things are working now? Is there a way to set the Digi+ Pro to 24/192khz?

    Google Music remains problematic. I see the same repeat errors in the log files:

    Error 403

    \n\n\n‘) at line 2
    [17-05-06 20:07:33.1803] Plugins::GoogleMusic::ProtocolHandler::getNextTrack (103) Looking up stream url for url googlemusic:track:15e6ffba-04f4-3849-b3d7-9f623bd48abe failed: CallFailure: GetStreamUrl: 403 Client Error: Forbidden
    (requests kwargs: {u’url‘: u’https://android.clients.google.com/music/mplay‘, u’headers‘: {u’X-Device-ID‘: ‚max2play‘, u’Authorization‘: u“}, u’allow_redirects‘: False, u’params‘: {u’opt‘: u’hi‘, u’songid‘: u’15e6ffba-04f4-3849-b3d7-9f623bd48abe‘, u’pt‘: u’e‘, u’slt‘: ‚1494126452965‘, u’sig‘: ‚t-PBtEy_gSvBKai3x34MnoGh8Go‘, u’hl‘: u’en_US‘, u’tier‘: u’aa‘, u’net‘: u’mob‘}, u’method‘: u’GET‘})
    (response was: u’\n\n\n\n\n
    Forbidden

    \n

    • This reply was modified 3 years, 6 months ago by  atmfrank.
Viewing 8 posts - 1 through 8 (of 8 total)