[SOLVED] Google Music Plugin Failed to Load

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Google Music Plugin Failed to Load

Tagged: 

This topic contains 17 replies, has 5 voices, and was last updated by  Heiner Moderator 5 months ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • 17. Dezember 2016 at 17:04 #24959

    I got my Squeezebox server up and running and had max2play install the Google Music plug in. It went thru and did its thing, but when I look at the plugins in my Squeezebox settings it says the Google Music plugin failed to load. Anyone have a guide as to how to set this up?

    17. Dezember 2016 at 19:28 #24960

    Ok say I found the issue with installing it and it will now load, but it won’t let me log in. It keeps telling me I have a bad username and password. I’ve tried following other post from over a year ago, but either I’m missing something or they no longer work. Anyone else have the Google Music plugin running that could give me hand?

    18. Dezember 2016 at 14:18 #24968

    Hi

    It keeps telling me I have a bad username and password.

    the same here. After Reboot the SBS, new load the Browserinterface it works. But only with email-address, not with Usernae
    Also I must enter the phone-ID manually

    Sorry for my bad english

    6. Januar 2017 at 15:42 #25611

    Hi nick and std,
    We tried to point the necessity of an active phone-ID out in the installation yellow text of the plugin. It is a requirement for the login to work.

    I might make another How-To on exactly the steps you have to take to activate the plugin in the future. Thanks for your feedback.

    22. November 2018 at 12:09 #42205

    Sorry for bringing up an old thread.

    Nick295 how did you resolve the ‚failed to load‘ issue in the squeezebox server as I have the same issue?

    22. November 2018 at 15:53 #42206

    Hi lew-hand,

    When did you install the plugin and which Pi are you using?

    Please try installing the plugin again.

    22. November 2018 at 22:58 #42207

    Hi Heiner

    I initially installed it a while back and just come back to it.

    How do I actually uninstall the plugin?

    Its a Pi 2, I’ve updated the Pi packages and updated to the latest LMS nightly

    23. November 2018 at 10:42 #42210

    Hi lew-hand,

    Just click install again and the installer will overwrite the existing install.

    23. November 2018 at 20:31 #42218

    Hi Heiner

    I ran the installer again, I think one issue is the fact I cant resolve raspberrypi.collabora.com, what DNS server would you recommend I configure to resolve the address.

    It also looks like when I done a package update its made things worse as the install log says I need development versions of libxml 2 and libxslt. What package do I need to re-install

    usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] …]
    or: -c –help [cmd1 cmd2 …]
    or: -c –help-commands
    or: -c cmd –help

    error: invalid command ‚bdist_wheel‘

    —————————————-
    Failed building wheel for future
    Running setup.py clean for future
    Running setup.py bdist_wheel for lxml: started
    Running setup.py bdist_wheel for lxml: finished with status ‚error‘
    Complete output from command /usr/bin/python -u -c „import setuptools, tokenize;__file__=’/tmp/pip-install-o7CWmJ/lxml/setup.py‘;f=getattr(tokenize, ‚open‘, open)(__file__);code=f.read().replace(‚\r\n‘, ‚\n‘);f.close();exec(compile(code, __file__, ‚exec‘))“ bdist_wheel -d /tmp/pip-wheel-OJwQGC –python-tag cp27:
    Building lxml version 4.2.5.
    Building without Cython.
    ERROR: /bin/sh: 1: xslt-config: not found

    ** make sure the development packages of libxml2 and libxslt are installed **

    Using build configuration of libxslt
    usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] …]
    or: -c –help [cmd1 cmd2 …]
    or: -c –help-commands
    or: -c cmd –help

    error: invalid command ‚bdist_wheel‘

    26. November 2018 at 13:21 #42248

    Hi lewhand,

    If it’s not too much hassle, please try downloading a new version of Max2Play and burning it to check whether your issue is an individual one. We tested the installer here with a fresh image and it worked out of the box.

    You can make an image backup beforehand for safety.

    27. November 2018 at 22:51 #42315

    Hi Heiner

    I downloaded and loaded the new image and Google music installed successfully (the install script looked completely different to last time)

    Only issue I have now is for some reason I can’t log Google music even though username and password is definitely correct

    Thanks for your help.

    28. November 2018 at 11:48 #42339

    Hi lew-hand,

    Please double-check your device-ID and try entering it again.

    7. Januar 2019 at 5:40 #43185

    After months of the Google Music plugin working perfectly, I had a reboot of my m2p and the plugin now loads but doesn’t seem to login correctly, showing an empty library that „reloads“ instantly. I mucked around with it a bit, and then tried burning a fresh image of the latest M2P..thought it would be easier to just start from scratch.

    Unfortunately, I am having problems:

    Here’s what I’m doing with the fresh install:
    * Latest M2P image (m2p_stretch_rpi_v247.img) for RPi 3BA on a new 64gb sd card
    * Check boot partition is expanded; it is
    * Install LMS Nightly 7.9 via M2P interface
    * Go though basic setup for LMS and play MP3s from attached USB drive –all looking good
    * Use M2P interface to install Google Music plugin:
    ** Install updates seem to stall when doing python setup of future… no further updates given for hours. But on second try, seems to install ok (logs below)
    ** Even though plugin does seem to be installed and activated on LMS, when entering user/pass/androidID from previous setup, I get „Not logged in to Google Play Music. Set your username and password.“ I know the info is correct, was working until last week with same androidID
    ** Try restarting LMS just in case… no change

    I’ve done this a couple times and also tried an older image of M2P I had around..no joy.

    Any help would be greatly appreciated.

    Cheers,

    Bob

    —here’s the output from the second attempt to install the plugin:

    Requirement already satisfied: validictory!=0.9.2,>=0.8.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: future in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: mock>=0.7.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: python-dateutil!=2.0,>=1.3 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: decorator>=3.3.1 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: requests!=1.2.0,!=2.12.0,!=2.12.1,!=2.12.2,!=2.2.1,!=2.8.0,!=2.8.1,>=1.1.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: mutagen>=1.34 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: MechanicalSoup>=0.4.0 in /usr/local/lib/python2.7/dist-packages (from gmusicapi==10.1.2)
    Requirement already satisfied: setuptools in /usr/lib/python2.7/dist-packages (from protobuf>=3.0.0->gmusicapi==10.1.2)
    Requirement already satisfied: rsa>=3.1.4 in /usr/local/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi==10.1.2)
    Requirement already satisfied: httplib2>=0.9.1 in /usr/local/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi==10.1.2)
    Requirement already satisfied: pyasn1-modules>=0.0.5 in /usr/local/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi==10.1.2)
    Requirement already satisfied: pyasn1>=0.1.7 in /usr/lib/python2.7/dist-packages (from oauth2client>=1.1->gmusicapi==10.1.2)
    Requirement already satisfied: pycryptodomex>=3.0 in /usr/local/lib/python2.7/dist-packages (from gpsoauth>=0.2.0->gmusicapi==10.1.2)
    Requirement already satisfied: funcsigs>=1; python_version < „3.3“ in /usr/local/lib/python2.7/dist-packages (from mock>=0.7.0->gmusicapi==10.1.2)
    Requirement already satisfied: pbr>=0.11 in /usr/local/lib/python2.7/dist-packages (from mock>=0.7.0->gmusicapi==10.1.2)
    Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/local/lib/python2.7/dist-packages (from requests!=1.2.0,!=2.12.0,!=2.12.1,!=2.12.2,!=2.2.1,!=2.8.0,!=2.8.1,>=1.1.0->gmusicapi==10.1.2)
    Requirement already satisfied: idna<2.9,>=2.5 in /usr/local/lib/python2.7/dist-packages (from requests!=1.2.0,!=2.12.0,!=2.12.1,!=2.12.2,!=2.2.1,!=2.8.0,!=2.8.1,>=1.1.0->gmusicapi==10.1.2)
    Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/local/lib/python2.7/dist-packages (from requests!=1.2.0,!=2.12.0,!=2.12.1,!=2.12.2,!=2.2.1,!=2.8.0,!=2.8.1,>=1.1.0->gmusicapi==10.1.2)
    Requirement already satisfied: certifi>=2017.4.17 in /usr/local/lib/python2.7/dist-packages (from requests!=1.2.0,!=2.12.0,!=2.12.1,!=2.12.2,!=2.2.1,!=2.8.0,!=2.8.1,>=1.1.0->gmusicapi==10.1.2)
    Requirement already satisfied: beautifulsoup4 in /usr/lib/python2.7/dist-packages (from MechanicalSoup>=0.4.0->gmusicapi==10.1.2)
    Requirement already satisfied: lxml in /usr/lib/python2.7/dist-packages (from MechanicalSoup>=0.4.0->gmusicapi==10.1.2)
    Inline is up to date. (0.80)
    Inline::Python is up to date. (0.56)
    IO::Socket::SSL is up to date. (2.060)
    /var/lib/squeezeboxserver/Plugins /var/www/max2play/public
    /var/lib/squeezeboxserver/Plugins/GoogleMusic /var/lib/squeezeboxserver/Plugins /var/www/max2play/public
    Cloning into ‚.’…
    Restarting logitechmediaserver (via systemctl): logitechmediaserver.service.
    Finished installing Google Music Plugin

    GoogleMusic Plugin installed.
    Important: Now edit the settings of the Plugin within Squeezebox Server Settings, add your GoogleMusic credentials (including a mobile device ID!) and you are ready to go.

    8. Januar 2019 at 16:53 #43277

    Thank you for the detailed report. I’ll try to recreate the issue here this week and get back to you asap.

    22. Januar 2019 at 14:32 #44007

    Hi sorry about the late reply. Does the issue persist? Were you able to try another deviceID?

    22. Januar 2019 at 18:01 #44038

    There seems to be a new authentification method where you set up an app password. Here’s the link

    22. Januar 2019 at 18:06 #44039

    I think you have missed the link out

    22. Januar 2019 at 18:25 #44040

    It’s there when you hover over the passage „Here’s the link“

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

Register here