[SOLVED] No internet connection on Wifi

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] No internet connection on Wifi

This topic contains 45 replies, has 16 voices, and was last updated by  TimHoward premium 1 year, 3 months ago.

Viewing 16 posts - 31 through 46 (of 46 total)
  • 13. November 2017 at 8:26 #32441

    Hi there.

    I just purchased Max2Play with a Pi3 and HiFiBerry and getting exactly the same issue (no internet on WiFi)

    When will a proper fix be available as this bug must be effecting many of your user base downloading current image.

    Regards,

    Peter.

    13. November 2017 at 12:37 #32444

    Hi Peter,

    What connection method did you use? I am not sure which bug you are referring to as we have not yet been able to recreate the specific issues. This topic contains various solutions to different problems, including a shairtunes2 bug fix that you might be referring to.

    For now, please try using WPS, Access Point Autostart or following the normal Wifi procedure.

    How-to – WiFi Configuration with WPS and Max2Play

    Access Point Autostart Mode

    If you are having issues with the latter, please share your steps and error messages so we can understand what might be the problem.

    Firstly, do make sure your ethernet cable is reomved after you configure your WiFi and reboot, if you are going with the normal WiFi configuration.

    13. November 2017 at 12:40 #32445

    I’ve implemented the work around with adding manually the DNS entries to the resolution file. That works.

    14. November 2017 at 21:47 #32490

    Hi,

    i also had the „no internet“ problem with my PI Zero W.

    nbmorgan´s soloution about adding the google DNS-Server to the file /etc/dnsmasq.conf fixed it.

    30. November 2017 at 0:08 #32713

    Hi there, I still have the problem with missing internet connection on wifi and I did not find a solution in this forum. I have a Pi3 and a Pi2 with USB wifi, both with freshly installed m2p, that behave as follows:
    – pi3: internet connection avaiable, but IP adress (ifconfig) remains on 192.168.189.1. Accesspoint Mode is disabled
    – pi2: not internet connection avaiable, i disabled Accesspoint Mode but after reboot the pi falls back into Accesspoint Mode

    I tried to change the nameserver in /etc/resovle.conf to my router what gives me an internet connection untill reboot. After reboot, my changes to resolve.conf are overwritten to the defaults…

    Updating kernel an packages also doesn’t help.

    It’s feels annoying that even the first basic step – establishing the wifi connection – seems to be buggy….
    can you help me? whta do you need to help?

    Thx
    Nils

    30. November 2017 at 16:33 #32720

    Hey again,

    it seams tu run now:

    pi2 => reset configuration to defaults and activated WPS on next boot – worked
    pi3 => startet again with fresh sd-card, as reset to defaults didin’t work. Activated WPS on first boot – worked

    My recommendation: use only WPS for the wifi setup! Do not follow the steps described on the download page. Do not manually fill in network und key via webinterface. Maybe that should be changed on the website.

    I am really like the idea of max2play and i hope that the next steps towards multiroom-system won’t be that tricky…

    regrads
    Nils

    10. Dezember 2017 at 8:35 #32848

    I am having the same issue (RP3 is connected to wifi but Max2Play says no internet connection over wifi). I am a newbie, could someone please tell me where to find /etc/dnsmasq.conf and how to edit it.

    Thanks.

    10. Dezember 2017 at 9:50 #32849

    Thank you nbmorgan. Your fix worked! I prepended the lines you gave to /etc/dnsmasq.conf and internet now works over wifi.

    10. Dezember 2017 at 9:58 #32850

    Sorry for not being clear. nbmorgan’s fix (from another blog) is perpending the following lines to /etc/dnsmasq.conf (which I did using the Remote Control pluging and a sudo nano command to edit the file):

    #hack in googles dns servers
    server=8.8.8.8
    server=8.8.4.4

    10. Dezember 2017 at 9:59 #32851

    Thank you nbmorgan. Your fix worked! I prepended the lines you gave to /etc/dnsmasq.conf and internet now works over wifi!

    12. Dezember 2017 at 14:40 #32894

    Just to add to this, I just set up a RaspPi Zero W via WPS, same issue here => no DNS server entry. Added them within the dnsmasq.conf and now it´s connected.

    18. Dezember 2017 at 18:09 #33035
      Hello there, how do you edit this file?
      Total newbie
      Thanks for the help.
    • This reply was modified 1 year, 4 months ago by  daviddepiston.
    27. Dezember 2017 at 0:05 #33105

    ssh [ip-adress-of-pi]

    Just type in „sudo nano /etc/dnsmasq.conf“ and add the two lines „server=8.8.8.8“ and „server=8.8.4.4“
    Ctrl+x, Save
    sudo reboot

    • This reply was modified 1 year, 3 months ago by  dtesan.
    27. Dezember 2017 at 0:21 #33107

    Found something new…… workaround with dnsmasq.conf works until I install SD-Card-Protection… Entries in dnsmasq.conf are still there but DNS is not running anymore…. after deinstalling SD-Card-Protection and editing dnsmasq.conf again (because the file is empty now) with Google-DNS-Servers it works again…..

    • This reply was modified 1 year, 3 months ago by  dtesan.
    4. Januar 2018 at 0:59 #33212

    Thank you,got it working.

    7. Januar 2018 at 18:32 #33280

    I had same problem of no internet connection via wifi, despite everything else working.
    Solution was to set a fixed IP address, eg 192.168.1.33 (pick last 2/3 digits to be clear of any other devices)
    To be safe, you can allocate the address in your router to the pi.

Viewing 16 posts - 31 through 46 (of 46 total)

You must be logged in to reply to this topic.

Register here