[SOLVED] No internet connection on Wifi

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] No internet connection on Wifi

This topic contains 45 replies, has 16 voices, and was last updated by  TimHoward premium 2 years, 9 months ago.

Viewing 30 posts - 1 through 30 (of 46 total)
  • 1. August 2017 at 20:10 #30294

    Hi all,

    Today I installed Max2Play on a SD card and booted it on my PI B+.

    I have now almost every thing running (via LMC on Synology NAS).
    I have a TP link USB WIFI adapter and this is working fine.

    The connection with the PI and Max2Play page works fine.
    But in the interface on the ’settings/reboot‘ tab it says ‚Internet: NO Connection‘ when the PI is only using Wifi.
    When I also use UTP, there is an internet connection (all other devices can use internet on the same wifi channel).

    So I can’t download any plugins over WIFI, but also the spotify connect plugin doesn’t work then.

    A couple of reboots didn’t worked.

    On the network/wifi settings:

    – I used the WPS button to connect to my router (and this worked ok)
    – I use a fixed IP address
    – access point mode is off

    Does anyone have a solution for this?

    • This topic was modified 3 years, 2 months ago by  Bassie.
    • This topic was modified 3 years ago by  Heiner.
    2. August 2017 at 8:55 #30298

    Hi Bassie,

    After connecting via WPS, does the system still tell you that you have no internet connection?

    Please deactivate fixed IP, it is only for LAN use, and try connecting to your network again.

    3. August 2017 at 10:35 #30361

    Hi Heiner,

    After connecting via WPS, does the system still tell you that you have no internet connection?
    Yes, it did.
    The strange thing is that yesterday evening when I wanted to change the ‚Fix IP setting‘ I had an internet connection.
    So probably, later on it was getting connected to the internet.

    Then I tried to start the ’spotify connect‘ addon and this one started.
    But when I tried to connect with spotify to the spotify connect ‚max2play‘ (yes it was visible in spotify) it looked like the PI restarted.

    So after that I changed the ‚Fix IP‘ off and restarted the PI.
    But then I again had no internet connection.
    So I can connect via Wifi to the PI, but somehow it can’t connect itself to the internet.

    SO still some questions from my side:

    – is there a way I can force the PI to connect to the internet

    3. August 2017 at 12:29 #30366

    Please check your router’s web interface, to make sure the device is connected to your network. There, you should also see whether it is connected to the internet connection.

    3. August 2017 at 12:50 #30371

    Hi Heiner,

    I already checked this.
    I can see that the PI is connected to my router in the router webinterface and the PI is only connected with a Wifi USB stick and I can connect with the PI, so it is using my router.
    I don’t have any restrictions on my router, so the M2P software should connect to the internet.

    The strange thing is that when I connect an UTP cable there is an internet connection right away (same router).
    So I would think that there is a different setting between the WIFI setting and UTP network settings.

    IS there a log file or something on the PI that I can look into?

    3. August 2017 at 13:30 #30374

    Hi Bassie,

    There sure are some log files.

    You can find logs for all your plugins in the bottom of the web interface by clicking on „Debug Info“.

    Do you have the newest version of Max2Play? If so, please also uncheck the new Access Point Autostart (and reboot) to rule it out as a source of error.

    3. August 2017 at 14:03 #30380

    Hi Heiner,

    Ok, I will look into the log files then and try if I can see some issues.

    And yes, I have the latest version.
    I think the access point autostart is already set to off, but will check this tonight.

    Thanks for your help.

    22. September 2017 at 19:00 #31484

    Did you find a way to fix this?

    I have a new setup. RPi3, v2.44, iQaudio and see the same thing – if I plug in an ethernet cable then it says it has an internet connection, but on wifi it says no internet connection. However, I can configure Max2Play over wifi from my Mac , so the RP3 wifi is working!

    One thing is that both the Mac and the RP3 are connected into a DLAN wifi, then vias homeplug to my router/modem. Other devices connected this way (eg iPhone) have internet connection with no problems, so I dont see why this should make a difference.

    22. September 2017 at 20:46 #31486

    Hi,

    I’m having a similar problem on a RPi 2 with a fresh install of Max2Play. The interconnection was working fine with the ethernet cable plugged in, but I get a „No internet connection“ message when I use WIFI only.
    I have unchecked WPS and „use as accesspoint“ and rebooted, to no avail.

    What I find odd is that I can still access Max2Play locally from my laptop.

    Thanks in advance for your help.

    24. September 2017 at 18:05 #31500

    A bit more info (I’ve been trying a few experiments):

    Airplay does not work with squeezelite – although the shairtunes plugin has been selected my rPi does not appear as an airplay option on my iPhopne. This is true whether I connect my rPi3 to my modem/router vias wifi or ethernet. I also tried updating to the beta release, but it made no difference.

    However if I load shairplay (and dont run squueezelite) then my rPi does appear as an airplay destination on my iPhone. Again, this is true whether the rPi3 is connected to my modem/router vias wifi or ethernet. If conencted by wifi the „No internet connection“ warning still apeears.

    I want to have internet radio as well so I need the squeeze server setup – can anyone help?

    25. September 2017 at 17:02 #31541

    Hi Andy,

    Please check your LMS‘ settings. Under Plugins, you will find shairtunes2. Please make sure this is active and running properly.

    25. September 2017 at 22:37 #31548

    I’ve selected shairtunes2 and installed it from the menu and rebooted, but how do I tell if it’s running properly? I’m controlling all this via an iPad and Safari, not keyboard & hdmi monitor.

    26. September 2017 at 10:52 #31554

    Hi Andy,

    In our web interface, head to Squeezebox Server menu, click the blue button to get to the LMS menu, click the bottom right corner „Settings“, there you can find „Plugins“ as a menu item.

    30. September 2017 at 12:36 #31638

    The only Blue button I see is „Open Squeezebox Server Webadministration“. This takes me to a page where I need to log into a squeezebox account, after which I see various web apps – not what you are talking about.

    There is a debug informatuon at the bottom of the sueezebox server tab. Have pasted this all in below incase it helps…

    <deleted as there was so much of it it was getting the way!>

    • This reply was modified 3 years ago by  AndyS.
    1. Oktober 2017 at 15:48 #31643

    I have the same problem with my Raspberry Pi Zero W.
    After every reboot there is no internet connection available.

    I always have to go to the Wifi tab, scan for networks, choose the network and re-enter the password. The internet connection works until the next reboot.

    It would be great if m2p could investigate this issue…thanks!

    2. Oktober 2017 at 16:04 #31660

    @andys: The interface you access when you click the big blue button is the one in question. There, you can find a small button in the bottom right corner „Settings“ under which you will find a tab named „Plugins“. In this list, you should find shairtunes2, either in active or inactive.

    @email protected: please disable the access point autostart mode in the WiFi/LAN menu (dropdown item), save and reboot the device.

    6. Oktober 2017 at 0:52 #31721

    Hi everyone,

    I’m having this problem also with a preconfigured Max2Play SD card with an IOAudio DAC on Raspberry Pi 3. Using the built-in wifi on the RPi3.

    My router issues an IP to the RPi using DHCP. The RPi configures the wifi interface with the IP on the local network as it should – i can see this in the Wifi/LAN tab. Its showing as active and I can also connect to my NAS server on the same local network and configure mount points for smb shares. But if I go back to the Settings/Reboot tab the health checker shows no internet connection and I’m unable to connect to the outside world and download anything. Its the same in Kodi.

    If I plug the RPi into the router with an ethernet cable it all works fine. But that’s not practical for my setup and I need this to work over Wifi.

    So, I also hope that max2play can provide a fix for this soon.

    6. Oktober 2017 at 15:25 #31760

    Hi gray,

    Have you checked your Access Point Autostart Mode in the WiFi/LAN menu? If not, please make sure the tick is removed and reboot. Furthermore, please make sure to remove the ethernet cable right after rebooting if you are still connected via LAN to make sure it is not prioritized during the boot sequence.

    6. Oktober 2017 at 15:53 #31762

    Hello Heiner,

    Accespoint autostart mode was ticked. I’ve just inticked it, saved and reboot. The problem with no internet still persists.

    kind regards

    Gray

    6. Oktober 2017 at 16:07 #31765

    Please try re-establishing your WiFi connection now, save, reboot and immediately unplug the ethernet cable after clicking reboot.

    6. Oktober 2017 at 17:13 #31767

    ok. I stripped out all Wifi config, saved, reboot. Connected over ethernet and reconfigured wifi, saved, reboot and immediately unplugged cable. connected again over wifi interface and still no internet connection. I’ve also reboot my router several times.

    The problem still persists.

    Gray

    8. Oktober 2017 at 11:22 #31782

    Ok, a little progress. I reflashed the card and started again, this time never connecting to network by cable. Now my rPi3 max2play DOES report it has an internet connection (over Wi-fi) 🙂

    However I still cannot get AirPlay to work. When I look at which plugins are active (via squeeze server web admin) sharetunes2 is unticked and marked “Plugin failed to load”. How can I fix this? I thought max2play was supposed to be robust and easy to use??

    • This reply was modified 3 years ago by  AndyS.
    • This reply was modified 3 years ago by  AndyS. Reason: Correcting typing errors
    8. Oktober 2017 at 12:34 #31785

    Found the answer elsewhere on these forums. Go into the squeezebox webadmin, settings, go to plugins tab, activate the „shairtunes2 (fork)“ one and apply. I now have AirPlay working. :-). (Notes say this is for Windows but I am using only Apple devices and it’s still necessary!)

    9. Oktober 2017 at 14:30 #31817

    Hi Andy,

    Thanks for the quick update and the feedback. we will consider this issue for future requests. 🙂

    10. Oktober 2017 at 2:34 #31834

    Hello,

    I am having the same issue.

    What I have found so far : dnsmask is not getting its resolve.conf set when on wifi. dhcpcd is collecting the wlan0 address from the dhcp server but not setting reslov.conf in /run/dnsmask/resolv.conf

    10. Oktober 2017 at 2:44 #31835

    My Temp fix is:

    In the file /etc/dnsmasq.conf prepend the following lines

    #hack in googles dns servers
    server=8.8.8.8
    server=8.8.4.4

    11. Oktober 2017 at 16:19 #31866

    Hi nbmorgan,

    Thanks for sharing, which issue exactly are you referring to and can you elaborate a little?

    21. Oktober 2017 at 9:37 #32027

    Hi,

    I have just installed a clean max2play system, configured the network with WPS, no LAN cable was attached, deactivated WPS at start, deactivated Accesspoint Mode, rebooted -> no internet connection.

    I have other Raspbian Jessie systems in the same network without any issues.

    Then I followed nbmorgan’s advice and added DNS servers to /etc/dnsmasq.conf and this solved the issue. This seems like a general issue here…?

    21. Oktober 2017 at 9:52 #32028

    Also I had the same AirPlay issues as AndyS, I had to activate shairtunes2 (fork) in squeezebox webadmin, settings, plugins tab, to get it running. Before sharetunes2 was unticked and marked as „Plugin failed to load“.

    • This reply was modified 3 years ago by  Toxiro. Reason: After testing it I realized it was still not working
    • This reply was modified 3 years ago by  Toxiro. Reason: edited again, after some waiting AirPlay showed up in iOS
    24. Oktober 2017 at 12:12 #32055

    Hi Toxiro,

    Thanks for sharing these issues. We will try to address them in our next release.

Viewing 30 posts - 1 through 30 (of 46 total)

You must be logged in to reply to this topic.

Register here