No Internet Connection Available

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No Internet Connection Available

This topic contains 11 replies, has 2 voices, and was last updated by  Heiner Moderator 3 years, 7 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 13. August 2017 at 12:29 #30582

    I have one Hifiberry Dac and One Amp+ as Squeezebox players, both running Max2Play and over wifi.

    Everything was working fine until this morning when the amp became unresponsive. Repowering the amp didn’t help but repowering everything including my router did enable me to access the web interface for the amp again. However I still can’t use it as a player and I see the warning „No internet Connection Available“

    I can see the amp connected and assigned an ip address in my router configuration.

    I saw another forum post like this a few days ago with no resolution so far.

    14. August 2017 at 10:22 #30600

    Hi yocky,

    Could you please link the previous, unresolved post, tell us the specifications of your Amp-Pi-Setup’s power supply and the settings you have in your Squeezelite player?

    14. August 2017 at 10:42 #30603

    Sure.

    https://www.max2play.com/en/forums/topic/no-internet-connection-on-wifi/

    The PSU is 18v/3.3A . In fact, ths one: https://www.hifiberry.com/shop/accessories/meanwell-gs60a18-p1j/

    I’m not sure which squeezelite settings you mean, but I haven’t altered anything from the default settings.

    FYI, I have the unit running successfully via LAN now.

    • This reply was modified 3 years, 8 months ago by  yocky.
    • This reply was modified 3 years, 8 months ago by  yocky.
    14. August 2017 at 11:49 #30609

    ….. should have said, I have the unit running successfully via *ethernet*. Wifi is still not working.

    14. August 2017 at 13:29 #30610

    Hi yocky,

    By Squeezelite I mean the advanced options and the values in there. However, if you have the default this should not be an issue.

    Regarding WiFi, you said you assigned an IP? The Pi should receive its IP when you enter your login credentials for WiFi in the web interface. Once you have this set up, you should be able to reboot the Pi, remove the LAN cable and it should automatically connect to your WiFi. (Don’t forget to tick the „load WiFi interface“ box)

    14. August 2017 at 13:57 #30612

    Last week the Pi was operating fine via wifi. Just a standard dchp connection (no static address). Now I can see it in my router config’s network map and I can reach it via the max2play web interface, but the squeezebox functionality doesn’t work and I get this „No Internet Connection Available“ message.

    Nothing has changed, it just stopped working via wifi.

    15. August 2017 at 10:06 #30632

    Any more input on this please?

    15. August 2017 at 16:23 #30647

    Hi yocky,

    Please share the debug info log from the WiFi/LAN plugin.

    Also, did you try the aforementioned steps again:
    Reboot the Pi, remove the LAN cable and it should automatically connect to your WiFi. (make sure to disconnect the cable directly after clicking „reboot“ to ensure that the device does not prioritize the LAN immediately)

    16. August 2017 at 8:03 #30655

    Yes. I have rebooted the device multiple times, including just now in exactly the way you specified. Same result every time.

    Here is the debug info from just after my last reboot.

    eth0 Link encap:Ethernet HWaddr b8:27:eb:a8:ed:1a
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:186 errors:0 dropped:0 overruns:0 frame:0
    TX packets:186 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:13340 (13.0 KiB) TX bytes:13340 (13.0 KiB)

    wlan0 Link encap:Ethernet HWaddr b8:27:eb:fd:b8:4f
    inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:226 errors:0 dropped:0 overruns:0 frame:0
    TX packets:455 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:23300 (22.7 KiB) TX bytes:476050 (464.8 KiB)

    16. August 2017 at 14:06 #30659

    Hi yocky,

    The device still prioritizes the ethernet connection when booting, according to your log.

    Please try one of our new WiFi connection options:

    WPS: https://www.max2play.com/en/how-tos/how-to-wifi-configuration-with-wps-and-max2play/

    or

    Access Point Autostart Mode: https://www.max2play.com/en/2017/08/access-point-autostart-mode/

    Both should would definitely solve the dependency issue with your ethernet.

    16. August 2017 at 20:29 #30672

    I came back home this evening and without me doing anything, the issue was gone. No warning message and I could use the Squeezebox functionality. I’ve included an updated debug copy which as you can see is almost identical to the earlier one.

    So I have some questions.

    Doesn’t this invalidate your previous diagnosis?

    Did the WPS solution involve me buying a USB wifi adaptor?

    Why would the system prioritize an ethernet connection that wasn’t made?

    None of this sounds very satisfactory.

    eth0 Link encap:Ethernet HWaddr b8:27:eb:a8:ed:1a
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:65536 Metric:1
    RX packets:638 errors:0 dropped:0 overruns:0 frame:0
    TX packets:638 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1
    RX bytes:41899 (40.9 KiB) TX bytes:41899 (40.9 KiB)

    wlan0 Link encap:Ethernet HWaddr b8:27:eb:fd:b8:4f
    inet addr:192.168.1.10 Bcast:192.168.1.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:29197 errors:0 dropped:0 overruns:0 frame:0
    TX packets:10843 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1971755 (1.8 MiB) TX bytes:2021417 (1.9 MiB)

    • This reply was modified 3 years, 7 months ago by  yocky.
    17. August 2017 at 9:32 #30677

    We do strive to be satisfactory.

    The internet connection that is first accessible after rebooting is what your device prioritizes. So if the Pi still recognizes the ethernet in the first seconds before you disconnect it, it CAN lead to an issue. However, this does not happen very often and has become less and less of an issue as we improved and debugged Max2Play over time.

    My previous diagnosis is just based on the small information that I can glean from this correspondence and the debug logs. However, the device’s many processes that run concurrently are something I am not privy to, as is your WiFi setup and its complexities. I assume the solution happened due to a process of your router, but the most important thing is, that it works 😉

    WPS does not require an additional dongle, we just created the HowTo when the Raspberry Pi 2 was the newest model and it did not have built-in WiFi.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here