polrus

Forum Replies Created

Viewing 10 posts - 1 through 10 (of 10 total)
  • Posted in:
  • 27. Juli 2021 at 8:35 #51514

    HI
    as I wrote during the troubleshooting steps I could see that /etc/fstab gets updated by m2p (modification timestamp) but the content of fstab is not changed – so the mountpoint remains.

    So if the mountpoint is in fstab of course it is displayed.

    So again I’m saying that the script responsible for fstab modification is faulty.

    21. Juli 2021 at 21:43 #51488

    anyway in my case
    sudo ls -la /etc/fstab
    -rw-rw-rw- 1 root root 409 Jul 14 09:35 /etc/fstab

    20. Juli 2021 at 18:26 #51483

    yes exactly, i can see them but cannot remove them.

    as I mentioned for troubleshooting I added the entries with the m2p gui also after removing them from console

    14. Juli 2021 at 2:41 #51462

    #### blkid ####
    /dev/mmcblk0p1: LABEL_FATBOOT=“boot“ LABEL=“boot“ UUID=“B6BB-0F0E“ TYPE=“vfat“ PARTUUID=“0634f60c-01″
    /dev/mmcblk0p2: LABEL=“rootfs“ UUID=“638417fb-7220-47b1-883c-e6fee02f51ac“ TYPE=“ext4″ PARTUUID=“0634f60c-02″
    /dev/mmcblk0: PTUUID=“0634f60c“ PTTYPE=“dos“
    /dev/mmcblk0p3: PARTUUID=“0634f60c-03″

    #### mounted ####

    9. Juli 2021 at 9:05 #51440

    I checked the sdcard – it is not currupted.

    Of course burning new image would be an option but as I dedicated lots of time to set it up I would like to avoid doing this again.

    for troubleshooting steps you might consider:

    1. I deleted the mountpoints in /etc/fstab
    2 I added one of them with m2p gui – success
    3. I checked /etc/fstab modification date after adding -08:51
    4. I pressed delete on the newly added mountpoint in m2p gui at 08:53, for several seconds icon of turning gear apears – then it refreshed – feedbacj no message if removing was succesfull or not – just a refresh where the mountpoint is still present
    5. INTERESETING – there were no changes in /etc/fstab but modification time of /etc/fstab changed to 08:53 so the time when I pressed „delete“ in gui

    So to me there is no corruption but a bug in the file parsing /etc/fstab

    • This reply was modified 1 year, 2 months ago by  polrus.
    6. Juli 2021 at 21:26 #51426

    ok – if you want me to shoot some commands in terminal for troubleshooting I’m fine with it

    6. Juli 2021 at 12:04 #51420

    It does not work in Beta either

    what I saw in Firefox is that you call
    http://192.168.0.121/plugins/max2play_settings/controller/Filesystem.php?action=delete_0&mountpoint=&path=&type=&options=
    or
    http://192.168.0.121/plugins/max2play_settings/controller/Filesystem.php?action=delete_1&mountpoint=&path=&type=&options=

    when I press on first or second button. Maybe mountpoint and path are also needed? Just guessing

    2. Juli 2021 at 17:58 #51406

    How do I do it?
    Is there a way to go back to stable ?

    30. Juni 2021 at 20:25 #51380

    Hi,
    I’m using Buster and M2P version is
    Version 2.53

    7. Januar 2021 at 21:54 #50564

    Thank you for the reply.
    Makes sense.
    Just a proposal – you might want to add description to the versions – like
    – tested
    – beta
    – experimental
    Where for exmaple experimental would be the latest deb released by lms

Viewing 10 posts - 1 through 10 (of 10 total)