Martinsthlm

Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Posted in:
  • 22. Januar 2019 at 9:36 #43972

    Update:

    The remote restart of Max2Play via HomeAssistant works just fine! Great!

    11. Januar 2019 at 18:38 #43536

    No probblem. It was not that advanced and quite easy.
    In the config.yaml in Home assistant I wrote:

    rest_command:
    my_request:
    url: http://192.168.1.xx/plugins/max2play_settings/controller/Squeezeserver.php?action=restart
    method: GET
    my_request_2:
    url: http://192.168.1.xx:9000/status.html?p0=mixer&p1=volume&p2=-10&player=%5BMAC ADRESS FROM M2P API]
    method: GET
    my_request_3:
    url: http://192.168.1.xx:9000/status.html?p0=mixer&p1=volume&p2=%2B10&player=%5BMAC ADRESS FROM M2P API]
    method: GET

    Important, I gave the RPI a static ip adress in the router since I point the rest_commandt to a specific local IP adress.
    Then I used the script editor in Hassio and created scripts „rest_command.my_request“ without any additional adjustments, „rest_command.my_request_2“ etc and then added the script ID to the Lovelace UI.

    Voilá, from the Home assistant app I can execute each specific script and the squeezebox server restarts, lower volume etc.

    Now I just have to wait until Spotify connect is unreachable (not very often that problem occurs though) to see if it solves the problem. It should. 🙂

    9. Januar 2019 at 11:54 #43322

    Thanks Heiner!
    I made a script in Home Asssistant and it works perfectly.

    6. September 2018 at 9:20 #37671

    Thanks!!

    25. Mai 2018 at 12:26 #35881

    UPDATE! Solved (but don’t know how)
    Hi Heiner,
    I’ve been on a trip for a week. During the trip I didn’t have access my raspberry pis through the Spotify connect in the native spotify iphone app as described above. When I got home yesterday evening I updated squeeze server again (just to be make sure I had the latest version if there was any update when I was away) and rebooted the system and…voilá…now everything works as it should again. The spotify connect appears in the native spotify app in my iphone and can control Spotify even when I am not on my home network. I have no clue why it started to work again but am happy that it does. Maybe it was the update procedure I carried out late last night. Anyway, thanks for looking into the issue and thanks for the amazing Max2Play.

    18. Februar 2018 at 9:35 #34040

    Hi again,
    I managed to solve the previous issue but the problems continues….spotify won’t start…again.
    Now i get this info from debug:

    #### Librespot Output ####
    Starting Spotify Connect Service

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing.
    Usage: /opt/spotifyconnect/librespot [options]

    Options:
    -c, –cache CACHE Path to a directory where files will be cached.
    –disable-audio-cache
    Disable caching of the audio data.
    -n, –name NAME Device name
    –device-type DEVICE_TYPE
    Displayed device type
    -b, –bitrate BITRATE
    Bitrate (96, 160 or 320). Defaults to 160
    –onstart PROGRAM
    Run PROGRAM when playback is about to begin.
    –onstop PROGRAM
    Run PROGRAM when playback has ended.
    -v, –verbose Enable verbose output
    -u, –username USERNAME
    Username to sign in with
    -p, –password PASSWORD
    Password
    –disable-discovery
    Disable discovery mode
    –backend BACKEND
    Audio backend to use. Use ‚?‘ to list options
    –device DEVICE Audio device to use. Use ‚?‘ to list options
    –mixer MIXER Mixer to use (e.g. alsa)
    –mixervolume MIXERVOLUME
    Alsamixer Volume control to use

    17. Februar 2018 at 22:45 #34037

    Hi
    Thanks.

    PLease forgive a newbie for asking stupid questions…..

    I made a reinstall of Max2play and after updates etc I managed to get spotify connect running and I can identify it in my iphone. However, next problem….No sound.

    When I check the output device in Spotify Connect tab there is only one choice available „hw:alsa – alsa, hw:alsa“, although I identified Hifiberry Amp2 as my soundcard on the hifiberry tab in max2play and on the Raspberry settings tab.

    Any suggestions at all are very much appreciated.

    14. Februar 2018 at 18:28 #34012

    Hi again,
    Appreciate your help.
    I have done and checked Everything suggested by you but unfortunately still does not work. Below is the debug info:

    #### Librespot Output ####
    Starting Spotify Connect Service

    #### Librespot Command Line Options ####
    /opt/spotifyconnect/librespot: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.17′ not found (required by /opt/spotifyconnect/librespot)
    /opt/spotifyconnect/librespot: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.18′ not found (required by /opt/spotifyconnect/librespot)

    14. Februar 2018 at 18:11 #34010

    Thanks for the reply.

    I’m using Hifiberry Amp2. In the output section of Spotify connect is stated „hw:sndrpihifiberry – sndrpihifiberry, hw:sndrpihifiberry“

    As an alternative I can choose „hw: ALSA-ALSA, hw:ALSA“

    But how to I choose Hifiberry Amp 2 as output in the Spotify Connect setion?

    Everywhere else in M2P Hifiberry Amp2 is the defined soundcard.
    No other audioplayers are running.
    Help is very much appreciated.

Viewing 9 posts - 1 through 9 (of 9 total)