[SOLVED] Spotify connect problems

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Spotify connect problems

This topic contains 3 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 19. Mai 2018 at 10:14 #35776

    Hi
    I’m running max2play and squeeze box server on raspberry pis (with hifiberry) and it works like a charm. Wonderful system at a fraction of the price of Sonos. 🙂
    I also downloaded iPeng9 to my iphone to run multiroom at home and it works perfectly. However, suddenly my spotify connected raspberries disappeared from my native Spotify app in my Iphone. Usually my spotify connect enabled raspberry pis appear as „available units“ in my spotify app on iphone, even when I am not in my home network. I can see them flickering for tenth of second in the spotify app and then they disappeared. My max2play, squeeze box server and plugins are all updated. Since it works prefectly when I use iPeng or Sueezebox web server in my home network (and even controllable from Home assistant!) I suspect something is wrong with the native spotify app in iphone. Has anybody else experienced this issue? Has the latest update of Spotify app in Iphone made it incompatible with the max2play spotify connect implementation?

    22. Mai 2018 at 15:13 #35808

    Hi Martin,

    I was not able to test iOS Spotify app in recent time, but will do so now and try to recreate the issue. Thank you for the kind words and the detailed report 🙂

    25. Mai 2018 at 12:26 #35881

    UPDATE! Solved (but don’t know how)
    Hi Heiner,
    I’ve been on a trip for a week. During the trip I didn’t have access my raspberry pis through the Spotify connect in the native spotify iphone app as described above. When I got home yesterday evening I updated squeeze server again (just to be make sure I had the latest version if there was any update when I was away) and rebooted the system and…voilá…now everything works as it should again. The spotify connect appears in the native spotify app in my iphone and can control Spotify even when I am not on my home network. I have no clue why it started to work again but am happy that it does. Maybe it was the update procedure I carried out late last night. Anyway, thanks for looking into the issue and thanks for the amazing Max2Play.

    28. Mai 2018 at 10:40 #35911

    Hi Martin,

    Thanks for the update! 🙂

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here