danilu

Forum Replies Created

Viewing 12 posts - 1 through 12 (of 12 total)
  • Posted in:
  • 27. August 2020 at 8:28 #49581

    Ich komme hier leider einfach nicht weiter, obwohl es ja nicht so schwer sein kann, wenn niemand anderer meine Probleme hat. Ich habe jetzt schon mehrfach ein neues Image auf unterschiedlichen Speicherkarten, Raspberrys und Hifiberry Amp 2 probiert.

    Hättet ihr vielleicht die Möglichkeit, mir ein Image von einer funktionierenden Installation zukommen zu lassen? Dann könnte ich zumindest einmal einschränken, ob es an einem Hardware- oder Software-Problem liegt. Ich könnte auch einen Link für den Upload zur Verfügung stellen.

    12. August 2020 at 15:56 #49554

    Da habe ich mich wohl nicht ganz deutlich ausgedrückt. Ich habe zuvor schon Einstellungen am Terminal geändert, aber aktuell nutze ich ein frisches sauberes Image mit den minimal notwendigen Einstellungen.
    Geändert habe ich von den drei Reglern in der Weboberfläche den obersten „Einstellungen für Digital Volume“.

    7. August 2020 at 10:18 #49513

    Hallo Mario,

    ich habe die Lautstärke jetzt bei laufendem Kodi auf 100 gesetzt, es kommt aber trotzdem kein Ton.
    Mit der Kommandozeile habe ich auch schon einmal einiges probiert, was man im Internet so findet. Aber im Endeffekt waren das alles nur Einstellungen, die über das Webinterface genauso gesetzt werden. Bei meinem aktuellen Setup habe ich aber nur das gemacht, was ich hier beschrieben habe -also keine Basteleien.

    2. August 2020 at 18:55 #49488

    Hallo Mario,

    das habe ich probiert, ändert aber leider auch nichts.
    Wirkt diese Lautstärken-Einstellung überhaupt auf Kodi? Wenn ich die nämlich ändere und auf speichern klicke, erscheint eine Meldung „Alsa Settings aktualisiert“. Alsa wird aber von Shairport benutzt. Wenn man über ein iPhone Musik streamt und die Lautstärke am iPhone ändert, ändert das nämlich auch den Lautstärke-Balken auf der Hifiberry Plugin Seite.

    Kodi nutzt ja Pulseaudio. Kann man für Pulseaudio separat Einstellungen setzen?

    23. März 2020 at 10:57 #48204

    Hello everybody!

    I have good news for this topic:

    Because of sound in kodi via hifiberry wasn’t working, I decided to use max2play only in the other rooms and in the living room I installed stand alone kodi on raspberry (without max2play). The last days I started reinstalling my max2play-raspi with the new max2play version (v2.51).
    Originally I wanted to test another thing (HDMI CEC) and for that I pluged a raspberry with newest max2play version in my TV. Surprisingly sound via hifiberry in kodi works out of the box. I actually haven’t made a decision, but maybe I will again install max2play on my raspberry in the living room to listen to music and watch videos via kodi.

    23. August 2019 at 9:25 #46829

    Hello,

    now I tried two installations of kodi: Once with manually installed kodi under raspbian, where I have to make some settings in raspbian, but then I got hifiberry running under kodi. And once with kodi installed via Noobs, where hifiberry was running instantly.

    I further don’t know whats the problem under max2play, but my hope is rising! I will go on trying 🙂

    16. August 2019 at 12:26 #46781

    Hi Heiner,

    would have been nice, if it only was the volume. My hope rised for a short time, but sadly not the solution.
    Maybe I will try hifiberry with a simple kodi installation and not max2play.

    14. August 2019 at 10:29 #46768

    Hi Heiner,

    built in audio is disabled. If it is enabled, hifiberry amp is not an option in kodi. So I disabled it an I can choose hifiberry as audio output in kodi, but there is no sound.

    13. August 2019 at 20:44 #46764

    Hi,

    I’m sorry for being annoying, but I dont‘ get this.

    Now I downloaded the newest max2play image and copied it to a new SD-card. I only set the necessary settings: Hifiberry card, disable internal audio (only with this option I can choose hifiberry in kodi), an I set the hifiberry card in kodi as audio output.
    Squeezelite and Shareplay are disabled. Nevertheless -C 5 option in Squeezelite is set.

    Actually I don’t worry about sound via Squeezelite and Shairplay. I am only trying to get sound in kodi. But I don’t get it, but once I had a setup where I got sound in kodi, but not via shairplay and actually I can’t reproduce it.

    I don’t know what to do. Meanwhile I doubt I can get kodi running with sound.

    So if there are any further suggestions, please give it to me. Hope is the last to die.

    28. Juli 2019 at 20:27 #46511

    Hi,

    Sorry for my late response, had no time the last few days.

    I tried some settings:
    If I deactivate the option „disable internal audio“ under tab „raspberry settings“, the hifiberry card is located at hw:1, so I have to set hw:1 as option in the settings of squeezelite and shairplay to play music via Iphone.
    If I enable the option „disable internal audio“, hifiberry is on hw:0, which then I have to set in the option.

    In both ways, I only can get sound in kodi via hdmi.
    If option „disable internal audio“ is not set, hifiberry isn‘t available in kodi.
    If option „disable internal audio“ is set, I can choose hifiberry card in kodi, but no sound.

    So actually there is only the problem with kodi…

    17. Juli 2019 at 15:54 #46350

    Hello Heiner,

    I think we are getting closer to what I want, but it already didn’t work at all.

    -C 5 option was already set for squeezelite but not for shairport. I set it yet. There I recognized, that hw:1 was set for both sqeezelite and shairport. I changed it to hw:0 for both and now squeezelite is also able to start and with it iPhone finds the raspberry via airplay.

    But now my first problem is present again. In Kodi the hifiberry card is choosen as audio device, but no sound in Kodi. Shairport and Squeezelite are stopped while Kodi is running. (incidentally: there is no option to run Shairport and Kodi simultanously?). The option „disable internal audio“ is still enabled.

    Again thanks for your help!!!!

    12. Juli 2019 at 17:02 #46300

    Now I can hear sound via hifiberry in kodi. I think it was the option „disable internal audio“ under „raspberry settings“. Now the error about hw:0 is also gone.

    Shairport gets automatic stopped if you start kodi.

    But now I have the problem, that (if kodi is stopped) my iPhone doesnt find the raspberry via airplay. If I choose „non“ as „installed hifiberry card“ my iPhone finds it.

    And also squeezelite could not be started. Gives me the following errors:
    [17:01:06.902331] test_open:384 playback open error: No such file or directory
    [17:01:06.902516] output_init_common:382 unable to open output device

    Any suggestions?

    Many thanks for your help!

Viewing 12 posts - 1 through 12 (of 12 total)