Max2play mit Hifiberry Amp 2 und Kodi

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Max2play mit Hifiberry Amp 2 und Kodi

This topic contains 8 replies, has 2 voices, and was last updated by  MarioM Moderator 1 month, 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 29. Juli 2020 at 12:45 #49479

    Hallo Leute,

    ich hatte früher schonmal Probleme mit der Sound-Ausgabe über Hifiberry unter Kodi, habe deswegen dann statt max2play einfach libreelec genutzt. Unter libreelec stört mich aber, dass man sehr eingeschränkt ist (zB kein root-Zugang, kein apt-get install). Deswegen habe ich mich jetzt noch einmal mit max2play beschäftigt und ich denke, es muss doch schaffbar sein!?

    Mein Setup:

    Raspberry Pi 3
    Hifiberry Amp 2
    max2play (diverse Versionen)

    Ich setze Hifiberry Amp 2 als Audiokarte, unter Raspberry Einstellungen setze ich den Haken „Deaktiviere integriertes Audio des Raspberry“, damit Hifiberry unter Kodi überhaupt zur Auswahl steht. In den Shairport Einstellungen muss ich dann als Option „-m hw:0“ setzen, da die Hifiberry dann die Adresse Null hat. Beim Start von Kodi wird Shairport und Squeezelite automatisch gestoppt, die können also nicht dazwischen funken.

    Die einzige max2play-Version, in der ich eine Sound-Ausgabe über Kodi habe, ist die beta-Version unter Buster v2.50. Nur funktioniert diese Version leider noch nicht richtig, da bei laufendem Kodi die CPUs ziemlich am Anschlag sind (über 90%) und eine entsprechende Wärmeentwicklung herrscht (81°C). Das wird wahrscheinlich auch der Grund sein, warum die Software sehr träge reagiert (Eingaben benötigen ca 1sek bis sie ausgeführt werden).

    Aber es muss doch unter den älteren Versionen auch möglich sein! Ich habe alle Versionen, die aktuell auf der Website herunter zu laden sind getestet. Manche booten gar nicht (was logisch ist, weil sie nicht für Raspberry Pi 3 supportet sind), unter den anderen funktioniert Shairport immer, aber über Kodi kam noch nie ein Ton heraus.

    Kann mir dabei bitte jemand helfen??

    LG Danilu

    29. Juli 2020 at 14:43 #49480

    Hallo Danilu,

    ich habe das Ganze gerade mit einem Pi 3B und einem frischen Image (Stretch v.2.49) getestet und konnte deine Probleme nicht rekonstruieren. Wenn du die Wiedergabe über Kodi gestartet hast, kontrolliere bitte das Digital Volume des Amps auf der HiFiBerry Plugin Seite oder den Raspberry Einstellungen. Es kann sein, dass du dort die Lautstärke für Kodi neu einstellen musst.

    2. August 2020 at 18:55 #49488

    Hallo Mario,

    das habe ich probiert, ändert aber leider auch nichts.
    Wirkt diese Lautstärken-Einstellung überhaupt auf Kodi? Wenn ich die nämlich ändere und auf speichern klicke, erscheint eine Meldung „Alsa Settings aktualisiert“. Alsa wird aber von Shairport benutzt. Wenn man über ein iPhone Musik streamt und die Lautstärke am iPhone ändert, ändert das nämlich auch den Lautstärke-Balken auf der Hifiberry Plugin Seite.

    Kodi nutzt ja Pulseaudio. Kann man für Pulseaudio separat Einstellungen setzen?

    4. August 2020 at 12:17 #49497

    Hallo Danilu,

    Ja, bei meinem Test konnte ich so Audio über Kodi ausgeben. Beim Wechsel von Squeezelite zu Kodi wurde die Lautstärke automatisch auf 0 gesetzt. Als ich diese angehoben und gespeichert habe, kam Sound über Kodi bzw. eben den Amp2. Hast du irgendwelche Einstellungen in den Kommandozeilenoptionen von Squeezelite oder Shairport geändert?

    7. August 2020 at 10:18 #49513

    Hallo Mario,

    ich habe die Lautstärke jetzt bei laufendem Kodi auf 100 gesetzt, es kommt aber trotzdem kein Ton.
    Mit der Kommandozeile habe ich auch schon einmal einiges probiert, was man im Internet so findet. Aber im Endeffekt waren das alles nur Einstellungen, die über das Webinterface genauso gesetzt werden. Bei meinem aktuellen Setup habe ich aber nur das gemacht, was ich hier beschrieben habe -also keine Basteleien.

    11. August 2020 at 12:28 #49525

    Hallo Danilu,

    sofern du während des Testens noch Einstellungen geändert hast, versuche es bitte nochmal mit der Standardkonfiguration. Welchen der drei Lautstärkeregler hast du denn angepasst?

    12. August 2020 at 15:56 #49554

    Da habe ich mich wohl nicht ganz deutlich ausgedrückt. Ich habe zuvor schon Einstellungen am Terminal geändert, aber aktuell nutze ich ein frisches sauberes Image mit den minimal notwendigen Einstellungen.
    Geändert habe ich von den drei Reglern in der Weboberfläche den obersten „Einstellungen für Digital Volume“.

    27. August 2020 at 8:28 #49581

    Ich komme hier leider einfach nicht weiter, obwohl es ja nicht so schwer sein kann, wenn niemand anderer meine Probleme hat. Ich habe jetzt schon mehrfach ein neues Image auf unterschiedlichen Speicherkarten, Raspberrys und Hifiberry Amp 2 probiert.

    Hättet ihr vielleicht die Möglichkeit, mir ein Image von einer funktionierenden Installation zukommen zu lassen? Dann könnte ich zumindest einmal einschränken, ob es an einem Hardware- oder Software-Problem liegt. Ich könnte auch einen Link für den Upload zur Verfügung stellen.

    2. September 2020 at 13:38 #49602

    Hallo danilu,

    Sofern du sonst über Squeezelite oder Shaiport Musik abspielen kannst, sollte kein Hardware Defekt vorliegen. Bitte gehe nochmal sicher, dass sowohl Squeezelite als auch Shairport nicht laufen, wenn Kodi geöffnet ist. Überprüfe auch noch einmal ob „Settings for Analogue Boost“ auf 100%, „Settings for Digital Volume“ auf mindestens 50% und „Settings for Analogue Playback Boost“ auf 0% steht. Richte vorher zur Sicherheit deine Soundkarte nochmal neu ein, indem du in den Raspberry Einstellungen „none“ auswählst, neustartest und dann nochmal die Soundkarte auswählst. Ich habe die Soundausgabe mit Kodi und dem Amp2 (diesmal mit Stretch v.2.52) eben erneut getestet und konnte wieder keine Probleme feststellen.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here