[SOLVED] WiFi fails after restart

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] WiFi fails after restart

Tagged: 

This topic contains 4 replies, has 3 voices, and was last updated by  Jessarpi 1 week, 4 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 25. Oktober 2018 at 20:09 #41445

    Hello, apologies if this is the wrong subforum. Please feel free to move to appropriate one.

    I have been trying to get max2pay up and running on my B model for three days now.

    I have been running max2play for quite some time with squeezebox server on my B model with no issues at all, but last week I changed my internet provider and as such I had to re-enter my WiFi credentials.

    My problem started at this point when I couldn’t even connect to the internet with my ethernet cable. What I did then was to install max2play from scratch, which works fine up to point of entering the WiFi details

    This works initially but after downloading and installing squeezebox server, and rebooting the Pi, it doesn’t connect to the WiFi again. Since it won’t connect with ethernet cable either, I have to erase the SD card again and install max2play again. I have done this twice already and I am not sure what the problem may be.

    As I said, I have been using squeezebox (in its pre-max2play form and then max2play) since 2014 and never had any issue.

    Could it be that my WiFi dongle (which is the „official“ one bought from the RPi shop) is broken?

    Thanks

    26. Oktober 2018 at 14:32 #41729

    Hi Gwydion,

    Thank you for your request and your long support of Max2Play.

    Did you also exchange the router? Raspberry Pis can sometimes have issues with channel 13 WiFi. So if your router uses this channel, try changing it to another (10 or 11).

    You can also try WPS to connect to your local network if your router supports it.

    Also, with Max2Play from 2.44, there should be an automatic access point being established as soon as the Pi does not find a network to connect to. You can then connect to Pi’s own accesspoint network to access the webinterface there and enter your SSID manually.

    Here is some documentation on those features:
    WPS HowTo
    Access Point HowTo

    30. Oktober 2018 at 1:53 #41754

    Hello Heiner, thanks for your advice, it now works. I manually changed the wifi channel to 11, as it was set to automatic, which probably explains why I was only able to connect on some occasions.

    I will bear the access point and WPS functionalities in mind for next time

    Again, thanks for your help.

    30. Oktober 2018 at 16:14 #41763

    Thanks for letting me know you solved your issues! 🙂

    10. November 2018 at 4:18 #41918

    I also just had this problem.
    I was not able to access the RaspberryPi / HifiBerry via WiFi or Ethernet.
    I had to reinstall Max2Play.

    After install:
    Log in via Ethernet, WiFi was not working, had to set router to Channel 11 Manually.
    Unsure of what caused the RaspberryPi / HifiBerry to stop being responsive.
    Glad it is working again now.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here