Squeezebox server only playing a few seconds of tracks..

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezebox server only playing a few seconds of tracks..

This topic contains 34 replies, has 5 voices, and was last updated by  rwanou premium 1 month, 4 weeks ago.

Viewing 30 posts - 1 through 30 (of 35 total)
  • 11. May 2017 at 13:04 #28790

    I am having an issue with both my Pi players ( Justboom and the Kali+Piano 2.1) when running the squeezelite player with a remote squeezebox server. They both work fine when using a local squeezebox server accessing a connected usb drive, but if using a remote/network server, only the first few seconds of a track is played then the player goes silent. They will sometimes play a full track or on occasion an album, then when you change album, it is back to the same behaviour of only playing a few seconds before going silent.

    I have tried everything I can think of, I have turned off everything except squeezelite on the Pi’s, but still the same problem. I can however play fine from the remote squeezebox server by using iPeng on my iPad and on my Mac, so server / signal doesn’t seem to be the problem.

    I would be grateful for any thoughts on how to solve this?

    12. May 2017 at 2:58 #28799

    Same problem here (Raspberry Pi with IQaudIO DigiAmp+)! But not only with a remote server. The music folder is on a Synology NAS, and the server is installed on the Max2Play player.

    • This reply was modified 4 months, 1 week ago by  MatthiasSt.
    12. May 2017 at 10:52 #28804

    Hi all,

    Could you please be more specific, which Max2Play version are you using ? Which pi are you using ? what is the network configuration ?

    Best Regards,
    Mohammad Mbydeen

    12. May 2017 at 11:33 #28806

    Raspberry Pi 3 Modell B
    IQaudIO DigiAmp+
    Raspberry Pi 7” Touch Display
    (this bundle:
    https://shop.max2play.com/de/raspberry-pi-bundle-7-display-iqaudio.html,
    newest version, arrived yesterday).
    Max2Play shows version 2.42.

    Created a mountpoint (CFIS) for the music folder (all Apple Lossless files) on my Synology NAS (DS116). Created a Logictech Mediaserver on the Pi (Nightly 7.9.1).

    The Pi is connected to the network via Ethernet/LAN, the Synology as well.

    When I start playing music in Squeezelite, very often it plays only a few seconds of the track, then there is no sound anymore. When I restart the track, it plays these few seconds again, and then again no sound anymore.

    In addition to that: Very short lapses/dropouts during playback (even when it manages to play a whole track or album).

    I hope you can help! 🙂

    • This reply was modified 4 months, 1 week ago by  MatthiasSt.
    • This reply was modified 4 months, 1 week ago by  MatthiasSt.
    12. May 2017 at 12:39 #28817

    Hi Mohammad

    Hardware /Software
    Player 1 : Pi 3B / Justboom Dac – Max2play (Justboom) 2.4.2 / Squeezelite (wifi)

    Player 2 : Pi 3B / Allo Kali + Piano2.1 – Max2Play (Allo) 2.4.2 / Squeezelite (tried both wifi & ethernet) / Squeeze Server 7.9 nightly – music on USB SSD.

    Player 3 : MacPro 2 / Squeezeplay ( ethernet ) this plays fine.

    Player 4 : iPad / iPeng (wifi) this plays fine.

    Remote server 1 : Player 2 above

    Remote server 2 : MacPro 1 / LMS 7.7.5 then updated to 7.9.1 – music on internal SSD.

    In use :

    Players 3 & 4 always work, whether connected to server 1 or 2.

    The Pi players only work with directly connected SSD, with either remote server (Pi or MacPro) tracks play for a couple of seconds then stop, try again same behaviour.

    Hope you can help 🙂

    • This reply was modified 4 months, 1 week ago by  anotbot.
    • This reply was modified 4 months, 1 week ago by  anotbot.
    • This reply was modified 4 months, 1 week ago by  anotbot.
    16. May 2017 at 13:35 #28874

    Hi all,

    Have you tried to add -s [server] [:port] in the commandline settings of Squeezelite Audio player page ?, this command is used to Connect to specified server, otherwise it will use autodiscovery to find the server.And we recommend you to use only ONE LMS in the setup.

    Could you please send us the debug info for each Squeezelite and Squeezebox server, you can find it on the bottom of the web-interface page.

    Best Regards,
    Mohammad Mbydeen

    • This reply was modified 4 months, 1 week ago by  Mbydeen.
    17. May 2017 at 14:41 #28887

    Hi Mohammad,

    I have added the -s [server] [:port] in the commandline settings as you suggested (I didn’t know the port, so I used only the server address).
    But still the same problem. I can reproduce the problem, because there are some tracks where it plays only a few seconds almost every time. Sometimes the time display of the track still continues to move, but it stays silent. Sometimes I can jump in the middle of the track and it will continue to play from there, sometimes not.
    I don’t think that the server connection is lost, because I can always navigate through my music folder and jump to other tracks instantly and they might (or might not) play normally.

    — Here is the debug info of the Squeezebox server (I have copied the info of the last couple of days only – please tell me if you need the full debug info):

    2017-05-15 19:29:15 squeezeboxserver_safe stopped.
    2017-05-15 19:30:24 squeezeboxserver_safe started.
    [17-05-15 19:30:34.0039] main::init (387) Starting Logitech Media Server (v7.9.1, 1494234793, Mon May 8 09:33:57 UTC 2017) perl 5.020002 – arm-linux-gnueabihf-thread-multi-64int
    [17-05-15 19:30:53.7934] Plugins::ShairTunes2::Plugin::publishPlayer (222) start avahi-publish-service “max2play”
    [17-05-15 20:01:08.0289] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 20:01:08.0532] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 20:31:28.4295] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 20:31:28.4550] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 21:00:47.1936] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 21:00:47.2146] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 21:01:38.9012] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 21:01:38.9183] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 21:31:41.8453] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 21:31:41.8756] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 22:01:45.4157] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-15 22:01:45.5007] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 01:31:57.2895] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /mnt/share/Haydn, Joseph (1732–1809)/Orchesterwerke/Konzerte/Konzert für Cembalo und Orchester in D-Dur Hob XVIII,11 · Koopman, Ton; Amsterdam Baroque Orchestra
    [17-05-16 01:31:57.3731] Slim::Utils::Scanner::Local::__ANON__ (193) Start processing found tracks
    [17-05-16 01:31:57.3745] Slim::Utils::Scanner::Local::__ANON__ (201) Connect do DB
    [17-05-16 01:31:57.3759] Slim::Utils::Scanner::Local::__ANON__ (204) Get latest ID
    [17-05-16 01:31:57.3779] Slim::Utils::Scanner::Local::__ANON__ (226) Delete temporary table if exists
    [17-05-16 01:31:57.3796] Slim::Utils::Scanner::Local::__ANON__ (229) Re-build temporary table
    [17-05-16 01:31:59.1019] Slim::Utils::Scanner::Local::__ANON__ (278) Get deleted tracks count
    [17-05-16 01:31:59.1031] Slim::Utils::Scanner::Local::__ANON__ (285) Get new tracks count
    [17-05-16 01:31:59.1050] Slim::Utils::Scanner::Local::__ANON__ (290) Get changed tracks count
    [17-05-16 01:32:01.2127] Slim::Utils::Scanner::Local::__ANON__ (296) Removing deleted audio files (0)
    [17-05-16 01:32:01.2145] Slim::Utils::Scanner::Local::__ANON__ (374) Scanning new audio files (0)
    [17-05-16 01:32:01.2162] Slim::Utils::Scanner::Local::__ANON__ (454) Rescanning changed audio files (3)
    [17-05-16 18:53:58.1198] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 18:53:58.2212] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 19:54:21.6071] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 19:54:21.7452] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 20:24:29.7009] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 20:24:29.7102] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 20:54:49.0005] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 20:54:49.0915] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 21:54:58.9609] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 21:54:59.0057] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 22:25:10.1982] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 22:25:10.2413] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 22:55:10.8795] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 22:55:11.0892] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 23:25:22.9840] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-16 23:25:23.0271] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 02:51:37.1724] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /mnt/share
    [17-05-17 02:51:47.1668] Slim::Utils::Scanner::Local::__ANON__ (193) Start processing found tracks
    [17-05-17 02:51:47.1681] Slim::Utils::Scanner::Local::__ANON__ (201) Connect do DB
    [17-05-17 02:51:47.1692] Slim::Utils::Scanner::Local::__ANON__ (204) Get latest ID
    [17-05-17 02:51:47.1712] Slim::Utils::Scanner::Local::__ANON__ (226) Delete temporary table if exists
    [17-05-17 02:51:47.1744] Slim::Utils::Scanner::Local::__ANON__ (229) Re-build temporary table
    [17-05-17 02:51:48.9359] Slim::Utils::Scanner::Local::__ANON__ (278) Get deleted tracks count
    [17-05-17 02:51:48.9371] Slim::Utils::Scanner::Local::__ANON__ (285) Get new tracks count
    [17-05-17 02:51:48.9389] Slim::Utils::Scanner::Local::__ANON__ (290) Get changed tracks count
    [17-05-17 02:51:50.9895] Slim::Utils::Scanner::Local::__ANON__ (296) Removing deleted audio files (0)
    [17-05-17 02:51:50.9907] Slim::Utils::Scanner::Local::__ANON__ (374) Scanning new audio files (0)
    [17-05-17 02:51:50.9919] Slim::Utils::Scanner::Local::__ANON__ (454) Rescanning changed audio files (0)
    2017-05-17 02:54:00 squeezeboxserver_safe stopped.
    2017-05-17 02:55:17 squeezeboxserver_safe started.
    [17-05-17 02:55:27.8045] main::init (387) Starting Logitech Media Server (v7.9.1, 1494234793, Mon May 8 09:33:57 UTC 2017) perl 5.020002 – arm-linux-gnueabihf-thread-multi-64int
    [17-05-17 02:57:05.9585] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:fb:1f:a9: request not dispatchable!
    [17-05-17 02:57:16.0847] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:fb:1f:a9: request not dispatchable!
    [17-05-17 02:57:48.7939] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:fb:1f:a9: request not dispatchable!
    [17-05-17 02:59:23.0575] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /mnt/share
    [17-05-17 02:59:23.1275] Slim::Utils::Scanner::Local::__ANON__ (193) Start processing found tracks
    [17-05-17 02:59:23.1288] Slim::Utils::Scanner::Local::__ANON__ (201) Connect do DB
    [17-05-17 02:59:23.1299] Slim::Utils::Scanner::Local::__ANON__ (204) Get latest ID
    [17-05-17 02:59:23.1319] Slim::Utils::Scanner::Local::__ANON__ (226) Delete temporary table if exists
    [17-05-17 02:59:23.1340] Slim::Utils::Scanner::Local::__ANON__ (229) Re-build temporary table
    [17-05-17 02:59:24.9177] Slim::Utils::Scanner::Local::__ANON__ (278) Get deleted tracks count
    [17-05-17 02:59:24.9189] Slim::Utils::Scanner::Local::__ANON__ (285) Get new tracks count
    [17-05-17 02:59:24.9207] Slim::Utils::Scanner::Local::__ANON__ (290) Get changed tracks count
    [17-05-17 02:59:26.9615] Slim::Utils::Scanner::Local::__ANON__ (296) Removing deleted audio files (0)
    [17-05-17 02:59:26.9629] Slim::Utils::Scanner::Local::__ANON__ (374) Scanning new audio files (0)
    [17-05-17 02:59:26.9640] Slim::Utils::Scanner::Local::__ANON__ (454) Rescanning changed audio files (0)
    2017-05-17 03:01:04 squeezeboxserver_safe stopped.
    2017-05-17 03:01:35 squeezeboxserver_safe started.
    [17-05-17 03:01:43.1248] main::init (387) Starting Logitech Media Server (v7.9.1, 1494234793, Mon May 8 09:33:57 UTC 2017) perl 5.020002 – arm-linux-gnueabihf-thread-multi-64int
    2017-05-17 03:02:21 squeezeboxserver_safe stopped.
    2017-05-17 03:02:21 squeezeboxserver_safe started.
    [17-05-17 03:02:28.7648] main::init (387) Starting Logitech Media Server (v7.9.1, 1494234793, Mon May 8 09:33:57 UTC 2017) perl 5.020002 – arm-linux-gnueabihf-thread-multi-64int
    2017-05-17 03:07:02 squeezeboxserver_safe stopped.
    2017-05-17 03:08:10 squeezeboxserver_safe started.
    [17-05-17 03:08:20.2594] main::init (387) Starting Logitech Media Server (v7.9.1, 1494234793, Mon May 8 09:33:57 UTC 2017) perl 5.020002 – arm-linux-gnueabihf-thread-multi-64int
    [17-05-17 03:15:53.8508] Plugins::ShairTunes2::Plugin::publishPlayer (222) start avahi-publish-service “max2play”
    [17-05-17 03:16:15.1239] Plugins::ShairTunes2::Plugin::publishPlayer (222) start avahi-publish-service “max2play”

    #### PERL VERSION ####
    v5.20.2

    — And here is the Squeezelite debug info:

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=IQaudIODAC -a 80:4:: -o hw:CARD=IQaudIODAC -V Digital -s 192.168.178.48
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=IQaudIODAC -t hardware -m hw:CARD=IQaudIODAC -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    sysdefault:CARD=ALSA – bcm2835 ALSA, bcm2835 ALSA – Default Audio Device
    dmix:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample mixing device
    dmix:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample mixing device
    dsnoop:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct sample snooping device
    dsnoop:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct sample snooping device
    hw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Direct hardware device without any conversions
    hw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Direct hardware device without any conversions
    plughw:CARD=ALSA,DEV=0 – bcm2835 ALSA, bcm2835 ALSA – Hardware device with all software conversions
    plughw:CARD=ALSA,DEV=1 – bcm2835 ALSA, bcm2835 IEC958/HDMI – Hardware device with all software conversions
    default:CARD=IQaudIODAC – IQaudIODAC, – Default Audio Device
    sysdefault:CARD=IQaudIODAC – IQaudIODAC, – Default Audio Device
    dmix:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Direct sample mixing device
    dsnoop:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Direct sample snooping device
    hw:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Direct hardware device without any conversions
    plughw:CARD=IQaudIODAC,DEV=0 – IQaudIODAC, – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed

    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed

    Thanks very much in advance for helping!

    18. May 2017 at 14:00 #28923

    Hi Mohammad,

    I have also tried using the LMS on the Pi and get exactly the same results and using -s livingroom.local makes no difference.

    If however I try and add the port :9000 or [:9000] I either get a command line error, or if it works, all the players disappear from my controller… so that doesn’t work either…

    Here is the debug from the Pi max2play server :

    #### SQUEEZESERVER LOG ####
    [17-05-17 18:41:25.7579] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-17 18:51:29.8389] Slim::Formats::readTags (166) File missing: /media/usb/Music/Compilations/Five Hand Reel _ For A’ That _ Earl O’Moray/2-17 Freedom Come-All-Ye.m4a
    [17-05-17 18:52:15.9128] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed:
    [17-05-17 18:53:04.3483] Slim::Player::Protocols::File::open (102) Error: could not open /media/usb/Music/Compilations/Five Hand Reel _ For A’ That _ Earl O’Moray/2-17 Freedom Come-All-Ye.m4a: No such file or directory
    [17-05-17 18:53:04.3497] Slim::Player::Song::open (471) Warning: stream failed to open [tmp:///media/usb/Music/Compilations/Five%20Hand%20Reel%20_%20For%20A%27%20That%20_%20Earl%20O%27Moray/2-17%20Freedom%20Come-All-Ye.m4a].
    [17-05-17 18:53:12.2227] Slim::Player::Protocols::File::open (102) Error: could not open /media/usb/Music/Compilations/Five Hand Reel _ For A’ That _ Earl O’Moray/2-17 Freedom Come-All-Ye.m4a: No such file or directory
    [17-05-17 18:53:12.2234] Slim::Player::Song::open (471) Warning: stream failed to open [tmp:///media/usb/Music/Compilations/Five%20Hand%20Reel%20_%20For%20A%27%20That%20_%20Earl%20O%27Moray/2-17%20Freedom%20Come-All-Ye.m4a].
    [17-05-17 18:53:15.8443] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /usr/share/perl5/Slim/Networking/IO/Select.pm line 134.
    [17-05-17 18:54:14.9176] Slim::Utils::Timers::__ANON__ (273) Error: Timer Slim::Web::Cometd::sendResponse failed: illegal file descriptor or filehandle (either no attached file descriptor or illegal value): at /usr/share/perl5/Slim/Networking/IO/Select.pm line 134.
    [17-05-17 19:58:30.0733] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 19:58:30.1036] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 20:58:28.6592] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 20:58:28.6915] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 21:58:27.2543] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-17 21:58:27.2988] Slim::Plugin::UPnP::Events::error (323) Subscribe/unsubscribe error: 412 Precondition Failed
    [17-05-18 09:03:29.8931] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 09:03:34.9497] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    [17-05-18 09:03:40.0044] Slim::Web::JSONRPC::requestMethod (443) b8:27:eb:d3:61:3a: request not dispatchable!
    2017-05-18 09:08:11 squeezeboxserver_safe stopped.
    2017-05-18 12:16:27 squeezeboxserver_safe started.
    [17-05-18 12:16:32.3580] main::init (387) Starting Logitech Media Server (v7.9.1, 1493198727, Sat Apr 29 04:38:50 UTC 2017) perl 5.020002 – arm-linux-gnueabihf-thread-multi-64int
    [17-05-18 12:16:36.8669] Plugins::NPRRadio::Metadata::init (21) Register NPR meta provider, default icon=
    [17-05-18 12:27:32.7936] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-18 12:32:14.0424] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12
    [17-05-18 12:32:24.1567] Slim::Networking::Discovery::Players::_players_error (146) Unable to get players: Timed out waiting for data
    [17-05-18 12:41:24.0725] Slim::Networking::Slimproto::client_readable (414) Client not found for slimproto msg op: STAT from 192.168.0.12

    #### PERL VERSION ####
    v5.20.2

    Server currently works fine with the local player on the same Pi (kalli/piano), but only plays first couple of seconds of tracks when server being used by the remote pi (just boom).

    18. May 2017 at 14:29 #28925

    The same here: When adding the port number (9000) to the -s command, the player disappears from the iPeng App and from the web interface.

    22. May 2017 at 10:58 #28981

    Found the solution – I changed to PiCorePlayer and it just works, sounds better and has more advanced options for tweaking.

    22. May 2017 at 12:01 #28993

    Thanks for the info! Is there a way to install PiCorePlayer without having to re-format the SD card?

    22. May 2017 at 12:16 #28994

    no, but just format as fat32 and master boot record and then use etcher or what ever you used previously… or buy another SD card if you want to keep your existing card.

    Once you get the card written, just pop it in the pi, start it up and then use Fing or similar to get the Pi’s address, pop that in your web browser. Go to squeezelite page, select your DAC and restart Squeezelite… now go to wifi page put in your network details and switch on Pi wifi if using that and restart… restart Pi and probably good idea to restart your LMS server at this point… and that should be you. At the bottom the PiCorePlayer page there are some additional tabs – there is an advanced one that gives access to many more features and lets you add shairport if you need it. You can also add LMS and if you want to play with the DSP filters you can access those on the Squeezelite page.

    Main thing though is my players now work fine over wifi… I suspect there is a bug in Max2Play that was causing our problem. I also suspect that the driver for my Allo Piano 2.1 DAC isn’t working correctly in 2.0 mode and is why I’m now getting the bass that was missing.

    Good luck… oh there is a really helpful forum for PiCore there is a link on web interface 🙂

    • This reply was modified 4 months ago by  anotbot.
    22. May 2017 at 15:22 #29002

    Thank you so much! It’s working fine now with PiCorePlayer and the installation was easy! The only thing is: I can’t get ShairTunes working, but I’ll figure it out somehow. The Logitech Media Server is installed on my Synology NAS – maybe ShairTunes works only if I install it directly on the Pi? I don’t like the Shairport solution, because the airplayed tracks don’t show up in the player on the touch screen.

    22. May 2017 at 15:32 #29003

    No problem, glad you got it working. Have you tried the forum : http://forums.slimdevices.com/showthread.php?107352-Announce-piCorePlayer-3-20

    22. May 2017 at 18:48 #29007

    I have now installed LMS directly on the Pi (with the NAS as network mount point), activated ShairTunes2 and it works instantly. 🙂 Great!

    22. May 2017 at 19:28 #29012

    That’s great! I must give Sharetunes a look 🙂

    21. July 2017 at 23:35 #30039

    hi,

    I’m having exactly the same problem with some of my files. I didn’t test all, but it seems to be a problem only with the Apple Lossless files, and not all of them, only some. Stopping the player and restarting usually fixes the problem. Navigating in a song is almost always synonym of failure.

    Your solution is to run the agents on PiCorePlayer? Are you still using max2play for the server? My card is justBoom amp, i guess it’s supported by default. And I have another specificity, I need to run 2 agents on the same pi so I can use 2 speakers in 2 different rooms (mono each of them), would that still be possible? You guys confirm that it is still possible to use airplay with your squeezelite instances.

    If max2play can’t handle ALC files without issues, I don’t really see the point of paying a license for the multisqueeze plugin.

    Now, alternatively, did someone try to use the latest squeezelite release on a M2P instance?

    22. July 2017 at 16:47 #30043

    Hi rwanou,
    PiCorePlayer completely replaces the Max2Play system on my Pi. My Logitech Media Server is installed directly on the SD card in my Pi. The music folder is on a Synology NAS.
    There shouldn’t be any problem though, if the LMS is installed on a Max2Play device in your network. The PiCorePlayer should be able to access it without problems.

    AirPlay with Shairtunes for LMS works fine for me when LMS is installed directly on the Pi with PiCorePlayer. However, it did not work for me when I installed LMS directly on the Synology NAS instead.
    PiCorePlayer also has a Shairport option, so this would work in any case, but I don’t like Shairport because the album covers are not displayed on my Pi touch screen when using Shairport.

    I don’t know if it’s possible to have two agents installed on one Pi.

    23. July 2017 at 11:17 #30048

    Thanks for the confirmation. I will investigate about 2 agents on one PiCorePlayer, but actually, for my needs I could keep max2play on at least one of my pis to benefit some other plugins. I guess I can live with my bathroom having downgraded Apple Losseless files by using the -e alac option (cf. https://www.max2play.com/en/forums/topic/odd-behaviors-with-audio-playback/). Quality is just important for my living room with the JustBoom zero DAC that streams to the HiFi system.

    24. July 2017 at 16:21 #30090

    Hi guys,

    @Matthias: I am not sure what exactly the point of your argument for the PiCore Player is here. The same features are available on Max2Play. It is definitely possible to have two, or several more shairports on one Max2Play device. In fact, we have a premium plugin for just that purpose: https://www.max2play.com/en/portfolio/pluginmultishairport/

    @rwanou: The issues with these files are probably related to their specific rights and properties. Please make sure these are standard and do not have special file safety restrictions as this is the cause of 99 percent of all file issues with the Squeezebox system.

    24. July 2017 at 16:32 #30091

    The reason is simple – PiCore Player just works – Max2Play doesn’t.

    I wasted a week trying then finally switched. I and others asked for help with this same problem – the solution was to move to PiCore Player.

    Perhaps you should try and solve the problem as there must be a bug…

    • This reply was modified 1 month, 4 weeks ago by  anotbot.
    24. July 2017 at 17:06 #30093

    Hi anotbot,

    What issue exactly are you referring to?

    24. July 2017 at 17:15 #30095

    Hi Heiner,

    My argument for PiCorePlayer is the same as anotbot’s: Max2Play has a bug. When playing from a network source (Logitech Media Server) it often plays only the first few seconds of a track and then goes silent – even if LMS is installed directly on the SD card in the Pi and only the music folder is on a network drive. PiCorePlayer doesn’t have this bug and just works.

    It has nothing to do with Airplay. The Airplay question was a different question that rwanou had.

    24. July 2017 at 17:19 #30097

    I can try to make some tests an compare PiCorePlayer and max2play with the same ALAC files, but I’m afraid the file itself is not the issue. I suspect high bitrates to fail more easily than more modest ones. Sometimes closing the player (there is a on/off button for each instance in the main player page) and starting the song ones more fixes the issue. Maybe something to do with the buffer size? I should also state that I had the issue with a wired connection, no crappy Wifi involved.

    As stated in this forum, it is always possible to disable ALAC codec, which means the file is converted into FLAC (ASFAIK), but with a lower bitrate. This is not acceptable for my living room player (piZero with JustBoom DAC hat), but I don’t believe I will hear any difference on my mono speaker from the bathroom, or the 2 non-hifi speakers in the office. I’ll try to keep the best of 2 worlds.

    So max2play is still handy here, for the ease of configuration, and the ability to have 2 squeezelite instances on one pi, but the alac bug is a deal breaker for people with a large Apple Lossless collection.

    24. July 2017 at 17:24 #30099

    Same here. No WiFi connection, I use LAN connection. I am not sure if the problem is only with ALAC files. I think I remember I had the same issue with FLAC and MP3s, but I’m not sure about this.

    24. July 2017 at 17:26 #30100

    Okay, thanks for clearing this up. The problem with this purported bug, is that amongst the whole community of Max2Play it is only experienced by a few. In addition, the LMS depends on the Pi’s workload in combination with the size and variation of your music libary. These factors first and foremost command the smoothness with which the LMS runs. Also, we recently added support for the new LMS 7.9 and trying to phase out the nightly uses as they can also cause issues.
    For most users, there is no problem whatsoever with LMS under Max2Play. For some, a little tweaking of the settings might be necessary. For others, an entirely different issue might be the root problem and can be determined here based on a few questions of mine. Usually, I pride myself on our community’s quick responses and open interaction which results in 99 percent of all issues being solved rather quickly. However, here the issue is more vague. You can check the vitals of Pi when first indexing the LMS with your library in the Settings/Reboot menu. Yet, I assume you are interested in further trouble shooting as seem to have found your solution.
    Nonetheless, I would appreciate it if other users could still get the chance to find out their actual issue instead of jumping to another platform. This is always a possible solution, but not one they need to navigate to the Max2Play forums for.

    24. July 2017 at 17:33 #30103

    As I was saying earlier, I will still be using max2play as the ease of config (although it’s a geek tool designed by geeks that could benefit some ergonomic simplification) and the extended plugins make it very useful. The multisqueeze plugin is essential for me as I can now stream 2 different rooms with only one pi.

    I can provide you the files that produce the issues. I’m still settling in, so I haven’t had time to listen to my 120G of music yet, but I spotted some that definitely trigger the problem.

    24. July 2017 at 17:35 #30104

    Heiner, if you read up the thread you will see that I started it – and I spent a week answering questions and tweaking on this and on another thread on this site and got nowhere.

    The only thing I changed to have a working solution was from Max2Play to PiCore Player – both based on LMS… and my Server hasn’t been changed at all. So I think it is fair to say that Max2Play has an issue / bug that does not exist in PiCore Player.

    24. July 2017 at 18:56 #30107

    I can only agree with anotbot – I had exactly the same issue. Switching from Max2Play to PiCore Player instantly solved the problem – both with exactly the same LMS, exactly the same server with exactly the same settings. All suggestions to solve the problem when using Max2Play failed.

    24. July 2017 at 19:02 #30108

    You said “This is always a possible solution, but not one they need to navigate to the Max2Play forums for.”
    I have to disagree, because this is a Max2Play issue, so it belongs here. And if jumping to a different platform is the only known solution that works, it belongs here, too.

Viewing 30 posts - 1 through 30 (of 35 total)

You must be logged in to reply to this topic.

Register here