nipape

Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Posted in:
  • 21. Juni 2019 at 15:59 #45892

    Ok, so I managed to make it work by:

    – ssh connecting to the max2play device,
    – run ‚amixer set Digital unmute‘.

    21. Juni 2019 at 11:18 #45889

    I reinstalled everything from scratch, and it still doesn’t work even through I’m back to the „no error“ logs:

    #### Librespot Output ####
    INFO:librespot: librespot 431be9e (2018-05-18). Built on 2018-05-30. Build ID: YlMJ8i49
    INFO:librespot_core::session: Connecting to AP „gew1-accesspoint-a-jq5f.ap.spotify.com:4070“
    INFO:librespot_core::session: Authenticated as „####################“ !
    INFO:librespot_playback::audio_backend::alsa: Using alsa sink
    INFO:librespot_core::session: Country: „FR“
    INFO:librespot_playback::player: Loading track „Creep“ with Spotify URI „spotify:track:6b2oQwSGFkzsMtQruIWm2p“
    INFO:librespot_playback::player: Track „Creep“ loaded

    It’s indeed the hifiberry device selected. I disabled bluetooth and stopped by default all the other audio players.

    Regarding spotty, I’m afraid I’m not sure I want a dependency on squeezebox. I’d rather have a set-up as light as possible and I was happy with the spotify connect plugin when it was working.

    • This reply was modified 1 year, 8 months ago by  nipape.
    20. Juni 2019 at 22:56 #45885

    I now get this error

    ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
    ERROR:librespot_playback::audio_backend::alsa: Alsa error PCM open -19
    ERROR:librespot_playback::player: Could not start audio: Alsa error: PCM open failed

    20. Juni 2019 at 18:46 #45882

    Hi,

    Thx for the reply and apologies for the late answer.

    I managed to make it work by installing from scratch on a temporary SDCard. But when installing again on another it doesn’t work anymore.

    Here are the logs from the DEBUG:

    #### Librespot Output ####
    INFO:librespot: librespot 431be9e (2018-05-18). Built on 2018-05-30. Build ID: YlMJ8i49
    INFO:librespot_core::session: Connecting to AP „gew1-accesspoint-a-khl6.ap.spotify.com:4070“
    INFO:librespot_core::session: Authenticated as „######################“ !
    INFO:librespot_playback::audio_backend::alsa: Using alsa sink
    INFO:librespot_core::session: Country: „FR“
    INFO:librespot_playback::player: Loading track „Trois nuits par semaine“ with Spotify URI „spotify:track:3X9XJLwQPWqRnsNaL9z6ss“
    INFO:librespot_playback::player: Track „Trois nuits par semaine“ loaded
    INFO:librespot_playback::player: Loading track „Un été français“ with Spotify URI „spotify:track:4Ngeca4zs304bDnDh3pjzI“
    INFO:librespot_playback::player: Track „Un été français“ loaded
    INFO:librespot_playback::player: Loading track „Un été français“ with Spotify URI „spotify:track:4Ngeca4zs304bDnDh3pjzI“
    INFO:librespot_playback::player: Track „Un été français“ loaded

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing
    Usage: /opt/spotifyconnect/librespot [options]

    Many thanks for your help.

    • This reply was modified 1 year, 8 months ago by  nipape.
    13. Juni 2019 at 13:59 #45731

    Hi,

    I’m also having no sound issue with the spotify connect plugin. Even through it’s running and I can select it in the Spotify app, there is no sound. It used to work the few first times.

    There is no other audio player running, I closed the squeezebox server, disabled the build-in audio.

    Hardware: HifiBerry Amp2 + RP3B+

    Thx for any help

Viewing 5 posts - 1 through 5 (of 5 total)