[SOLVED] Spotify connect problems

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify connect problems

This topic contains 40 replies, has 8 voices, and was last updated by  Heiner Moderator 2 days, 1 hour ago.

Viewing 11 posts - 31 through 41 (of 41 total)
  • 21. März 2018 at 10:30 #34589

    Hi Stefan,

    The latter output is that of a working system. Please make sure your other players are not occupying the output device you want to use.

    24. März 2018 at 1:54 #34710

    hi, Heiner – Spotify Connect has been stable and working well for the last two weeks. If we run into trouble we will update to beta and reinstall Spotify Connect. Thanks for all your help.

    11. Oktober 2018 at 8:13 #38541

    Since the time, I have been reading news the things are going normal for me.
    Men a Liet

    13. Juni 2019 at 13:59 #45731

    Hi,

    I’m also having no sound issue with the spotify connect plugin. Even through it’s running and I can select it in the Spotify app, there is no sound. It used to work the few first times.

    There is no other audio player running, I closed the squeezebox server, disabled the build-in audio.

    Hardware: HifiBerry Amp2 + RP3B+

    Thx for any help

    14. Juni 2019 at 9:14 #45746

    Hi nipape,

    Can you copy the debug info log from the plugin here? Also, have you tried Spotty and encountered the same issue, yet?

    20. Juni 2019 at 18:46 #45882

    Hi,

    Thx for the reply and apologies for the late answer.

    I managed to make it work by installing from scratch on a temporary SDCard. But when installing again on another it doesn’t work anymore.

    Here are the logs from the DEBUG:

    #### Librespot Output ####
    INFO:librespot: librespot 431be9e (2018-05-18). Built on 2018-05-30. Build ID: YlMJ8i49
    INFO:librespot_core::session: Connecting to AP „gew1-accesspoint-a-khl6.ap.spotify.com:4070“
    INFO:librespot_core::session: Authenticated as „######################“ !
    INFO:librespot_playback::audio_backend::alsa: Using alsa sink
    INFO:librespot_core::session: Country: „FR“
    INFO:librespot_playback::player: Loading track „Trois nuits par semaine“ with Spotify URI „spotify:track:3X9XJLwQPWqRnsNaL9z6ss“
    INFO:librespot_playback::player: Track „Trois nuits par semaine“ loaded
    INFO:librespot_playback::player: Loading track „Un été français“ with Spotify URI „spotify:track:4Ngeca4zs304bDnDh3pjzI“
    INFO:librespot_playback::player: Track „Un été français“ loaded
    INFO:librespot_playback::player: Loading track „Un été français“ with Spotify URI „spotify:track:4Ngeca4zs304bDnDh3pjzI“
    INFO:librespot_playback::player: Track „Un été français“ loaded

    #### Librespot Command Line Options ####
    error: Required option ’name‘ missing
    Usage: /opt/spotifyconnect/librespot [options]

    Many thanks for your help.

    • This reply was modified 5 days, 20 hours ago by  nipape.
    20. Juni 2019 at 22:56 #45885

    I now get this error

    ALSA lib pcm_hw.c:1713:(_snd_pcm_hw_open) Invalid value for card
    ERROR:librespot_playback::audio_backend::alsa: Alsa error PCM open -19
    ERROR:librespot_playback::player: Could not start audio: Alsa error: PCM open failed

    21. Juni 2019 at 11:11 #45886

    Hi nipape,

    The new error indicates that you have the wrong parameters for your sound card. Make sure you have the right output device selected and please paste any other parameters of the player here as well. It looks like Spotify is using the built-in Pi sound card instead of the amp. Check to see that „sysdefault_hifiberry…“ is selected and no other player is running concurrently with the same card.

    Also, as I’ve mentioned, the Squeezebox Server solution Spotty is a great multiroom-capable alternative that also supports Spotify Connect.
    Here’s a tutorial on setting it up

    21. Juni 2019 at 11:18 #45889

    I reinstalled everything from scratch, and it still doesn’t work even through I’m back to the „no error“ logs:

    #### Librespot Output ####
    INFO:librespot: librespot 431be9e (2018-05-18). Built on 2018-05-30. Build ID: YlMJ8i49
    INFO:librespot_core::session: Connecting to AP „gew1-accesspoint-a-jq5f.ap.spotify.com:4070“
    INFO:librespot_core::session: Authenticated as „####################“ !
    INFO:librespot_playback::audio_backend::alsa: Using alsa sink
    INFO:librespot_core::session: Country: „FR“
    INFO:librespot_playback::player: Loading track „Creep“ with Spotify URI „spotify:track:6b2oQwSGFkzsMtQruIWm2p“
    INFO:librespot_playback::player: Track „Creep“ loaded

    It’s indeed the hifiberry device selected. I disabled bluetooth and stopped by default all the other audio players.

    Regarding spotty, I’m afraid I’m not sure I want a dependency on squeezebox. I’d rather have a set-up as light as possible and I was happy with the spotify connect plugin when it was working.

    • This reply was modified 5 days, 3 hours ago by  nipape.
    21. Juni 2019 at 15:59 #45892

    Ok, so I managed to make it work by:

    – ssh connecting to the max2play device,
    – run ‚amixer set Digital unmute‘.

    24. Juni 2019 at 13:13 #45904

    very odd, this should be the default when selecting the Amp2. Glad you got it working though 🙂

Viewing 11 posts - 31 through 41 (of 41 total)

You must be logged in to reply to this topic.

Register here