[SOLVED] Wifi connection issues

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Wifi connection issues

Tagged: ,

This topic contains 17 replies, has 2 voices, and was last updated by  Heiner Moderator 6 months, 1 week ago.

Viewing 18 posts - 1 through 18 (of 18 total)
  • 28. Februar 2018 at 17:09 #34147

    Hello,

    Since I started using max2play I have problems with wifi setup on a Raspberry 3. Initally I started with release 241 and I couldn’t connect to a wifi with a hidden SSID. The issue was never solved.

    Today I have downloaded 244 and I expected to have the wifi issues solved. I have discovered the new setup process with the hotspot mode and this is great, but the Max2Play cannot find the wifi SSID. The SSID is visible, but it’s not discovered by Max2Play.
    As happened before with 421 release, Max2Play doesn’t work setting my wifi SSID manually.

    This is very disappointing. The hardware works perfectly with other sw Raspberry free distributions, but not with Max2Play.

    Thanks for your help.

    Best regards

    28. Februar 2018 at 17:21 #34148

    Hi contax,

    Sorry about the inconvenience. Could you share the debug info log of your WiFi/LAN menu? Also, could you try WPS?

    1. März 2018 at 10:28 #34155

    Hello Heiner,

    Thanks for your quick answer. Finally I could set-up one wifi lan. Firts I shared my phone wifi and could use this network activate max2play. After that, I scanned wifi networks again and my 2,4GHz SSID was discovered. Not the 5GHz SSID.
    Now I and using this 2,4GHz SSID. My phone discovers 4 SSIDs and Max2Play only 2. I do not know if the built-in adapter is compatible with 5GHz networks. Do you know it?

    Now I am experiencing problems starting the squeezebox server. The message is always the same „Trying lo launch… NOT successful. Detailed information sudo: no tty present and no askpass program specified“

    Thanks for your help.

    Best regards

    1. März 2018 at 13:54 #34161

    Hi contax,

    Should be 2,4GHz only. (Source)
    Regarding LMS, could you share the debug info when trying to start?

    1. März 2018 at 14:46 #34162

    Hello Heiner,

    How can I get the log?. I have not seen the option in the squeezebox server settings screen.

    Best regards

    2. März 2018 at 13:00 #34177

    Hi contax,

    It’s in the web interface menu of Squeezebox Server at the end of the page.

    5. März 2018 at 17:11 #34222

    Hello Heiner,

    This is what I see in the debug window

    #### SQUEEZESERVER LOG ####

    #### PERL VERSION ####
    v5.20.2

    Best regards

    5. März 2018 at 17:18 #34223

    Hello Heiner,

    And the other message I sent

    Trying to launch … NOT successful Click here to show detailed information

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

    sudo: no tty present and no askpass program specified

    5. März 2018 at 17:24 #34224

    Hi contax,

    The issue seems to be related to the version 7.9 nightly of LMS. Please try installing the 7.9 proper version.

    5. März 2018 at 17:47 #34226

    This is the result of the installation

    Installation Progress: (startet 2018-03-05 16:20) 2018-03-05 16:20|
    –2018-03-05 16:20:07– http://downloads.slimdevices.com/nightly/7.9/sc/a141d03b6489a3a1c65eebc34213e809d1c95df4/logitechmediaserver_7.9.1~1519287262_arm.deb
    Resolving downloads.slimdevices.com (downloads.slimdevices.com)… 13.33.232.149, 13.33.232.140, 13.33.232.85, …
    Connecting to downloads.slimdevices.com (downloads.slimdevices.com)|13.33.232.149|:80… connected.
    HTTP request sent, awaiting response… 200 OK
    Length: 41495438 (40M) [text/plain]
    Saving to: ‘/opt/max2play/lms.deb’

    0K ………. ………. ………. ………. ………. 0% 79.2K ]
    30800K ,,,,,,,,,, ,,,,,,,,,, ,……… ………. ………. 76% 52.8K
    38600K ……….

    7. März 2018 at 11:23 #34255

    Hi contax,

    Thanks for sharing. Did you try installing the proper 7.9 version, yet?

    8. März 2018 at 11:52 #34275

    Hello Heiner,

    I do not know what is the proper version. LMS v.7.9.0 OR Nightly 7.9. I have reflashed the SD card again but the result is the same. Furthermore I don’t know if I can install one version and after the other. I did this before with the same results. I am going to re-flash the SD card twice more, one trying LMS v.7.9 and the other Nightly 7.9

    I have experienced the same issues with the wifi. It’s is not working fine. When I start, in AP mode, I can only join to my mobile phone wifi. My wifi connection is not showed after the scan.
    After being connected to the phone wifi, I re-scan the networks and my network SSID is showed and I can join it. Clearly there are problems with the built-in wifi adapter and Max2Play.

    Best regards

    • This reply was modified 6 months, 2 weeks ago by  contax.
    8. März 2018 at 16:20 #34283

    Hello Heiner,

    I have installed the beta version and the results are the same. I cannot start LMS 7.9 neither nightly.

    Best regards

    9. März 2018 at 16:39 #34298

    Hi contax,

    Sorry about the inconvenience, obviously this should be much simpler.

    – By proper I meant non-nightly. Both work fine but the nightly recently changed its repo which resulted in the first error message you posted. This is fixed now and both versions should install fine.

    – The WiFi should work out of the box but the Pi’s antenna is not the greatest. Perhaps try connecting nearby your router for first setup. You can also try using WPS for connecting.

    – There’s a difference between our beta image and our beta update. Beta version is based on Raspbian Stretch while beta update just adds our most recent bug fixes and changes which have not been officially released yet. However, LMS install should not even require a beta update at this point.

    Please check your free space to rule it out as an error. You can see it in the Settings/Reboot Debug Info. You can also check the Health Checker there to make sure your Pi is running fine.

    12. März 2018 at 19:01 #34353

    Hi Heiner,

    So, I understand I should download 244 re-flash the card again. After I must install LMS or nightly because it’s solved.

    I will comment the results.

    Thanks again for your help.

    Best regards,
    Mario

    13. März 2018 at 15:39 #34396

    Hi Mario,

    Yes, for nightly you first need to make a beta update under „Settings/Reboot“

    16. März 2018 at 19:05 #34484

    Hello Heiner,

    I have reflashed the SD card with the 244 version. Installing LMS 7.9 first, everything works.

    Thanks again for your help.

    Best regards,
    Mario

    19. März 2018 at 13:22 #34528

    Hi Mario,

    Thanks for following up! 🙂

    I’ll mark the topic as closed.

Viewing 18 posts - 1 through 18 (of 18 total)

You must be logged in to reply to this topic.

Register here