[SOLVED] Volume Control with Squeezlite and JustBoom Amp

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Volume Control with Squeezlite and JustBoom Amp

This topic contains 8 replies, has 3 voices, and was last updated by  Heiner Moderator 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 24. Juni 2017 at 17:29 #29706

    Hello,

    I’m running a speaker with a raspberryPi, Justboom Amp soundcard, the rotary encoder and Max2Play.
    The speaker ist working fine and I can start and stop playback using the button included in the rotary encoder.

    Problem:
    When I turn the rotary encoder, playback stops (turning direction doesn’t matter). If I start and stop playback with the rotary encoder, it works again. If I use an app to control the Logitech Media Server the player is attached to and change the volume of the speaker, playback starts again after turing the rotary encoder. The problem occured after I changed the rotary encoder start options to decrease the volume steps. The settings have been reset, but I couldn’t get the funtionality back.

    Settings:
    ========
    Rotary Encoder start options:
    -c hw:0 -m Digital –gpiorot=24,23

    ———————————-
    squeezelite

    ALSA Parameter
    80:4::

    Advanced command line options
    -s <servername> -o hw:CARD=sndrpijustboomd -V Digital -Q -X 25

    DEBUG INFORMATION
    #### SQUEEZELITE VERSION ####
    Squeezelite Max2Play v1.0.2 based on v1.8.4-726, Copyright 2012-2015 Adrian Smith, 2015-2016 Ralph Irving.

    #### SQUEEZELITE BUILDOPTIONS ####
    Build options: LINUX ALSA EVENTFD RESAMPLE FFMPEG VISEXPORT IR GPIO DSD CONTROLSBS ALSASYNC BLUETOOTHSYNC

    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=sndrpijustboomd -a 80:4:: -s <servername> -o hw:CARD=sndrpijustboomd -V Digital -Q -X 25
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d sysdefault:CARD=sndrpijustboomd -t hardware -m hw:CARD=sndrpijustboomd -c Digital
    USE_USB_DAC=0
    USE_EQUALIZER=1
    SYSTEM_USER=pi
    YMPD_PARAMETER=–webport 8081

    #### SQUEEZELITE -l ####
    Output devices:
    null – Discard all samples (playback) or generate zero samples (capture)
    pulse – PulseAudio Sound Server
    equal
    plugequal – Equalizer for plughw:0,0
    default:CARD=sndrpijustboomd – snd_rpi_justboom_dac, – Default Audio Device
    sysdefault:CARD=sndrpijustboomd – snd_rpi_justboom_dac, – Default Audio Device
    dmix:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_dac, – Direct sample mixing device
    dsnoop:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_dac, – Direct sample snooping device
    hw:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_dac, – Direct hardware device without any conversions
    plughw:CARD=sndrpijustboomd,DEV=0 – snd_rpi_justboom_dac, – Hardware device with all software conversions

    #### SHAIRPORT VERSION ####
    2.8.0-openssl-Avahi-ALSA-soxr

    #### OUTPUT SOUND DETAILS CARD 0 ####
    access: RW_INTERLEAVED
    format: S32_LE
    subformat: STD
    channels: 2
    rate: 44100 (44100/1)
    period_size: 882
    buffer_size: 3528

    #### OUTPUT SOUND DETAILS CARD 1 ####
    ======================================

    Thank you for your help!

    26. Juni 2017 at 11:24 #29720

    Hi Lowrider,

    Could you try burning a fresh image to see whether the problem will persist?

    26. Juni 2017 at 21:36 #29729

    Can I save the current Settings somehow? This would save some work.

    28. Juni 2017 at 15:27 #29749

    For the LMS settings you can simply copy the /var/lib/squeezeboxserver/ directory to a USB drive and then copy it back to your new image.

    For a whole backup, you can use our image burner plugin: https://www.max2play.com/en/wiki/creating-an-image-backup/

    29. Juni 2017 at 13:58 #29763

    Hello Heiner,

    thank you for your suggestions. I decided to reset the settings manually, wasn’t much effort in the end.
    The good news: your tip did the trick, now everything works perfectly again.

    One question: How can I reduce the steps in volume when turning the knob? I still feel they are too big.

    Tim

    9. Juli 2017 at 21:17 #29862

    Hello everyone,

    I found an easy way to adjust the volume steps / increments of the rotary encoder.

    In the rotary encoder start options just add „–inc=40“ at the end. Change the value if you prefer different increment sizes. Be aware that INCREASING the number, DECREASES the volume increment and vice versa. Who knows why, but it works so I stoped worrying.

    Here is my start option line:

    -c hw:0 -m Digital –gpiorot=24,23 –vol=60 –inc=40

    Greets
    Tim

    @heiner: Could you mark this topic as solved? I couldn’t find a way to do this. Thanks!

    10. Juli 2017 at 17:58 #29880

    Hi Lowrider,

    Thanks for the detailed shared solution and feedback! We appreciate the follow-up very much.

    13. Juni 2018 at 19:59 #36191

    Hi…in my case Volume control data it supposed to be sent through linux system driver with usb to custom Xmas card and then to ES9018k2m chip with I2C.You you know how i can setup my squeezebox and squeeze lite to run with it ?I did a test with DSD because it is the only way for me to be sure that this hardware volume control works or not.Do you know if there is something to do in asound.conf to bind the squeezelite / squeezebox volume control on the linux system volume control for it to work ?

    18. Juni 2018 at 11:39 #36234

    Hi Buchsung,

    If its a USB sound card, you need to select the USB sound card setting in the Raspberry Settings and reboot (Premium Plugin).

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here