Using the ODROID C1+ with touchdisplay and hifi-shield on Max2Play

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 Using the ODROID C1+ with touchdisplay and hifi-shield on Max2Play

This topic contains 46 replies, has 8 voices, and was last updated by  Bristow premium 4 years, 4 months ago.

Viewing 17 posts - 31 through 47 (of 47 total)
  • 29. Oktober 2015 at 12:23 #16606

    I think you have to do this what flyserver said just before your post:

    UPDATE: I added a switch to the latest Beta (click update to latest Beta in settings of Web interface)

    So just click the update to beta and reboot and I guess your display will work.

    Because you have the 3.2 display did you get a pin stacking header for it to plug in along with the HiFi shield?

    -Raymond Day

    Anonymous
    29. Oktober 2015 at 12:52 #16607

    Hi Raymond,

    i have the latest beta update installed. The display showed jivelite, but with the wrong resolution. The only available skin is the 2.8 Adafriut display. I miss the possibility to change the skin to the 3.2 Odroid display. This is also the case after installation of additional skins.
    My system is the old C1 without the HiFi shield connector.

    Gerhard

    update: Now i have used the 2.8 skin and now it is ok for the first try

    29. Oktober 2015 at 14:01 #16609

    Looks like I my get the pin header today. So I will find out if it works with the C1 3.2 inch Touchscreen Display Shield. Seems like that’s what he is making the beta Odroid-C1+ for so seems like it should work.

    Here is my select skin on my 1080 screen.

    Can't pick a 3.2 inch screen or 320x240 pixels.

    Seems like there would be a 320×240 on there. I guess start fresh seems like it’s made to work with this display.

    Maybe can pick one of the last 2 on that select skin.

    -Raymond Day

    • This reply was modified 5 years ago by  Raymond Day.
    Anonymous
    29. Oktober 2015 at 17:07 #16612

    Raymond,

    i use the joggler skin on both 3.2″ Odroid TFT and on the Raspi 7″ display successfully. Both display have different resolutions, but the joggler skin is working perfect on both.

    Gerhard

    30. Oktober 2015 at 9:18 #16616

    Installed the RPI DISPLAY and it looks like it works good with the 3.2 inch touchscreen now.

    Just got the pin header yesterday before I had to go to work and only had like 7 min. I cut the header with a utilitie knife and plug it in and the display lit up all wight and then blank. I had to take out the # I put on every line on the /usr/share/X11/xorg.conf.d/99-odroidc-tftlcd.conf file and rebooted and seems like it’s all working good.

    The display seems a little slow showing things. But works.

    -Raymond Day

    30. Oktober 2015 at 18:30 #16656

    On the C1 3.2 inch Touchscreen is never goes to sleep mod. Is there some setting I should do?

    Did some settings it does go to sleep blanks the screen. I guess the clock don’t work yet?

    -Raymond Day

    • This reply was modified 5 years ago by  Raymond Day.
    30. Oktober 2015 at 19:18 #16658

    Yes – set it up in Jivelite to show blank screen when not playing. This will be better for your display.

    Anonymous
    11. November 2015 at 13:14 #16842

    Hello Stefan, is there a possibility to rotate jivelite by 180 degree on the C1?

    11. November 2015 at 14:39 #16843

    Hi Gerhard,

    you may rotate the display by editing the file /etc/modules as it contains the parameter „rotate=270“. Just change it to „rotate=90“. It should look like this:
    fbtft_device name=odroidc_tft32 rotate=90 gpios=reset:116,dc:115 speed=32000000 cs=0

    After changing this value restart the device.

    Anonymous
    12. November 2015 at 17:51 #16891

    Hi Stefan,

    the file /etc/modules doesnt exists on the C1. Could you check this?

    15. November 2015 at 23:38 #16921

    Hi,

    one question from my side, i try to build this with a raspeberry, and Audio Card and Display, but it looks like the Odroid is the better choice.

    I have read the most posts here but can someone please confirm what we need to buy to start working with that that.

    1. Odroid C1+ right?
    2. Odroid C1+ Hifie Shield How is the quality from this, is like the other for the raspi?
    (I have not found one with a amp on, is one avaliable?)
    3. To the Display you are talking about different in this post 2.8 ans also 3.2?

    can you please give some feedback what would be implementet in max2play image and is the best choise?
    Perfect would be a link to a EU distributor.

    Thanks

    Olaf

    19. November 2015 at 12:15 #16962

    Hi Olaf,

    the hardware choice depends on what you need / want. Basically I would recommend a Raspberry Pi for player purpose as it offers more options for soundcards (DACs and AMPs) and community support is better. Also the system itself is more „stable“. The Odroid C1+ supports just the HifiShield (DAC) from hardkernel (quality is similar to the HifiBerry DAC+).
    Max2Play only supports the 3.2 inch Touchscreen Display Shield for the C1+. Software like Jivelite need some settings to display properly on small displays – this is why this thread mentions a skin for a 2.8″ display, that is needed to show Jivelite correct on the 3.2″ display.

    You may have a look at our shop as we offer different bundles that work very well together with Max2Play.

    12. März 2016 at 19:17 #19229

    Hi flysurfer,

    I have bought the Odroid C1+ incl. the Hifi Shield, but without the touch display for using it as a media center. I.e. I would like to use the HDMI for video and therefore need to deactivate the touch display.
    As I am a bloody rookie within the linux universe as well, I am currently struggling with the necessary adjustments you have mentioned above. I have already made it to access the Linux-Distro (directories) via SSH (Bitvise SFTP). But according to the post of gerhardc I am neither able to find the path/folders „/etc/modules“ (for removing modules spicc and fbtft-device) nor the path „nano /usr/share/X11/xorg.conf.d“ for editing the file „99-odroidc-tftlcd.conf.“ From my point of view the folders are not existing on my image.
    I have already tried to find a kind of search functionality for folders and files within the Bitvise-Tool, but couldn’t find it as well.

    Another attempt of mine was to enter the directory via console (Eingabeaufforderung: „cd etc/modules“ etc.), but the following message was raised: „No such file or directory“)

    Could you please help me finding the folders. Do I need to unhide system folders or files like in Windows via the Bitvise-Tool?

    Thanks in advance and best regards,
    Pheidiass

    • This reply was modified 4 years, 7 months ago by  Pheidiass.
    14. März 2016 at 13:20 #19254

    Hi flysurfer,

    I have found at least the path to modify the file. Just going one level up from the HOME-folder. I thought I am at root-level when accessing via SSH-Tool.
    But the folder „modules“ does still not exist underneath „etc“. Therefore I am still not able to delete the subfolders „spicc“ and „fbtft-device“.

    Best regards,
    Pheidiass

    1. Juni 2016 at 22:52 #20426

    Hi !

    I don’t understand. After bigs problems with Jivelite, i burned an other time in order to re-install Max2Play.

    Jivelite is ok but not with the good skin, i use 3.2″ touchscreen. I installed the good skin (QVGA) with the web interface but i can’t choose it with Jivelite, it doesn’t appear on the menu. So i can’t use Jivelite.

    What i made :
    – install Max2Play
    – upgrade Max2Play
    – install Jivelite, reboot…
    – install Max2Play Beta, reinstall Jivelite…

    Please i need help !

    2. Juni 2016 at 8:35 #20428

    Hi!
    You need to update to latest max2play beta on settings page and then just reinstall the skin on jivelite page. Reason: The location of the sources for the skin have changed.

    2. Juni 2016 at 21:17 #20458

    I think i have found the bug !

    The script (/opt/max2play/cache/newplugin/jivelite/scripts/addskin_jivelite.sh) didn’t get the skin :

    sh /opt/max2play/cache/newplugin/jivelite/scripts/addskin_jivelite.sh 
    /opt/max2play/cache/newplugin/jivelite/scripts/addskin_jivelite.sh: 7: /opt/max2play/cache/newplugin/jivelite/scripts/addskin_jivelite.sh: pushd: not found
    Cloning into 'jivelite-qvga-touch-rpi'...
    fatal: unable to access 'https://github.com/ysop/jivelite-qvga-touch-rpi.git/': Failed to connect to github.com port 443: No route to host
    cp: cannot stat ‘/opt/jivelite-qvga-touch-rpi/share/jive/applets/QVGATouchSkin/’: No such file or directory
    cp: cannot stat ‘/opt/jivelite-qvga-touch-rpi/share/jive/jive/ui/Keyboard.lua’: No such file or directory
    Skin setting updated
    finished
    

    I made a git clone from my personal computer, made a scp command in the right directory and it was ok 🙂

    Maybe it was due to my hostname (error : sudo: unable to resolve host SqueezeSdB). I changed it from webinterface : odroid > SqueezeSdb. It was changed in /etc/hostname but not in /etc/host. New bug ? I don’t know.

    Now my Jivelite with right Skin is ok 🙂

Viewing 17 posts - 31 through 47 (of 47 total)

You must be logged in to reply to this topic.

Register here