Using the ODROID C1+ with touchdisplay and hifi-shield on Max2Play

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 Using the ODROID C1+ with touchdisplay and hifi-shield on Max2Play

This topic contains 46 replies, has 8 voices, and was last updated by  Bristow premium 6 months, 1 week ago.

Viewing 30 posts - 1 through 30 (of 47 total)
  • 15. October 2015 at 12:11 #16381

    As we tested the C1+ we found that it offers a very good solution to use a touchdisplay and a high-res audio card in combination. There are some changes needed to get everything working and we decided to create a special C1+ Max2Play Image with the target to run as a perfect audioplayer.

    The Image will be available in our download section and it has some changes over the former C1 Image:
    – Upgraded packages and Kernel to the latest version
    – Changed desktop to LXDE to get Jivelite working in Fullscreen mode
    – activated and configured display and hifi-shield

    Cheers,
    Stefan

    16. October 2015 at 4:10 #16399

    Can you post here indicating when C1+ image will be avaialble for download.
    Thank you

    17. October 2015 at 16:43 #16419

    Hi,

    I am stuck, with my Odroid C1+ and I2S dac and touch display, cannot get the i2s dac “SEEN” by player. Need the new distro please!

    thanks

    Patrick

    19. October 2015 at 12:09 #16425

    The new SD/Emmc-Card Image for the C1+ is now available on the downloads page!

    19. October 2015 at 14:10 #16426

    Thank you .. will install and provide feedback.

    19. October 2015 at 15:48 #16428

    So are you saying if you get the:

    ODROID-C1+
    ODROID-SHOW2
    HiFi Shield for C1+

    They all can work together with the image you are making?

    All 3 would add up to $101 + shipping, and SD card.

    Is this right? I can’t find were they say they can all plug in to each other and not photos of that yet I guess.

    Can even buy a remote from them. That be nice if could get it to work like the remote on the Squeezebox radio.

    -Raymond Day

    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    19. October 2015 at 16:01 #16430

    Hi Raymond,

    the Image is set up to work with the HiFi-Shield and the LCD-Shield (touch display 2.8″) on a ODROID C1+. Jivelite is preinstalled and can be started on Boot or via Webinterface. Although it is not the same “touch” experience as the 7″ Raspberry Pi Display does offer, it is usefull as a small player.

    The ODROID-Show is probalby not used to show a desktop environment and it won’t be possible to show any graphic stuff on it.

    Stefan

    19. October 2015 at 19:25 #16432

    Audioplayer – Squeezelite is running (verified via web-interface). I can use the web control installed on my PC to verify that the HiFi audio DAC is working on OdroidC1+ (via headphone jack on the HiFi DAC)

    Is the next step to simply goto Jivelite and launch it? When I do that I get nothing showing on the screen. Do I need to install Squeezebox server on the OdroidC1+ or have I missed a step?

    Thanks

    • This reply was modified 1 year, 1 month ago by  viperman3.
    19. October 2015 at 23:08 #16434

    So do you mean it’s this display.

    Looks like it’s sold out right now and cost $120. All most just like the $60 Raspberry Pi 7″ Touchscreen. But this one is a 9″

    So is that the set up for the Max2Play on the Odroid C1+?

    Or could it be this one the “C1 3.2inch TFT+Touchscreen Shield”? That one cost $25. A 3.2 inch one. A little bigger then the 2.8 inch raspberry Pi one.

    Or because you said it can’t show graphics. It is this one, Only $8.90?

    The Odroid-show2 can show colorful texts so I guess you mean that one a $25 one. Seems like text would be good for Max2Play because that’s all it has on the old slimp3 is text. It works good too.

    Something like this:

    The old Slimp3 player just used text showed like this.

    -Raymond Day

    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    19. October 2015 at 23:21 #16439

    So if I am right it would be the:

    Odroid-Show2
    Odroid-C1+
    HiFiShielf for C1+

    If so I like to order them.

    Thank you for making it for this better system.

    -Raymond Day

    20. October 2015 at 10:32 #16440

    Hi,

    Downloaded your new C1+ image.

    1. max2play web pages very slow to change and load —- long waits between.

    2. New image runs my home brew I2s PCM5102 DAC very well! — Great!

    3. I have still to get my TFT working. This is a 7inch 800×480 HDMI tft, not the Odroid one. I am getting the same errors as several other people in the Odroid forums, i.e. wrong res and purple line. I KNOW you do not support my tft, so I am slowly working through the set ups and will try to get it working.

    However if anyone HAS already got a 800×480 hdmi tft woking, please tell me how.

    cheers

    P

    20. October 2015 at 11:29 #16441

    @Raymond: the C1 3.2inch TFT+Touchscreen Shield is the one that we tested and set up in the C1+ image of Max2Play. We picked this because of the price and the touch functionality. Btw: nice picture of a player!

    @superpat: if the web interface is slow loading there is something wrong. Maybe high load on the system? You see details in the Debug of the Settings Page in the Web interface. I’m sorry but I can’t tell you anything about your display as we do not have one here for testing.

    @viperman3: make sure not to connect a monitor via HDMI when booting up the C1+. It should automatically show a desktop environment on the 3.2″ display. Starting or setting Jivelite to “Autostart” in the Web interface will start Jivelite on the desktop.

    21. October 2015 at 5:00 #16450

    So I guess this would be it to order to get it all working on Max2play for the Odroid from this photo.

    But the 3.2 inch Touchscreen just says C1 not C1+ and can they all plug in together?

    But reading more it says “Tested on ODROID-C1”. But can’t find C1+

    Am I right?

    -Raymond Day

    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    21. October 2015 at 5:18 #16454

    Just was looking on the web and I found this one that has C1+,HiFi-Shield and the 3.2 inch touch screen.

    So I guess the screen has to go on the side of it.

    -Raymond Day

    21. October 2015 at 6:50 #16455

    I can now see the screen working, but how do I get the menus on the screen to display in English?

    Update – navigated through the menus and figured out the language settings

    • This reply was modified 1 year, 1 month ago by  viperman3.
    26. October 2015 at 19:00 #16561

    Today in the mail I got the Odroid C1+ and order it with the C1+ HiFi Shield and IR Remote Control and the 3.2 inch Touchscreen Display Shield.

    With the HiFi Shield the Pitch Female Pin Headers can not plug in. I guess I need a extender.

    Does any one know were I can buy a pin header extender that will work with it?

    I played some music with it and it works. I got it on a HDMI screen and it boots up to the log in and shows that only about a sec. Then the screen stays blank.

    Any way to temp get it working on the 1080 HDMI screen?

    Not a to good photo of it but can see how it don't fit

    -Raymond Day

    • This reply was modified 1 year, 1 month ago by  Raymond Day.
    27. October 2015 at 11:58 #16572

    How do you “Changed desktop to LXDE”? It says it’s all ready installed.

    -Raymond Day

    27. October 2015 at 12:25 #16573

    Hi Raymond,

    I used the pin stacking header (tall) from the Adafruit page to connect it.

    LXDE is not the default desktop in the Ubuntu distribution of hardkernel. Normally it boots into lUbuntu which doesn’t let you completely undecorate the windows. When using the HDMI connection instead of the touch display you may need to change settings on the console via SSH to switch the display: open this file and uncomment every line with a “#”.

    nano /usr/share/X11/xorg.conf.d/99-odroidc-tftlcd.conf

    After this the desktop will appear on HDMI in full resolution. You may still control the mouse with the touchdisplay 😉
    If you do not use the display at all you should remove the modules spicc and fbtft_device from /etc/modules

    Cheers,
    Stefan

    27. October 2015 at 13:35 #16574

    Can you give me a link to the Adafruit page?

    I posted here to ask about it.

    But looks like you all ready have it. Any of the links in that link to Adafruit page is the pin stacking header you use?

    I think I just found the link to it.

    Looks like that one will work. I order it. Thank you flysurfer.

    One thing on the Odroid-C1+ I got a 64GB SD card and just can’t get it to Expand Filesystem. It gives some error.

    -Raymond Day

    27. October 2015 at 14:54 #16575

    That worked to get the desktop on the HDMI display. Just put a # at the start of every link in that file. rebooted.

    But it still will not “Expand Filesystem” It says this:

    WARNING: Re-reading the partition table failed with error 16: Device or resource busy.
    The kernel still uses the old table. The new table will be used at
    the next reboot or after you run partprobe(8) or kpartx(8)
    Syncing disks.
    Adding system startup for /etc/init.d/resize2fs_once ...
    /etc/rc0.d/K20resize2fs_once -> ../init.d/resize2fs_once
    /etc/rc1.d/K20resize2fs_once -> ../init.d/resize2fs_once
    /etc/rc6.d/K20resize2fs_once -> ../init.d/resize2fs_once
    /etc/rc2.d/S20resize2fs_once -> ../init.d/resize2fs_once
    /etc/rc3.d/S20resize2fs_once -> ../init.d/resize2fs_once
    /etc/rc4.d/S20resize2fs_once -> ../init.d/resize2fs_once
    /etc/rc5.d/S20resize2fs_once -> ../init.d/resize2fs_once
    Rootfs Extended. Please reboot to take effect

    I do reboot but it still says:

    [email protected]:~# df -h
    Filesystem      Size  Used Avail Use% Mounted on
    /dev/mmcblk0p2  7.0G  4.5G  2.3G  67% /
    none            4.0K     0  4.0K   0% /sys/fs/cgroup
    udev            413M  4.0K  413M   1% /dev
    tmpfs           419M  8.0K  419M   1% /tmp
    tmpfs            84M  2.9M   81M   4% /run
    none            5.0M     0  5.0M   0% /run/lock
    none            419M  4.0K  419M   1% /run/shm
    none            100M  4.0K  100M   1% /run/user
    /dev/mmcblk0p1  129M  7.7M  121M   6% /media/boot
    [email protected]:~#
    

    67% used a lot for 64GB.

    -Raymond Day

    27. October 2015 at 15:19 #16576

    I got it to re-size. Used the Odroid Utility rebooted and it worked.

    24 packages can be updated.
    10 updates are security updates.

    So updating now now.

    Can used the keyboard arrow keys on the java screen. I had to dig though the menu’s to find English.

    -Raymond Day

    27. October 2015 at 15:52 #16577

    I know it’s a Beta-151027 I have now.

    Jivelite can work but can’t switch to a music lib. It just can’t connect.

    Then after a little on at lest my 1080 HDMI it blanks the screen and goes back to the desktop. On it’s web page I can click Stop then Start Jivelite but it don’t bring it up. I reboot will but then I have to start Jivelite on the webpage and it’s is set to auto start. But then I looks like it crashes after about a min.

    -Raymond Day

    27. October 2015 at 18:15 #16583

    I can’t get the Squeezelite to start any more. It use to.

    I guess I have to select the right Audio output. I did a lot but still no start.

    Got this img of it.

    What one to pick for C1+ HiFi Shield

    So what Audio output do I pick for “C1+ HiFi Shield”?

    -Raymond Day

    27. October 2015 at 18:36 #16584

    Just tested every one. I put tape on the bottom of the C1+ HiFi Shield board too because it looks like it touches the heat-sink from the Odroid-C1+.

    Picked all the audio even the HDMI and still can’t start the player.

    Here is the DEBUG Information if that helps:

    #### SQUEEZELITE VERSION ####
    Squeezelite v1.8, Copyright 2012-2015 Adrian Smith.
     
    
    #### AUDIOPLAYER CONFIG ####
    ### Configuration of Audioplayers
    SQUEEZELITE_PARAMETER=-o sysdefault:CARD=ODROIDDAC -a 80:4:: -v
    SQUEEZESLAVE_PARAMETER=-n plugequal
    SHAIRPORT_PARAMETER=-d plug:pulse
    USE_USB_DAC=0
    USE_EQUALIZER=0
    SYSTEM_USER=odroid
     
    
    #### SQUEEZELITE -l ####
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      pulse                          - PulseAudio Sound Server
      default                       
      sysdefault:CARD=ODROIDHDMI     - ODROID-HDMI,  - Default Audio Device
      dmix:CARD=ODROIDHDMI,DEV=0     - ODROID-HDMI,  - Direct sample mixing device
      dsnoop:CARD=ODROIDHDMI,DEV=0   - ODROID-HDMI,  - Direct sample snooping device
      hw:CARD=ODROIDHDMI,DEV=0       - ODROID-HDMI,  - Direct hardware device without any conversions
      plughw:CARD=ODROIDHDMI,DEV=0   - ODROID-HDMI,  - Hardware device with all software conversions
      sysdefault:CARD=ODROIDDAC      - ODROID-DAC,  - Default Audio Device
      dmix:CARD=ODROIDDAC,DEV=0      - ODROID-DAC,  - Direct sample mixing device
      dsnoop:CARD=ODROIDDAC,DEV=0    - ODROID-DAC,  - Direct sample snooping device
      hw:CARD=ODROIDDAC,DEV=0        - ODROID-DAC,  - Direct hardware device without any conversions
      plughw:CARD=ODROIDDAC,DEV=0    - ODROID-DAC,  - Hardware device with all software conversions
    
     
    
    #### SHAIRPORT VERSION ####
    2.2.3-openssl-Avahi-ALSA-soxr
     
    
    #### OUTPUT SOUND DETAILS CARD 0 ####
    closed
     
    
    #### OUTPUT SOUND DETAILS CARD 1 ####
    closed
    

    It was working but now that I can see it on the 1080 HDMI screen I can’t get the sound to work any more.

    -Raymond Day

    27. October 2015 at 19:19 #16585

    Hi Raymond,

    if you update packages or do other things on the commandline, this might cause issues as you already noticed.

    You should start again with a fresh image (Audioplayer is set to the DAC). I found a bug on the ODROID C1 that it sometimes uses DISPLAY 0 for the LCD-Shield and sometimes DISPLAY 1. This changes on reboot what makes it kind of difficult to reproduce (really strange behavior). This is why Jivelite sometimes is not showing up after starting it… If you manually log in as user odroid you may start Jivelite with

    
    export DISPLAY=:1
    /opt/jivelite/jivelite/bin/jivelite
    

    There might be other Bugs with the C1+ itsself (related to the hardware) and with the Max2Play-Image.

    I would recommend, that you use the Squeezebox Server Webinterface to connect to your Music Library as Jivelite is just a
    a tool to control the Squeezelite player and show its status.

    UPDATE: I added a switch to the latest Beta (click update to latest Beta in settings of Web interface) to get the right display to show Jivelite. As the display randomly switches between 0 and 1, this solves the problem, not showing Jivelite after starting it on the web interface.

    • This reply was modified 1 year, 1 month ago by  flysurfer.
    • This reply was modified 1 year, 1 month ago by  flysurfer.
    28. October 2015 at 14:02 #16594

    Thank you flysurfer. Installed Fresh again and now the sound is working again! Wow I thought my C1+ HiFi Shield went bad.

    Used the Odroid tool to resize the 64GB SD card I have in it and updated to Beta-151028 Version.

    I use the 1080 by 1920 grid Jivelite and set it to English. Pressing the “Now Playing” does nothing. I can pick the Library and it wants to connect to DiskStation. I can say change it to mine but it errors. But it does play though the though the web page Logitech Media Server. Just can’t see any thing of it playing on the screen. Maybe it will work on the C1 3.2 inch Touchscreen. Still waiting for the headers to plug it in along with the 3.2 inch touchscreen.

    Guess you are still working on all this.

    Thank you. I just will not do a apt-get upgrade on it. Guess you will have this fix to when it comes out.

    -Raymond Day

    28. October 2015 at 14:09 #16595

    Hi Raymond,

    yes – still working on this 😉

    Please try to “Reset Jivelite Settings” on the Jivelite Tab in the Web interface. Somehow our Testing Squeezebox Server (network name is Diskstation) is still present in the Jivelite settings…

    28. October 2015 at 14:43 #16596

    Flysurfer you were right I reset the “Reset Jivelite Settings” Stop and start it and now it shows a lot more on the screen and can pick now playing and it shows it.

    It all so show my music in the Library.

    Seems like all is working real good now.

    Thank you.

    -Raymond Day

    28. October 2015 at 15:29 #16597

    When I order the Odroid C1+ I order it with the IR Remote Control only $4.95 and I just tested it and it works! When it did I said “Wow!”.

    Very good thank you again!

    The Odroid-C1+ comes with a IR input on the board. So this is very good to have it work with it in the beta code all ready.

    -Raymond Day

    29. October 2015 at 12:05 #16605

    flyserver, i installed max2play successfully on my old C1 with disabled HiFi shield. On the jivelite configuration page i have only the 2.8 display as a selection option. After installation of optional skins, the skin for the 3.2 display is not available. Any idea?

Viewing 30 posts - 1 through 30 (of 47 total)

You must be logged in to reply to this topic.

Register here