[SOLVED] USB hard disk drive sleep mode

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) [SOLVED] USB hard disk drive sleep mode

This topic contains 14 replies, has 3 voices, and was last updated by  MarioM Moderator 5 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • 3. Dezember 2019 at 0:10 #47656

    Hello,

    I just mounted a 2TB usb HDD via SMB protocol and can access my files from VLC player which is great BUT the HDD is always on(running/disk is turning) which is completely unnecessary and also creates constant noise. The same HDD goes to automatic sleep mode when attached to laptop. So the request is enable the sleep mode for USB devices and wake them up on demand. Thanks a lot

    (Right now the only workaround seems to be to buy an SSD)

    • This topic was modified 1 year ago by  whatta.
    • This topic was modified 1 year ago by  whatta.
    • This topic was modified 11 months, 3 weeks ago by  Heiner.
    6. Dezember 2019 at 12:17 #47693

    Hi whatta,

    The default sleep timer for HDDs with max2play should be 180 seconds. If the drive keeps spinning after that amount of time, let us know and try changing it according to the instructions in this thread.

    6. Dezember 2019 at 18:24 #47706

    Hello,

    thanks for the reply, the hhd was keep running for days. I will check the thread you linked and come back to you. Thanks

    7. Dezember 2019 at 11:22 #47712

    My hdd goes into sleep mode now. The only thing I did: turned off the desktop auto start feature of max2play. Thanks!

    11. Dezember 2019 at 13:16 #47744

    Hi whatta,

    Glad to hear you found a fix! 🙂

    2. Mai 2020 at 8:54 #48684

    Hi there. I have upgraded to RPi 4 (from 3) and same issue is happening. Usb hdd keeps spinning. “Auto start desktop” is unclicked. Please suggest. Thanks

    3. Mai 2020 at 9:31 #48687

    One more info. If I software shutdown Max2Play (from web interface), then the hdd goes into sleep mode. Best would be to add explicit configuration to this feature in the web interface. Sleep mode timeout In seconds/always on and immediate manual sleep mode. Thanks

    19. Mai 2020 at 14:41 #48809

    Hi whatta,

    Sorry for the late reply. I will ask our chief developer if he can integrate a fix for sleep mode into our beta image. If so, I will contact you again.

    27. Mai 2020 at 15:18 #48866

    Hi whatta,

    The problem with sleep mode on the Pi 4 should now have been fixed in our beta. After 10 minutes of inactivity, the hard drive should go into sleep mode.

    If you want to change the time after the hard drive goes into sleep mode, you would have to edit the hdidle config.

    27. Mai 2020 at 22:56 #48875

    Ok, thanks. Which beta version to be explicit? How can I install the beta? Thanks

    29. Mai 2020 at 15:06 #48876

    Hi whatta,

    On the Settings/Reboot page in the Max2Play web interface you will find a button with which you can update to the latest beta version.

    7. Juni 2020 at 23:48 #48955

    Hello,

    I have been on max2play 2.52 since the begging

    If I hit the update max2play button in web interface then it says no update available. Any suggestion?

    [email protected]:~ $ sudo hd-idle -t sda1
    sudo: unable to resolve host tv-hi-pi: Name or service not known
    [email protected]:~ $

    Maybe the issue is with the host name? I can only acces the web interface via the IP address and not via the max2play host..

    Thanks

    • This reply was modified 5 months, 4 weeks ago by  whatta. Reason: Extra info added
    9. Juni 2020 at 14:35 #48966

    Hi whatta,

    I am very sorry, but I totally missed the fact that you are not a premium member. To update to the most current beta version you need a premium license. Then you will find an „update to latest beta“ button in the Settings/Reboot tab.

    21. Juni 2020 at 17:40 #49060

    I see. Can you please tell how you fixed the bug? I guess it is not very complicated. I can operate via ssh.. Thanks

    24. Juni 2020 at 14:26 #49088

    Hi whatta,

    Apparently I made a mistake because sleep mode already works with the Pi 4 in version 2.52. So we haven’t made any changes in the beta. To change the settings for sleep mode, please use the hdidle config.

    Please excuse the previous misleading information.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Register here