[SOLVED] USB Hard Drive not sleeping

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] USB Hard Drive not sleeping

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  Heiner Moderator 5 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 4. January 2017 at 20:10 #25538

    HD-idle seems to be working on my Pi3 as I have seen the hard drive become idle but something is waking the hard drive when the system is not being used meaning it spends little time idle. How can I find the cause? I don’t think this was an issue on my U3 with the same HDD.

    • This topic was modified 7 months, 2 weeks ago by  Slartibartfast.
    • This topic was modified 5 months ago by  Heiner.
    5. January 2017 at 0:58 #25544

    If I run
    sudo hd-idle -t sda
    the HDD enters sleep mode. If I run
    sudo hd-idle -i 0 sda -i 300 -d
    I can see reads and writes to the HDD. These numbers do not change for 30 minutes but the HDD does not enter sleep mode. So I guess hd-idle is not working.

    6. January 2017 at 13:13 #25600

    Hi Slartibartfast,

    The Idle time is currently 180 seconds. If you want to change this preset, you need to go to the console and enter the following:
    nano /etc/default/hd-idle
    and then in the following line’s output
    HD_IDLE_OPTS="-i 180 -l /var/log/hd-idle.log"
    readjust the time.

    6. January 2017 at 20:14 #25643

    I have reinstalled the image and hd-idle is still not working. I have not made any changes to the file “/etc/default/hd-idle” so after 180 seconds the drive should sleep but it never spins down. The drive is a WD Elements drive which aspins down correctly with my Squeezeplug on a Goflex Net.

    6. January 2017 at 23:45 #25649

    I have monitored reads and writes to the HDD using iostat. After a reboot the hard drive does go to sleep after 10 minutes. After about 10 minutes the hard drive spins up again and iostat shows there has been no read or write activity during this time period. Once the hard drive has spun up it never spins down again as if hd-idle does not realise that it has woken up which is understandable as there has been no disk activity.
    If I then cause some read activity by clicking on My Music in LMS then 10 minutes later the drive enters standby state again. About 10 minutes later the drive wakes up again with no read/write activity. It then stays awake until the idle timer is triggered again by using LMS. My squeezeplug with the same drive didn’t behave like this.

    7. January 2017 at 1:01 #25651

    On a whim I thought I would try turning off “Autostart Desktop”. My HDD has been in Standby for almost an hour so far. So far so good. Maybe you can think of a reason this would help.

    18. February 2017 at 17:35 #27011

    Hi,

    I have what seems to be the exact same issue with my WD Passport drive connected to Odroid XU4. If I reboot the system the drive spins down and enters standby mode (led slow flashing on hard drive and no whirring disc) but if I play music and then stop music so nothing is playing the hard drive never sleeps again.

    Like your issue, if I have rebooted the drive will go idle but then later spin up for no apparent reason and never go back to idle – this is even if I haven’t asked the sever to do anything and I do not have any auto music scanning active.

    Sorry i can’t help your issue, but if there’s a solution to fix I’d be grateful to know. My drive has been spinning constantly now for weeks and am concerned it will wear out faster in this state.

    22. February 2017 at 16:30 #27128

    Hi Teetertank and Slartibartfast,
    Thanks for the feedback, we will look into this issue and try to reproduce your issues. Have you tried turning off autostart desktop as well, Teeter?

    28. February 2017 at 22:28 #27354

    Thanks for the response Heiner. I’ve looked on every tab of the Max2play Web interface but don’t see an option to disable destop autostart.

    Is this function accessed on the browser interface or does it require somekind of terminal login to change this setying? (Device is an OdroidXU4).

    13. March 2017 at 18:21 #27694

    Hi Teetertank,
    It’s right below the license input field in the Settings/Reboot menu.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here