Squeezebox server samba mount – raspi 3, Max2Play 2.45, Ubuntu server 16.04

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Squeezebox server samba mount – raspi 3, Max2Play 2.45, Ubuntu server 16.04

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 6 months, 4 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 15. Februar 2018 at 7:44 #34016

    I am a complete noob with raspi and Max2Play. I landed here after coming across a multiroom install highlighted over at HiFiBerry. I received the Pi as a gift and had been pondering a useful application. This seems to me to be a brilliant use for it.

    I’m running Mx2Play version 2.45, with the premium license. The bluetooth, Squeezebox server and multisqueeze plugins are installed.

    The Ubuntu server has a shared folder for all of our audio and is shared by user, across the network. I struggled for a day or two trying to get it installed via the Filesystem mount tab, rather unsuccessfully but I’d forgotten much of what I’d learned during the the server build.

    First thing was to create a new user called „mainpi“ on the server, and assign it to the user group that has access to the //server/share. Using SSH with the raspi, I successfully mounted //server/share to /mnt/music and added it to /etc/fstab. When the pi reboots, the fileshare remounts and shows in the filesystem mount tab. From the raspi CLI, I can enter and access the files in /mnt/music. So far so good.

    However, this isn’t reflected in the Squeezebox server interface. The shared folder does not show up in the menu selection on the Squeezebox settings „Basic“ tab, when using the Browse feature for the Media folders. If I enter it manually, the system tries to rescan, but the finds no files.

    Scanner Log:
    [18-02-14 21:39:34.0312] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /mnt/music
    [18-02-14 21:39:34.0618] Slim::Utils::Scanner::Local::Async::__ANON__ (71) Error scanning file or folder: /mnt/music: Permission denied

    Going back to the raspi CLI, I installed sox and can play files in /mnt/music from the command line.

    -rw-rw—- 1 root users 3062932 Oct 18 2005 track.mp3

    01 Track.mp3:

    File Size: 3.06M Bit Rate: 128k
    Encoding: MPEG audio
    Channels: 2 @ 16-bit Track: 1
    Samplerate: 44100Hz
    Replaygain: off Artist: Bach
    Duration: 00:03:11.43 Title: 01 Track

    I’m not sure where to go from here now. Does Squeezebox use it’s own credentials to access the files?

    15. Februar 2018 at 15:53 #34024

    Hi andrew,

    Best way to mount with Max2Play is to use the Filesystem Mount menu of our web interface. You’ll just have to enter the credentials as stated in the examples shown below each parameter and click save to mount any share in the directory of your choice.
    Please do make sure to delete the manual mount beforehand.

    Regarding the scan issue, please make sure that the files and folders do not have any special rights, protections or formats, to rule those out as possible sources of error.

    Here’s a wiki entry on the steps to take

    15. Februar 2018 at 18:26 #34028

    Thank you Heiner. I will try this when I am home this evening.

    What does using the Max2Play GUI form do that isn’t done by adding //<IPaddress>/<ShareName> /<mountPoint> cifs user=<userName>,pass=<passwd> 0 0 to /etc/fstab?

    16. Februar 2018 at 7:26 #34029

    I grew frustrated with things, and started with a fully clean install of M2P, careful to avoid any of the errors I’d made previously. I successfully used the filesystem mount tab to mount the samba from my home server with no drama. Once again however, it did not show up under the LMS /mnt/ folder drop-down so I added it manually. Once more, the scan shows a permission error

    [18-02-15 21:59:29.3080] Slim::Utils::Scanner::Local::rescan (181) Discovering audio files in /mnt/itunes
    [18-02-15 21:59:29.3377] Slim::Utils::Scanner::Local::Async::__ANON__ (71) Error scanning file or folder: /mnt/itunes: Permission denied
    [email protected]:/media/ZZ Top $ ls -l /mnt/
    total 4
    drwxrwx--- 2169 root users    0 Feb 15 22:06 itunes
    drwxrwxrwx    2 root root  4096 Jun 30  2016 mpd

    I’m not sure where to proceed from here unfortunately, but will update this thread when I eventually sort it out.

    • This reply was modified 7 months, 1 week ago by  andrew283. Reason: formatting
    18. Februar 2018 at 7:55 #34039

    Solved.

    I copied a track from the samba share /mnt/itunes into /mnt/mpd, changed the folder and track permissions to 777 and scanned the folder with success. Then I changed the permissions to those shown in /mnt/itunes for both directory (770) and track (540), re-scanned the folder and the music disappeared from LMS.

    All folders needed on /mnt/itunes needed to changed to 775, at the server.
    sudo find /srv/nas/itunes -type d -exec chmod 775 {} \;
    All files had to be changed to 664.
    sudo find /srv/nas/itunes -type f -exec chmod 644 {} \;
    Obviously this needed to be done from the Ubuntu server end as Max2Play user pi will not be a sudoer on the network server.

    26. Februar 2018 at 12:32 #34084

    Hi andrew,

    Sorry about the late response. I was on holiday over the last week.

    I am happy that you found your own solution, nonetheless, you should be able to mount a SambaShare right in LMS. Did you try selecting the parent folder mnt/ itself for LMS?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here