Spotify Connect Not Working with Pi Zero W and HiFiBderry DAC+ Zero

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Spotify Connect Not Working with Pi Zero W and HiFiBderry DAC+ Zero

This topic contains 6 replies, has 3 voices, and was last updated by  Heiner Moderator 2 years, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 17. April 2018 at 20:55 #35212

    Hello! I am new to music streaming. I just signed up for Spotify and Max2play Premium services. I want send the output from a DAC (instead of my CD player) to my Technics amplifier and then to Technics passive speakers. Once that is done, I’ll work on a multi-room system with several Pi Zeros and DACs connecting wirelessly to the Pi Zero acting as the server.

    Spotify Connect will not let me change the 4-digit password that keeps appearing in the menu for my Spotify password.

    When I try to install Spotify Connect, initially, everything goes well. However, the system pre-installs a 4-digit password for Spotify Connect that I cannot change. Every time I change it to my Spotify password, the system changes it back. I can enter the username without any problem.

    I am running Pi Zero W and HiFiBerry DAC+. I installed the Stretch image of Max2Play, expanded the file system and updated Max2Play and installed everything. I have selected HiFiBerry DAC+ Lite since DAC+ Zero does not show up on the drop down menu. During my evaluation, I stopped the Squeezelite player and autostart, but that did not change things.

    I have LastPass password manager on the main computer from which I work on the Max2Play set-up. I deleted the websites for Max2play and Spotify from it. I did not sign in to it as I worked through the sign in problem as well. That did not solve the problem

    I tried the Beta version of Max2Play with the same outcome. Re-flashing Max2Play to the SD Micro card did not solve the problem

    I have VNC operating, but I could not sign in to the Pi Zero’s root because I do not know the password. „raspberry“ and „max2play“ were not accepted.

    Thank you for your help in getting Spotify Connect working. Best regards.

    Mike

    18. April 2018 at 13:55 #35218

    Hello! I stream Spotify to my laptop rather than a smart phone. I’ve spent lots of time trying different options to get Max2Play up and running Spotify. No luck. I tried setting to the card HiFiBerry DAC instead of DAC light, but no luck.

    Under Spotify Connect, as I mentioned, the Spotify password is always blacked out and shows 4 dots. Whether this means that it loads a 4 character password or simply shows 4 dots always and saves the input Spotify password, I do not know. I performed this directly from the Pi Zero with HDMI screen and wireless keyboard as well as from the browser line on my laptop. The same thing appears with both.

    I do not have any audioplayers running and Squeezelight is not active.

    Spotify Connect never starts. After re-input the password and user name and saving, I click „start Spotify Connect Service.“ The page then states „Trying to launch … NOT successful Click here to show detailed information.“ However, nothing comes up when I click the link.

    Under DeBug, the following comes up:

    „#### Librespot Output ####

    #### Librespot Command Line Options ####
    Illegal instruction“

    I appreciate any guidance folks can give me. Thank you.

    Mike

    18. April 2018 at 19:37 #35221

    Hey…

    I have exactly the same problem!
    Anyone?

    19. April 2018 at 15:36 #35228

    Hello! Before I posted this question, I had performed a search and found a similar topic from January. The problem was solved by replacing the spotify connect file. However, I had trouble logging on and could not try it.

    „Default Spotify Connect from plugin does not working on Raspberry Pi Zero W.
    I replaced file /opt/spotifyconnect/librespot from precompiled file librespot version v20170717-910974e.

    Working !!!!“

    I figured out how to get to the command line as a superuser. However, scanning the file system, both from the command line and from the GUI desktop, I did not find spotifyconnect anywhere – neither in /opt or anywhere else.

    Could folks let me know where the spotifyconnect/librespot file is? Thank you and best regards.

    Mike

    24. April 2018 at 13:56 #35301

    Hi guys,

    First of all, sorry about the late response, I was on holiday until yesterday.

    With our current image on version 2.46, the newest version of librespot should automatically load. I just tested it on a new SD card to make sure. Please try reinstalling Spotify Connect or burning our new Stretch Image if you have not yet.

    24. April 2018 at 16:23 #35316

    Hello! Thank you for your note. I appreciate it, and I hope that you had a pleasant holiday.

    I just applied the Stretch image again, but I am not able to connect to Spotify.

    I’ve reinstalled the Stretch image a number of times already. The first few times, C/Opt/SpotifyConnect was not present. With the recent images installs over the last couple of days, the file was created and Librespot was installed. Thank you for your help with that.

    Just now, I reformatted my SD micro card and reinstalled everything. C/Opt/SpotifyConnect and Librspot are present. However, I have the same error as previously – „Trying to launch … NOT successful Click here to show detailed information“ No information comes up when I click the link. Under DeBug, the system states „#### Librespot Command Line Options #### Illegal instruction“

    SpotifyConnect works fine with my HiFiBerry DAC Zero + and my Pi 3. Unfortunately, the system cannot start SpotifyConnect when I go through the same steps but have a Pi Zero W.

    I saw a previous thread in the forums about a similar problem – https://www.max2play.com/en/forums/topic/spotify-connect-does-not-start/ – that suggested that the Librespot version v20170717-910974e may work with the Pi Zero W. However, I do not know where to log on in order to activate administrator privileges in order to replace the current file with that file. I outlined my problem in a parallel post.

    Thank you for your help with this. I have a Pi3/HiFiBerry DAC+ that I’ll be using as the main server for a multi-room setup. I would like to use the Zeros for the smaller rooms in my house that do not require all the features and abilities of the Pi3/DAC+. Best regards.

    Mike

    26. April 2018 at 12:59 #35344

    Hi Mike,

    Sorry about sending you on the wrong path. The Pi Zero seems to indeed be the only Pi that does not work with our current Spotify Connect player. We will try to find a fix asap. In the meantime, however, the Spotty plugin for LMS is ideal for your system!

    Please give it a try, here’s how you set it up.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here