[SOLVED] Spotify Connect does not start

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify Connect does not start

This topic contains 38 replies, has 11 voices, and was last updated by  antonio81le 4 months, 1 week ago.

Viewing 30 posts - 1 through 30 (of 39 total)
  • 1. Januar 2018 at 19:45 #33172

    Hi, I’m trying to get the Spotify Connect plugin to work.

    Unfortunately I’m not able to start it. All it says in the DEBUG output:

    #### Librespot Output ####
     
    
    #### Librespot Command Line Options ####
    Illegal instruction

    The „more information“ link on top of the plugin page does not work at all 🙁

    I’m running Version 2.45 on a Raspberry PI B with a Hifiberry card if that is any help.

    5. Januar 2018 at 14:01 #33256

    Hi kai,

    First of all sorry about the late reply. I am still working through the holiday break requests.

    Were you able to install Spotify Connect regularly without interruption?

    Which Raspberry Pi B is your model? B+, 2B, 3B?

    What more information link are you referring to? On top there should only be links to librespot’s github and mherger’s Spotty in the text field.

    Please check the other parameters of your player. Make sure the last there are empty and that your sound card is selected.

    Also make sure that both Squeezelite and Shairport are inactive.

    6. Januar 2018 at 14:58 #33270

    Hey, no worries about the late reply.

    Yes, the installation itself did not show any errors.

    My Raspberry is a plain old Model B, no B+, just the old one which had 2 USB ports.

    I’m talking about his link:
    https://imgur.com/a/ccDWW

    • This reply was modified 8 months, 2 weeks ago by  kai.
    8. Januar 2018 at 12:36 #33296

    Hi Guys,

    Just thought I’d mention I’m also encountering this issue. I’m running a raspberry pi zero W on a Justboom AMP HAT (full size AMP not the zero model). Both shareport and squeezelite players are deactivated and the soundcard is selected in the spotify connect setup.
    Look forward to resolving this issue.

    9. Januar 2018 at 16:57 #33322

    Hi guys,

    You both have very specific setups so I will just on a normal Pi3 to make sure the error is not reproducible there.

    For now, please try making a beta update, reinstalling Spotify Connect and playing something back.

    Edit: Do both of you have the error „illegal instruction“? Also, is that all that shows up when clicking more in the error message?

    • This reply was modified 8 months, 2 weeks ago by  Heiner.
    9. Januar 2018 at 17:47 #33326

    Quick update, Pi3 test worked fine. You do need an active premium license, but I assume that’s the case already with both of your accounts.

    11. Januar 2018 at 11:12 #33354

    Default Spotify Connect from plugin does not working on Raspberry Pi Zero W.
    I replaced file /opt/spotifyconnect/librespot from precompiled file librespot version v20170717-910974e.

    Working !!!!

    • This reply was modified 8 months, 2 weeks ago by  Arci.
    14. Januar 2018 at 0:48 #33397

    Hi Guys,
    Thanks for all the replies. Heiner, I’ve tried installing the beta version with no luck. I’ve also attempted to replace the librespot file but don’t seem to have the correct login. Using winscp with the login pi (password raspberry) doesn’t seem to allow me to change/modify files. Is there another login I should be Using?
    Thanks for any help guys,
    Jason

    15. Januar 2018 at 14:20 #33440

    Hi Jason,

    To get root rights, you need to log in as „su“ the password is „max2play“. You can also use „sudo“ to execute something as with root rights.

    15. Januar 2018 at 23:00 #33466

    Thanks Heiner. For some reason though, the login su with password max2play wouldn’t work. Nevertheless, I managed to transfer the file outlined by Arci using Putty and can confirm it now works perfectly. Thanks for all your help guys.

    17. Januar 2018 at 11:07 #33492

    Thanks Jason! Happy to hear that you got it all working 🙂

    17. Januar 2018 at 22:14 #33505

    Hi,

    I had the same issue with setup Raspberry Pi Zero + Justboom Amp.
    Solution provided by Arci works, thank you Arci!

    The question is do you plan to solve that issue in future version?

    Cheers

    23. Januar 2018 at 17:41 #33616

    Hi jbela,

    Should be included in our most current beta. If it does not work for you there, please let me know.

    6. Februar 2018 at 1:11 #33874

    Installing the latest Beta does NOT solve the issue for me. I’m on Version Beta-180131 on a Raspberry PI B+.

    Luckily, the solution/workaround suggested by Arci (replacing librespot) works fine for me.

    6. Februar 2018 at 17:44 #33894

    Hi kraker,

    Thanks for letting us know.

    We will dust off the ol‘ B+ and try to recreate the error.

    25. Februar 2018 at 3:15 #34079

    Thanks very much 🙂 I tried for hours to get spotify connect to work — Now with Arcis hint it works very well

    1. März 2018 at 17:45 #34166

    Hi guys,

    We added a check for the version of Raspberry Pi in our most current beta of Max2Play. This makes sure the correct version for ZeroW, B+, etc. is installed and not just the newest one which is not compatible with these boards. You can test it out after making a beta update.

    3. März 2018 at 13:23 #34192

    So, I decided to give that new beta a try, Version Beta-180301 on Raspberry PI B+, and have spent some hours pulling my hair out since then.

    Even with the google DNS hack in place, I have no internet on the max2play after installing this beta.
    Well, that means, no DNS, because I can connect to it via webinterface and ssh without a problem, so the connection is there, but pinging a server by name from the raspberry gives an „unknown host“ error.

    Did a full reinstall this morning, first trying to get it all working without installing a beta release, but all I got at first was the illegal instruction for librespot, and then, after following the instruction from arch above (https://www.max2play.com/en/forums/topic/spotify-connect-does-not-start/#post-33354), all I got when trying to start spotify connect was

    hread ‚main‘ panicked at ‚called Result::unwrap() on an Err value: WireError(„invalid value for enum: 13“)

    Googling for this doesn’t help me much, just a few hits on GitHub with too much tech details (even though I think of myself as tech savvy).

    After the first reboot on the beta release, I get the no internet error, persistently…

    So… basically, now I can start over again with installing, but then I will still not be able to use spotify connect, which for me was the whole point of using max2play…

    Any hints welcome! Basically, without internet access (without a functioning DNS), this thing is useless…
    If there’s any useful logging I can get, let me know.

    If only I hadn’t tried out the latest beta, I would still be enjoying spotify connect. Is there a way to go back to the previous beta?

    • This reply was modified 6 months, 3 weeks ago by  kraker. Reason: minor addition
    5. März 2018 at 14:16 #34210

    Hi kraker,

    The image download beta is different from the beta update on a normal version. The image beta is based on Raspbian Stretch, a different version of the Debian structure Max2Play is built on.

    By doing a beta update from a normal image (based on Raspbian Jessie lite), you only get the newest bug fixes and changes to our proper release. Thus, you can just download the normal standard image and do a beta update.

    5. März 2018 at 18:03 #34227

    Hi kraker,

    We now updated the build of librespot for our Spotify Connect to account for some new changes.

    Just click „reinstall“ and it should work again.

    18. April 2018 at 22:12 #35223

    I’m sad to inform that this still doesn’t work.

    The fix Arci suggested here before, does.
    Installing the latest update, the beta, updating kernel, re-installing the spotify connect, disabling squeezelite and shairport, etc. did not fix this.

    My setup:
    Raspberry pi zero w + justboom zero DAC

    24. April 2018 at 13:37 #35295

    Hi jujosaar,

    I just tested a new install on a Pi3 and did not have any issues.

    If you have not tried it yet, please download and burn our new Stretch Image to rule out this possible source of error.

    6. Mai 2018 at 13:10 #35524

    Hi,

    I have just downloaded the Stretch image for my Raspberry PI Zero – m2p_stretch_rpi_245.img and flashed and booted into M2P. Setup wireless and upgraded to beta version Beta-180503

    Enabled and installed Spotify Connect

    Get the same error. Next steps?

    #### Librespot Output ####

    #### Librespot Command Line Options ####
    Illegal instruction

    7. Mai 2018 at 15:48 #35558

    Hi mctubster,

    Please make a „reinstall“ of Spotify Connect to make sure the changes from the beta update are included.

    8. Mai 2018 at 2:46 #35569

    Yes I have reinstalled while running Beta-180503

    It does not appear to be installing the correct version (as I understand it, an older version is required for the Pi Zero).

    [email protected]:/opt# cd spotifyconnect/
    [email protected]:/opt/spotifyconnect# ls -l
    total 13388
    -rwxrwxrwx 1 root root 13707640 Mar 5 16:08 librespot

    Same error in debug.
    Thanks

    „#### Librespot Output ####

    #### Librespot Command Line Options ####
    Illegal instruction“

    8. Mai 2018 at 12:22 #35585

    Hi mctubster,

    It works with our Pi Zero Wireless. Which version of the pi Zero do you have?

    8. Mai 2018 at 14:08 #35594

    Pi Zero Wireless. Is the librespot file the correct version?

    Can you tell me where I can find the install script so I can debug?

    Thanks

    [email protected]:~ $ cat /proc/cpuinfo
    processor : 0
    model name : ARMv6-compatible processor rev 7 (v6l)
    BogoMIPS : 997.08
    Features : half thumb fastmult vfp edsp java tls
    CPU implementer : 0x41
    CPU architecture: 7
    CPU variant : 0x0
    CPU part : 0xb76
    CPU revision : 7

    Hardware : BCM2835
    Revision : 9000c1
    Serial : 0000000088be3ccb

    8. Mai 2018 at 14:49 #35595

    Something is up with your install.sh script … maybe the js is referencing the wrong location / file? Certainly not the latest version.

    When I run „Reinstall Spotify Connect Service“ from the web interface it installs
    -rwxrwxrwx 1 root root 13707640 Mar 5 16:08 librespot

    When I download the spotifyconnect.tar file (http://shop.max2play.com/media/downloadable/beta/spotifyconnect.tar) and run the install.sh in it as root it installs this version
    -rwxrwxrwx 1 root root 14617892 May 7 10:50 librespot

    which works 🙂

    Thanks

    8. Mai 2018 at 15:19 #35597

    Hi mctubster,

    We added an identification for the Zero Wireless chip because it needs a different version than the 2B, 3B and 3B+ does.

    With the newest beta, this should automatically get you the right version. As mentioned, we successfully tested this with a Zero Wireless.

    But I will set up a new image and see if I can recreate your issue.

    17. Mai 2018 at 12:43 #35742

    hello,
    on initial boot and install of Spotify Connect worked just fine.
    however, auto-start on boot did NOT work. i had to manually start it each time.

    then, i was playing with squeezelite but without the auto-start.
    it always came back with the following error:
    [03:40:00.965570] test_open:310 playback open error: Device or resource busy
    [03:40:00.965912] output_init_common:382 unable to open output device

    then, i tried to start Spotify Connect manually and now,
    it fails with error:
    Trying to launch … NOT successful Click here to show detailed information
    error: Unrecognized option: ‚onstart‘

    so, now i am faced with two problems.
    please help with some advise…

Viewing 30 posts - 1 through 30 (of 39 total)

You must be logged in to reply to this topic.

Register here