Spotify Connect: Lautstärke

Max2Play Home 2016 (en) Forums Max2Play Add-ons Spotify Connect: Lautstärke

This topic contains 10 replies, has 4 voices, and was last updated by  Heiner Moderator 2 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 12. September 2017 at 22:22 #31295

    Ich nutze bis dato immer den LMS mit Browser/Handy-Fernsteuerung, manchmal mit dem LMS-Spotiy-Plugin. Habe letzte Woche Spotty hinzugenommen, läuft auch gut. Ist viel schneller als das triode plugin. Aber nun zum Kern der Sache:

    Habe auch den Spotify-Connect Player installiert. Verbindung usw. einwandfrei. Aber beim ersten MAl sind mir fast die Ohren abgefallen, da die Start/Default-Lautstärke auf Maximum eingestellt war. Überhaupt ist der Pegel, der aus diesem Player an (dieselbe wir fü LMS) Soundcard geht, viel höher als der Rest.

    Frage: Kann ich den Pegel (z.B. per Kommandozeilenparameter) für den Audioplayer reduzieren?

    Obendrein merkt sich das Spotify auf meinem iPhone nicht die letzte Lautstärke, bzw. muss ich schon sehr weit herunterregeln und dann wird es sehr grob einzustellen. Außerdem klappt das Verändern der Lautstärke nur bei Wiedergabe, so dass anfangs im jeden Fall die Lautstärke BRUTAL hoch ist.

    Ideen hierzu? Vorschläge?

    VG, Andreas.

    14. September 2017 at 11:27 #31318

    Hi waterdrinkingman,

    Das ist leider ein bekanntes Problem im aktuellen librespot, der Software auf welcher dieses Plugin basiert. Wir arbeiten bereits an einer möglichen Lösung, aber aktuell lässt sich dies leider nicht einfach fixen.

    In der Zwischenzeit kannst du jedoch das Spotty-Plugin für Squeezebox Server nutzen, falls die Lautstärkeanpassung zu unpraktisch für deine Anwendung ist: https://www.max2play.com/howtos/howto-spotify-einrichten/

    14. September 2017 at 22:57 #31334

    Ah, okay..

    Na, Spotty habe ich ja schon installiert, das hatte ich doch geschrieben. Das funktioniert ja ganz gut und flott, Dort vermisse ich eigentlich nur, dass das nach vorne springen innerhalb des Stücks nicht (mehr) geht im Vergleich zum triode plugin.

    Ist das so oder kann man da vielleicht was machen?

    15. September 2017 at 9:32 #31336

    Hi Andreas,

    Sorry, das hae ich wohl überlesen. Aktuell ist das springen im Song leider nicht möglich mit Spotty. MHerger vom SlimDevices-Forum arbeitet jedoch akribisch daran, das Plugin weiterhin zu verbessern.
    Und bei unserem Spotify Connect-Plugin wird jetzt immer die neueste Version von librespot automatisch bezogen bei einer neuen Installation. Du kannst also, falls eine neuere Version raus ist, auf „Reinstall“ klicken und gucken wie die Ausgabe ist.
    Du kannst außerdem versuchen, bei den Command Line Options „–device hw:0“ oder „–device hw:1“ einzutragen. Je nachdem, welchen Slot deine Soundkarte hat (wenn Build-In Audio deaktivier ist, ist es 0, wenn nicht, ist es 1).

    Edit: Du kannst jetzt mit einem Beta-Update die neue Version unseres Spotify Connect Plugins starten. Damit kannst du den Mixer einstellen (Master bei den meisten Amp’s, Digital bei den meisten DAC’s) und hw volume control möglich machen.

    • This reply was modified 3 years ago by  Heiner.
    3. November 2017 at 9:56 #32266

    Hello,
    Same sound issue as described, using an AMP2.
    Is this solved now ? and how to ?
    Thanks

    3. November 2017 at 12:23 #32271

    Hi atacama,

    Add hardware volume control in the command line options:
    – For Mixer add „Digital“
    – For Command Line Options add “–device hw:0” or “–device hw:1”, depending on whether you have built-in audio active (1) or not (0).

    6. November 2017 at 16:48 #32311

    Hi atacama,

    To clarify: This concerns the current beta version of Spotify Connect, make a beta update if you have not yet in Settings/Reboot. The mixer device line should read „Digital“ and can be found in the Spotify Connect menu’s advanced options as well as the Command Line Options, whose contents should read “–device hw:0” IF you have the build-in audio deactivated in the Raspberry Settings. If this is not the case the parameter should read “–device hw:1”, instead.

    Please let me know if there are still issues and if so, what your error messages are.

    2. Dezember 2017 at 15:36 #32755

    Just tried this with the new Max2Play version 2.45. Audio device is „hw: sndrpihifiberry“, tried both „Master“ and „Digital“ as mixer setting. Both don’t stick, „mixer“ is empty after saving. Spotify Connect plugin works, but still resets to full volume after each restart and the volume mixer scale is messed up (i. e., way too loud even at 10%).

    Any hints?

    4. Dezember 2017 at 17:59 #32777

    Hi singlecask,

    That loud preset is unfortunately an issue with Spotify’s app but we are working on it.

    On your output issue, could please make sure that Squeezelite does not have the same output device selected?

    4. Dezember 2017 at 19:03 #32778

    Tried again with Squeezelite disabled. No matter what I enter in the „mixer control“ field, it doesn’t get saved, so no hardware volume control possible in Spotify Connect. Maybe „Master“ and „Digital“ are wrong for my Hifiberry Amp? I have no idea where to look for the correct mixer name.

    (Off-topic, but I’m mentioning this because it just happened: When I switch to dmix output on one of my three synchronized Squeezelite players, all three start stuttering. Took me a while to find the problem because I had already forgotten that I switched to dmix.)

    5. Dezember 2017 at 16:19 #32796

    Hi singlecask,

    Sorry about the confusion. I forgot to mention that the Mixer parameter is still a work in progress as it is currently not supported by the underlying solution for Spotify access. We will add a note to the field to indicate this status as to avoid further confusion. Thank you for pointing out this issue for us.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here