[SOLVED] Restoring LMS settings to new installation

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) [SOLVED] Restoring LMS settings to new installation

This topic contains 10 replies, has 2 voices, and was last updated by  Heiner Moderator 1 year, 2 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 19. Juli 2019 at 18:23 #46431

    Hello

    I am currently running M2P on a Pi 3 version 2.5 on Jessie. I want to upgrade to the latest Buster version and may even bite the bullet and purchase a Pi 4 in the near future.
    It is used only as a LMS server (7.9.2 – 1560759832) and connects to my music which is stored on a NAS. I mainly run the Spotty and BBC iPlayer plugins.
    I exported my settings file to my Windows desktop and a tar file is created which is 242meg. I have then created a new installation using a 4 gig SD card using the latest Buster image, these are the steps I took….

    1. Create new image and boot Pi 3

    2. Install LMS (same version) and then install the various LMS plugins (Spotty etc)

    3. I do not put the music path in the LMS settings as I assume it will be recreated by the settings restore file? I do create the mount path in M2P file system settings though.

    4. When I try to restore via the web interface nothing seems to happen. The screen goes pale for a few seconds but then just reverts to normal colours with nothing changed. No messages in the yellow box at the top of the screen are displayed.

    5. Obviously, when I look in the LMS settings screen none of my settings have been restored.

    I read on some previous posts that the file size limit for the tar is 100meg but was going to be increased to 200meg? This obviously doesn’t help me as my file is still too big. I have tried reducing the size of my tar file by deleting some of the library files although I’m not too sure how critical these are. This brings my file size down to about 95 meg but the results are the same as above. I did try removing the cache folder altogether from the tar file which left just the prefs folder. This did work in that I got the yellow boxes saying that the upload and restore had been successful but when I rebooted LMS and checked none of my settings appeared to have been carried over.

    I should add that my test SD card is a 4 gig card whereas my current installation is a 16 gig card. I’ve ordered another 16 gig card to see if that helps but I was wondering if anyone had some advice in the meantime.

    I haven’t deleted anything from my old SD card so this isn’t yet a disaster 😊

    Thanks
    Ashley

    22. Juli 2019 at 15:37 #46449

    Hi ashley,

    Thank you for the detailed description of your problem. I will try to recreate the issue here.

    26. Juli 2019 at 19:25 #46505

    Hi Heiner

    A quick update, I have tried again using a 32gb card but have the same result as above so I don’t think it’s a capacity issue. I have also tried using Chrome, Firefox and Edge with the same result. The screen just goes pale when I hit the restore button and after a few seconds returns to normal colours. No messages are displayed in boxes at the top.

    I’m a little unclear as to the correct order when setting up a new LMS installation. Should I install all of my plugins and scan music before I attempt a restore? I’m not sure what settings a restore actually recreates?

    Thanks
    Ashley

    29. Juli 2019 at 12:30 #46518

    Hi Ashley,

    It’s mostly the advanced settings, if you changed preferences for the file playback handling, your libraries, etc.

    It’s optional and if you have not changed a lot on your Squeezebox Server, you might be quick just setting it up again.

    29. Juli 2019 at 15:09 #46520

    Thanks Heiner

    I’m not against the idea of completely starting from scratch but it seems a shame when a restore feature is available. I don’t believe I’m doing anything wrong although my restore file might be too large at 246meg? It would have been nice to move onto Buster from Jessie but I’m not sure it’s worth all of the hassle if the restore feature won’t work for me. I have been using M2P for a few years now and have spent many hours tweaking the various settings and plugins, the thought of starting again doesn’t really appeal.

    Regards
    Ashley

    29. Juli 2019 at 16:07 #46521

    Okay, got it. For now, you should remain with stretch as there are still some minor bugs we need to figure out with the current beta of our Buster image. For future reference, you can upload the tar file and link it here so I can check if the restore works with one of our testers.

    29. Juli 2019 at 18:11 #46522

    Ok, thanks.

    I’ve ordered a Pi 4 (4gb) anyway so will starting playing again when that arrives 🙂

    29. Juli 2019 at 20:11 #46526

    Another update…..

    As I was in the mood so I decided to have another go using the Stretch 2.49 version. I had the same result with my large restore file so I then removed the cache folder completely from the settings tar file. This reduced the file size down to 208kb. This worked! All my settings were transferred over to the new installation. All I had to then do was a full library rescan.

    I’m now tempted to have another go using the 2.50 version. On second thoughts that can wait until the PI 4 arrives……

    30. Juli 2019 at 9:49 #46530

    Hi Ashley,

    Glad to hear it! You can make a backup of your existing install with our image burner and safely try out our buster if you like 😉

    30. Juli 2019 at 15:43 #46568

    Hello again

    I’be built another installation using the 2.50 Buster image on my Pi 3 and I’m pleased to say that, using the method described above, I was able to restore all of my LMS settings from my original Jessie installation. For me the key was to completely delete the cache folder from the settings tar file produced my M2P. This reduced the file size from 246meg to about 250kb. After that I just did a complete rescan of the media directories. I should also add that I stopped LMS whilst carrying out the restore procedure. This is a good result for me 🙂

    One further question, now that I have a working Buster image on my Pi 3, can I just put this SD card into my Pi 4 when it arrives. Does it matter that it has been configured on a Pi 3 or will I have to start again?

    Thanks
    Ashley

    31. Juli 2019 at 14:23 #46589

    Hi Ashley,

    Thanks for letting me know! Glad to hear this solved your issue 🙂

    You can actually use our image burner plugin to create a copy of the current install and then use it on your Pi4. (You can also use the image on any other Pi)

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here