Restore der Sicherung des Squeezbox Server

Max2Play Home 2016 (en) Forums Max2Play as Squeezebox (Player / Server) Restore der Sicherung des Squeezbox Server

This topic contains 43 replies, has 5 voices, and was last updated by  RK_aus_S premium 4 weeks ago.

Viewing 30 posts - 1 through 30 (of 44 total)
  • 2. Oktober 2018 at 20:40 #38338

    Schönen guten Abend,
    Leider ist es mir nicht möglich ein Backup der Servereinstellungen auf einen Squeezbox Server zurück zulesen, dabei ist es egal, ob das Backup von Logitech 7.9.1 oder Nigthly 7.9.2 kommt. In dem gelben Ausgabefeld erscheint, wenn das Feld erscheint „not successfull“. Das gelbe Ausgabefeld erscheint leider nur sehr sporadisch. Die Server liefen auf frischen 2.45 Max2play Images (strech) upgedated auf 2.47, auf zwei verschiedenen Raspberry PI 3B, einmal mit dem Sabre DAC und einmal mit den Justboom AMP. Wo kann der Fehler liegen? Die *.tar Files lassen sich mit Winzip öffnen und enthalten soweit ich es beurteilen kann alle Informationen.

    Grüße Jörg

    4. Oktober 2018 at 12:23 #38382

    Hallo Gordogass,

    Ich habe es gerade bei einem neuen Tester erfolgreich prüfen können. Könntest du deine Vorgehensweise genau beschreiben?

    Außerdem empfehlen wir, immer nur einen Server pro Netzwerk aktiv zu haben, damit sich dieser nicht mit einem anderen behindern kann.

    4. Oktober 2018 at 14:21 #38391

    Hallo Heiner

    1. es läuft immer nur 1 Serer (Logitech 7.9.1 oder Nigthly 7.9.2)
    2.vom Webinterface benutze ich save Settings to File. Im gelben Ausgabefeld ist dann die Anzeige squeezebox_server_settings.tar, durch anklicken des Links wird das File auf den localen Rechner geladen.
    3.über den Punkt Restore Settings from File wird das File nach aussuchen ausgewählt und dann der Restore gestartet.
    wie oben erwähnt erscheint das gelbe Ausgabefenster sporadisch mit not successfull oder garnicht also keine Meldung.

    Gruß Jörg

    • This reply was modified 3 years ago by  Gordogass.
    • This reply was modified 3 years ago by  Gordogass.
    4. Oktober 2018 at 16:23 #38394

    Hallo Jörg,

    Das ist in der Tat genau der richtige Prozess.

    Kannst du einmal die debug info im Squeezebox Server Menü von Max2Play hierher kopieren, nachdem du erneut versucht hast, die .tar Datei hochzuladen?

    Du kannst die Zeile bezüglich der Scan-Iniziierung auslassen (diese sind normal):
    [18-10-04 11:34:02.7526] Slim::Utils::SQLiteHelper::postConnect (374) Optimizing DB because of missing or empty sqlite_stat1 table
    [18-10-04 11:34:02.7835] Slim::Schema::forceCommit (2147) Warning: Trying to commit transactions before DB is initialized!

    4. Oktober 2018 at 16:44 #38395

    Hallo Heiner,
    das sind alle Loginformationen nach dem restore:

    2018-10-04 16:40:28 squeezeboxserver_safe stopped.
    2018-10-04 16:41:01 squeezeboxserver_safe started.
    [18-10-04 16:41:04.7441] main::init (387) Starting Logitech Media Server (v7.9.1, 1522157629, Fri Mar 30 12:27:11 CEST 2018) perl 5.024001 – arm-linux-gnueabihf-thread-multi-64int
    [18-10-04 16:41:27.8578] Slim::Networking::SqueezeNetwork::Players::_players_error (368) Unable to get players from SN: Connect timed out: , retrying in 604800 seconds

    #### PERL VERSION ####
    v5.24.1

    • This reply was modified 3 years ago by  Gordogass.
    5. Oktober 2018 at 11:20 #38401

    Hallo Jörg,

    Deaktivier bitte einmal mysqueezebox.com in den Einstellungen des LMS, falls es aktiv ist. Die Fehlermeldung könnte ein Abfrageloop an dessen Server sein, der andere Dienste blockiert.

    6. Oktober 2018 at 22:19 #38406

    Hallo Heiner,
    ich habe mysqueezebox.com deaktiviert, brachte aber leider auch nicht den gewünschten Erfolg. Ich habe sogar nocheinmal ein neues Image auf eine andere SD.Karte geschrieben, leider auch hier ist die restore Funktion nicht von Erfolg gekrönt. Was mir weiterhin aufgefallen ist, mit einem 7″ HDMI Display 1024 X 600 funktioniert der Bildschirmschoner nicht richtig es kommt immer nur ein Blankscreen, bei dem Orginal Raspberry Display alles ohne Probleme.(Jive lite habe ich neu installiert Binärcode von Euch und auch kompeliere neuste Version)

    Grüße aus Hamburg Jörg

    8. Oktober 2018 at 11:13 #38423

    Hallo Jörg,

    Danke für das Feedback. Hast du bereits das Joghgler Patch für 1024×600 geladen?

    8. Oktober 2018 at 12:30 #38428

    Hallo Heiner,

    ja der Patch ist installiert, ansonsten wäre die Anzeige des Spektrums auch in den Steuerelementen (Play, Skip usw.) zu sehen. Ich kann nur sagen in der Version 2.45 hat es ohne Probleme funktionierte. Was wird beim zurücklesen der LMS Konfiguration gemacht? Download des Tar Files vom localen Rechners in zB. temp und dann entpackt, mit überschreiben der bestehenden Verzeichnisse ? Wo kann ich das Script dafür finden?

    Grüße Jörg

    8. Oktober 2018 at 14:29 #38448

    Hallo Heiner,

    ich habe ein wenig gespielt. Über Umwege kann ich ein Restore durchführen, ich sichere das TAR File auf meinen NAS Drive, öffne eine SSH Verbindung zum PI und starte dann „sudo mc“. Dann wechsel auf der linken Seite in das Verzeichnis /var/lib/squeezboxserver, auf der rechten Seite öffne ich eine FTP Verbindung zu meinem NAS. Jetzt kann ich mit dem „mc“ das TAR File öffnen und die gewünschten Verzeichnisse oder Dateien auf dem PI ersetzen. Ich weiss das hätte ich auch alles aus dem CLI machen können war, aber zu faul alles zu tippen. Es geht, aber ist noch nicht die Lösung warum es aus dem Webinterface nicht funktioniert.(Ich habe es mit Firefox und Chrome probiert leider ohne Erfolg, bleibt nur noch der IE oder Edge)

    Grüße Jörg

    • This reply was modified 3 years ago by  Gordogass.
    • This reply was modified 3 years ago by  Gordogass.
    8. Oktober 2018 at 15:12 #38459

    Hi Jörg,

    Wenn möglich lade doch einfach mal die Datei hoch verlinke sie hier (falls keine persönlichen Daten hinterlegt sind). Dann kann ich die Migration hier auf einem Tester ausprobieren.

    8. Oktober 2018 at 15:25 #38462

    Hallo Heiner,

    wie soll ih die Datei hochladen, und es sind natürlich persönliche Date enthalten „Login Spotify“, obwohl ich kann das Passwort auch dannach ändern.

    Gruß Jörg

    p.s. ich habe den Spotty Ordner aus dem TAR File entfernt

    8. Oktober 2018 at 15:26 #38463

    entfernt

    • This reply was modified 3 years ago by  Gordogass.
    8. Oktober 2018 at 16:46 #38468

    Hallo Gordogass,

    Danke fürs hochladen, du kannst den Link bereits wieder rausnehmen, ich habe die Datei. Es fällt erstmal auf, dass sie doppelt so groß ist wie in unseren Tests. Ich werde morgen ein neues Image brennen und es darauf testen.

    9. Oktober 2018 at 13:14 #38494

    Moin Heiner,

    ich habe noch ein wenig probiert, der Fehler tritt erst auf wenn man mein NAS eingebunden ist und dann LMS dann die Medienbibliothek durchsucht hat. Die Größe der artwork.db und imgproxy.db wachsen stark an. Ich habe nur die Flac daten durchsuchen lassen, aber das reicht aus und der Restore läuft nicht mehr.

    Gruß Jörg

    //192.168.178.23/Media/flac /mnt/Nas/flac cifs user=xxx,password=xxx,sec=ntlm,iocharset=utf8,vers=1.0

    • This reply was modified 3 years ago by  Gordogass.
    9. Oktober 2018 at 13:43 #38498

    Hallo Jörg,

    Danke für die Info.

    Bei meiner Tester wird deine Konfig-Datei auch nicht richtig integriert. Es gibt jedoch keine Fehlermeldung wie bei dir.

    Ich werde dies einmal mit unserem Chefentwickler besprechen und sehen ob er noch eine Idee hat. Es kann jedoch sein, dass deine FLAC-Bibliothek bestimmte Dateien, Rechte oder Restriktionen hat, die den Prozess behindern oder die Größe einfach zu viel unsere Umsetzung ist.

    10. Oktober 2018 at 13:37 #38520

    Hallo Heiner,

    an den Rechten kann es meiner Meinung nicht liegen, ich logge mich mit root Rechten auf dem NAS ein.

    Gruß Jörg

    10. Oktober 2018 at 15:38 #38529

    Gemeint sind die Rechte und Formate der jeweiligen Dateien und Ordner. Diese muss der SBS auflösen beim Scan. Dies war bereits öfter in der Vergangenheit die Fehlerquelle bei Wiedergabeproblemen.

    Ich melde ich aber auch nochmal, wenn wir die Datei hier näher untersucht haben.

    10. Oktober 2018 at 15:43 #38530

    Hallo Heiner,

    danke für die Info. Zu dem Problem mit dem Screensaver auf dem HDMI Display kann ich nur soviel sagen, installiere ich eine Version 2.44(nicht strech) habe ich keine Probleme. Auch nach dem Update auf 2.47(nicht strech) läuft alles. Wiedergabe Probleme der FLAC Datei habe ich nicht.

    Gruß Jörg

    • This reply was modified 3 years ago by  Gordogass.
    • This reply was modified 3 years ago by  Gordogass.
    • This reply was modified 3 years ago by  Gordogass.
    23. Oktober 2018 at 12:14 #38753

    Hallo Jörg,

    Wir haben jetzt gefunden, was das Problem war. Es gab eine 100 MB Grenze für die .tar Dateien. Wir haben diese nun in der aktuellen Beta auf 200 MB angehoben. Nach einem Beta-Update sollte auch deine Konfig-Datei einlesbar sein.

    20. Juni 2021 at 20:45 #51346

    Hallo Heiner,

    ich laboriere an diesem Thema ja auch schon eine ganze Weile und konnte bislang auch noch keine Rücksicherung erfolgreich durchführen. Meine Datei ist allerdings auch 263Mb groß….

    Lieben Gruß
    Udo

    • This reply was modified 4 months ago by  morpheus33.
    23. Juni 2021 at 12:24 #51353

    Hallo Udo,

    Wir haben die Uploadgröße noch einmal angepasst. In der aktuellen Beta-Version von Max2Play solltest du jetzt Sicherungsdateien bis 300MB hochladen können. Sag uns gerne Bescheid, ob das funktioniert.

    26. Juli 2021 at 19:48 #51512

    Hallo Mario,
    ging natürlich wieder nicht. Habe, wie alle 3-4 Monate, den RasPi neu aufgesetzt. Squeezebox Server Version 8.2 und siehe da, die Sicherungsdatei ist mittlerweile auf über 300MB angewachsen. Glaube, der filmt mich…… 🙂
    LG Udo

    squeezebox_server_settings.tar 18.07.2021 16:13 TAR-Datei 321.300KB

    27. Juli 2021 at 11:22 #51515

    Hallo Udo,

    wir haben die Grenze jetzt nochmal auf 500MB erhöht. Du müsstest also nochmal ein Beta Update machen und es dann probieren.

    3. August 2021 at 8:28 #51543

    Eigenartig – obwohl angezeigt wird, dass dieser Thread von mir soeben ergänzt wurde sehe ich meinen vorherigen Post nicht…?

    3. August 2021 at 8:29 #51544

    Keine Ahnung was passiert ist – sende den gleich Post nochmals:

    Hallo zusammen

    Darf ich mich hier einklinken?

    Ich habe kürzlich entschieden, max2play auf einem stärkeren Raspi nochmals neu zu installieren, mit der Gewissheit, dass ich ja vom Logitech Media Server (LMS) die Einstellungen im Webinterface von max2play gesichert habe und diese danach einfach nur wiederherstellen könne. Weit gefehlt, das ging ziemlich in die Hose. Also habe ich den ganzen LMS nochmals von Hand neu konfigurieren müssen.

    max2play - LMS backup / restore

    max2play backup-restore-LMS-settings

    Auch Recherche hier im Forum führte für mich nicht wirklich zu einer brauchbaren Anleitung, wie das genau zu geschehen hat. Klar, ich habe zusammengestückelt erfahren, dass man irgendwie einen Samba-Share erstellen müsse etc. Was mich aber am ganzen wirklich stört ist, dass das Webinterface von max2play suggeriert, man könne die Einstellungen in Datei sichern und aus dieser Datei wiederherstellen?

    Da ich offensichtlich auch nicht der Erste bin, der damit Probleme hatte und danach fragte; gibt es keine verbindliche und funktinierende Anleitung dafür? Warum „suggerieren“ die beiden Optionen ein Backup/Restore – obwohl es nicht funktionierte (zumindest bei mir)?

    Ansonsten; max2play finde ich klasse!

    Grüsse
    Roman

    • This reply was modified 2 months, 2 weeks ago by  RK_aus_S.
    10. August 2021 at 7:28 #51552

    Hallo zusammen

    Ich weiss jetzt nicht, warum mein Frage zum Restore der LMS-Settings innerhalb des WebGUI auf kein Interesse stösst? Vermutlich habe ich die Frage schlecht forumuliert?

    Ich versuche es nochmals:

    Ich habe (innerhalb der WebGUI) die Logitech Media Server (LMS) Settings mit „Sichere Einstellungen auf Datei“ gesichert. Das hat funktioniert.
    Nach einer Neuinstallation von max2play wollte ich die LMS-Einstellungen mit „Einstellungen wiederherstellen von Datei“ wiederherstellen. Das hat nicht funktioniert; es kam zwar keine Fehlermeldung aber der LMS hatte keine einzige Einstellung übernommen und war immer noch unkonfiguriert – wie eben nach einer Neuinstallation.

    Die Sicherungsdatei „squeezebox_server_settings.tar“ war anscheinend völlig in Ordnung; sie einhielt die 3 Ordner, einen Menge Files und sowohl Permissions wie auch Owner waren korrekt.

    Mache ich was falsch oder funktioniert der Restore innerhalb der WebGUI wirklich nicht so wie es einem suggeriert wird?

    Natürlich bin ich mir bewusst, dass ich mich mit SSH auf max2play verbinden könnte und das tar-File manuell in das entprechende Verzeichnis entpacken könnte. Das ist aber nicht die Frage. Als Besitzer einer Premium-Lizenz möchte ich ja dazu beitragen, eventuelle Fehler zu erkennen und beseitigen. Und andere, weniger erfahrene Benutzer stolper ggf. über das gleiche Problem, oder?

    Viele Grüsse
    Roman

    • This reply was modified 2 months, 1 week ago by  RK_aus_S.
    10. August 2021 at 12:10 #51554

    Hallo Roman,

    was soll man da auch noch zu sagen. Haben das oben ja schon beschrieben. Habe seit Jahren das gleiche Problem und mache mir mittlerweile Screenshots, damit ich den LMS Server wieder richtig einstelle. Die Rücksicherung hat bei mir von Anfang an nicht funktioniert. Alle drei bis vier Monate hängt sich der RasPi auf (in der Regel nach Updates, Neustarts etc.) und ich setzte das Ding from Scratch neu auf. Nach der letzten Mail von Marco muss ich mir bei Zeiten noch mal eine frische SD Karte nehmen, Max2Play installieren und schauen, ob die Rücksicherung nun geht. Berichte, wenn ich damit durch bin…..

    Besten Gruß
    Udo

    10. August 2021 at 12:35 #51555

    Hallo Udo

    Vielen Dank für deine Nachricht.

    Na ja, richtig glücklich scheinst du mir mit diesem Backup/Restore auch nicht zu sein. Mal sehen, ob sich dazu auch nochmals jemand vom „max2play-Team“ äussert…

    Wie ich beschrieben habe sollte jedoch trotzdem mit der im WebGUI erstellen Sicherungsdatei einen Restore (eine Wiederherstellung) des Logitech Media Servers möglich sein, indem du dich mit SSH auf deinen max2play verbindest, zum root-User wechselst ($ sudo su -), die Sicherungsdatei „squeezebox_server_settings.tar“ auf max2play kopierst, z.B. nach /tmp und diese dann manuell in das entsprechende Verzeichnis des Logitech Media Servers entpackst.

    Ungefähr so:

    # tar -xf squeezebox_server_settings.tar -C /var/lib/squeezeboxserver/prefs

    Hab’s so noch nicht ausprobiert, ich denke aber das sollte hinhauen.

    Grüsse
    Roman

    12. August 2021 at 8:52 #51565

    @morpheus33

    Nochmals Udo

    Nicht dass ich jemand abwerben möchte, ich bin selbst Premium-User von max2play.

    Aber da sich hier für das Backup/Restore-Problem scheinbar niemand interessiert will ich nicht unerwähnt lassen, dass es eine extrem ausgereifte Alternative zu max2play gibt, sofern man es ausschliesslich wegen dem Logitech Media Server (LMS) bzw. -Player einsetzt:

    Hast du dir schon mal den piCorePlayer angeschaut?

    Dieses System ist extrem schlank, schnell und bietet ebenfalls Optionen zum sichern des LMS.

    Grüsse
    Roman

Viewing 30 posts - 1 through 30 (of 44 total)

You must be logged in to reply to this topic.

Register here