Mono Output

This topic contains 18 replies, has 3 voices, and was last updated by  orcas.cc premium 2 weeks, 1 day ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • 24. November 2016 at 8:17 #24159

    Hallo,

    es wäre toll, wenn man in den Soundkarten Plugins ein Auswahlfeld hätte, wo man auswählen kann, ob die Soundkarte in Stereo oder Mono ausgeben soll.

    Hintergrund ist, dass es öfters vorkommt, dass man mehrere Lautsprecher in einem Raum oder in aneinander angrenzender Räume mit der selben Musik versorgen möchte. Auch bei Systemen mit Deckenlautsprechen ist es oft nicht sinnvoll, diese mit Stereosound zu betreiben.

    Ich würde es mal für das IQ Audio Plugin benötigen und stehe auch jederzeit für Tests zur Verfügung.

    Danke, Andy

    24. December 2016 at 18:46 #25217

    Hallo Andy,

    ich habe das gleiche Problem. Hast du das mit dem Mono Sound schon umgesetzt?

    24. December 2016 at 21:44 #25219

    Hallo,

    als Plugin noch nicht, aber unter https://www.max2play.com/forums/topic/mono-output-with-squeezelite-and-iqaudio-pi-digiamp/#post-24360 hab ich eine Lösung gepostet.

    Frohe Festtage und ein gutes neues Jahr, Andy

    2. January 2017 at 23:15 #25371

    Hallo Andy,

    frohes neues Jahr und danke für dein Feedback. Wenn ich die Soundkarte wie du beschrieben hast als Mono schalte wird dann auch die Ausgangsleistung verändert und wie muss ich dann den Lautsprecher genau anschließen? Z.B. minus Kanal rechts und plus Kanal links?

    Kann man das auch für jede Soundkarte einzeln festlegen, wenn mehrere Soundkarten verbaut sind?

    Viel Grüße

    • This reply was modified 2 months, 3 weeks ago by  holzwurm83.
    3. January 2017 at 8:23 #25375

    Hallo,

    ganz normal wie vorher auch. Du hast nur nicht mehr einen linken und rechten Kanal (Stereo) sondern 2 gleiche Kanäle (Mono). Wenn du nur einen Lautsprecher brauchst, kannst du den einfach am linken (oder rechten) Kanal anschliessen. Bitte die Kanäle nicht zusammenschliessen, ausser der Verstärker den du verwendest kann das!

    lg, Andy

    3. January 2017 at 12:31 #25377

    Hi

    oder vielleicht bei eine 2-Weger eine Endstufe pro Treiber?

    Auf jeden Fall danke fr den Hinweis. Wird auch mir irgendwann helfen wenn das Projekt das ich im Hinterkopf habe umgesetzt wird

    3. January 2017 at 22:33 #25437

    Hallo Andy,

    danke für dein Feedback. Ich will mir eine Multiroomlösung zusammenbauen und möchte dabei 3-4 JustBoom Amp HAT verwenden. Für den einen Gartenlautsprecher möchte ich die beiden Kanäle der JustBoom Amp HAT zusammenschließen, da sie Leistung eines Kanals für den Lautsprecher nicht reicht. Ich habe dazu bei JustBoom direkt angefragt und die haben mir geschrieben, dass es Softwareseitig eingestellt werden muss.

    Weist du wie das gehen soll?

    3. January 2017 at 22:57 #25439

    @Holzwrm

    ich glaube da wurde aneinander vorbeigeredet. Den Amp per Software zu brücken, für “doppelte” Listung wird nicht gehen.

    Alternativen: eine für den Außeneinsatz geeignete Aktivbox oder eine Passivbox und ne geeignete Endstufe. In beiden Fällen natürlich ne Soundkarte mit Cinchausgang

    4. January 2017 at 8:09 #25453

    Hy,

    ich glaube auch, dass das Brücken der Endstufe nicht gehen wird, aber wenn ja dann müsste JustBoom ja eine Anleitung dafür haben, was softwareseitig zu tun wäre.

    Die Lösung von std wäre eine Möglichkeit, die andere wäre, 2 Monolautsprecher (je Kanal einer) zu verwenden, dadurch hättest du ebenfalls die Gesamtleistung beider Kanäle und kannst durch getrennte Aufstellung eine gleichmässigere Beschallung erreichen.

    lg, Andy

    19. February 2017 at 19:54 #27025

    Hallo Andy,

    ich habe nun versucht deine Lösung für

    für 2 Räume (für MultiSqueeze: als Soundkarte raum1 oder raum2 auswählen mit -o raum1 oder -o raum2 in den erweiterten Einstellungen von Squeezelite):

    #Define the soundcard to use
    pcm.snd_card {
        type hw
        card 0
        device 0
    }
    
    pcm.dshare {
     type dmix
     ipc_key 2048
     slave {
      pcm "snd_card"
      channels 2
     }
    }
    pcm.raum1 {
     type plug
     slave {
      pcm "dshare"
      channels 2
     }
     ttable.0.0 0.5
     ttable.1.0 0.5
    }
    pcm.raum2 {
     type plug
     slave {
      pcm "dshare"
      channels 2
     }
     ttable.0.1 0.5
     ttable.1.1 0.5
    }

    Ich habe dazu den code aus der /etc/asound.conf komplett gelöscht und deinen eingefügt.

    Allerdings bekomme ich den zweiten Player nicht gestartet es kommt immer ein Fehler beim start.

    Unter Multisqueeze habe ich bei Soundkarte jeweils die gleiche Karte ausgewählt und bei Komandozeilen Optionen habe ich -o raum1 und bei der anderen -o raum2 eingetragen.

    Das ist dann wohl nicht ganz richtig?

    19. February 2017 at 22:02 #27027

    Hallo,

    sollte soweit stimmen.

    Als Soundkarte steht bei mir in Multisqueeze bei beiden Instanzen “dshare – dshare,” drinnen.

    Wichtig ist auch noch der Parameter -m <Mac-Adresse> damit die beiden Instanzen eine unterschiedliche Macadresse bekommen, sonst gibts Probleme beim Abspielen, bei der 1. Instanz habe ich die Mac vom Pi genommen, bei der 2. 00:00:00:00:02:01. Wenn du mehrer verschiedene Player (Pis) hast, musst du für die Mac von der 2. Instanz jeweils eine einmalige nehmen.

    Hoffe das hilft dir.

    lg, Andy

    20. February 2017 at 0:05 #27028

    Hallo Andy,

    der 2. Raum will einfach nicht starten. Ich habe das so wie du beschrieben hast eingetragen. “-o raum2 -m 00:00:00:00:02:01” Ich habe auch nur einen PI. Ich kann immer nur entweder raum1 oder raum2 starten. ALs Soundkarte verwende ich aktuell eine IQaudIO AMP, falls das eine rolle spielt?

    LG

    20. February 2017 at 8:44 #27029

    Hallo,

    du musst als Soundkarte dshare für alle Instanzen eintragen, das ist die virtuelle Soundkarte, die du mit der neuen Konfig (asound.conf) erstellt hast. Die IQAudio kannst du nur einer Instanz zuweisen.

    lg, Andy

    20. February 2017 at 21:14 #27064

    Hallo Andy,

    da habe ich mich etwas falsch ausgedrückt. Ich nutze die IQAudio Karte und habe da die Boxen angeschlossen. Die Konfiguration ist unter Multisqueeze wie folgt:

    Instanz 1
    Soundkarte:dshare
    ALSA Parameter: ist leer
    Kommandozeilen Optionen:-o raum1 -m b8:27:eb:dd:79:95

    Instanz 2
    Soundkarte:dshare
    ALSA Parameter: ist leer
    Kommandozeilen Optionen:-o raum2 -m 00:00:00:00:02:01

    Ich kann immer nur eine Instanz starten. Die zweite will immer nicht starten.

    20. February 2017 at 21:58 #27066

    Hallo,

    hast du die Soundkarte vom Pi in den Pi-Settings (Deaktiviere integriertes Audio bei RPi3) deaktiviert? Das hab ich machen müssen, sonst hast nicht geklappt.

    Ansonsten hab ich auch keine Idee mehr, muss aber zugeben, dass ich nicht der Spezialist betreffen Linux (vorallem Soundconfig) bin und die Einstellungen nur durch google und viel herumprobieren geschafft habe.

    lg, Andy

    20. February 2017 at 23:10 #27067

    Hallo Andy,

    danke! Nach dem deaktivieren lies sich keine Instanz mehr starten. Nachdem ich das wieder aktiviert habe ist alles gestartet wie gewünscht. Warum auch immer es scheint erstmal zu gehen.

    Danke erste mal!

    21. February 2017 at 7:57 #27071

    Hallo,

    komisch, eigentlich sollte die Konfig nur mit deaktivierter Soundkarte funktionieren. Na egal, Hauptsache es klappt.

    lg, Andy

    PS: Hast du nach dem Deaktivieren neu gestartet?

    10. March 2017 at 19:31 #27567

    Hallo Andy,

    vielleicht hast du hierzu auch noch eine Idee?

    https://www.max2play.com/en/forums/topic/3-4-hifiberry-dac-pro-auf-einem-rpi/

    Danke dir!

    14. March 2017 at 13:45 #27718

    Hallo,

    leider nein. Hab immer nur eine Soundkarte pro Pi im Einsatz.

    lg, Andy

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.

Register here