max2plax Samba Server nicht mehr unter Name erreichbar

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI max2plax Samba Server nicht mehr unter Name erreichbar

This topic contains 3 replies, has 3 voices, and was last updated by  Heiner Moderator 3 weeks, 6 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • 16. September 2017 at 11:05 #31352

    Hi

    Irgendwie habe ich Mist gebaut 😉
    Zuerst lief bei mir unter max2play der NFS Server nicht, nach einigen Versuchen und schulssendlich einem sleep 30 im nfs-kernel-server Script lief das mal.
    Entweder habe ich versehendlich was verändert oder irgendein Update hat verursacht das ich jetzt nicht mehr über \\max2play auf den Samba Server zugreifen kann, seltsam ist das ich aber über die IP \\192.168.1.32 ihn noch erreiche.
    Woran könnte das liegen?

    PS: mir fällt gerade ein das ich noch eine Änderung vorgenommen habe, ich hatte wieder das Problem das der RaspBerryPi über zwei Adressen erreichbar war wie sochn mal hier https://www.max2play.com/en/forums/topic/statisch-ip-auf-eth0-funktionieret-nicht/, und habe die zweite dann so wie ich in den Beitrag geschrieben habe gelöscht. Denke aber nicht das dies die Ursache sein kann.

    17. September 2017 at 17:28 #31360

    Hallo Hansi9990!
    Habe seit ein paar Wochen mehrere Raspberrys mit Max2Play und Squeezebox am Laufen. Bis dahin alles OK. Wenn ich jedoch auf meine Festplatten am RPi vom PC aus über Samba zugreifen will, bekomme ich eine Fehlermeldung. Der Server (Adresse) wird gefunden, doch weder \Max2Play\, \mnt\ oder \media werden erkannt.
    PC läuft mit Win10 Pro. Kann es sein, dass es mit den verschiedenen SMB-Versionen (SMBv1,2,3)zu tun hat, die nicht alle für Linux basierte Systeme funktionieren?
    Vielleicht stehen wir mit der gleichen Herausforderung?
    Vielleicht mache ich aber auch einfach etwas total falsch und ich habe nicht die Ahnung was.

    18. September 2017 at 19:43 #31386

    Hi

    Ich habe herausgefunden warum das bei mir so ist.
    Ich habe den dhcpcd Daemon deaktiviert weil ich Probleme mit dem NFS zugriff hatte, wenn dieser deaktiviert ist dann kann ich nicht mehr über den Namen auf den Samba Server zugreifen, ist er aber aktiviert erhält die Netzwerkkarte eine zweite IP und diese wird mir an meinem Kodi Client im Browser untre NFS Server angezeigt und das Verursacht scheinbar einen Konflikt beim Zugriff.
    Ich habe jetzt folgendes gemacht, in der /etc/dhcpcd.conf dem Client angewiesen mir eine fest IP zuzuweisen indem ich folgendes ans Ende der Datei gesetzt habe:

    interface eth0
    static ip_address=192.168.178.32/24
    static routers=192.168.178.1
    static domain_name_servers=192.168.178.1

    dann habe ich den dhcpcd Daemon gestoppt:
    sudo service dhcpcd stop

    die fälschlich zweite vergebene IP gelöscht (ist scheinbar in dhcpcd Cache vorgemerkt):

    sudo ip addr del 192.168.178.33/24 dev eth0

    und den dhcpcd Daemon wieder gestartet:
    sudo service dhcpcd start

    Zudem musste ich noch in meiner FritzBox die 32er IP in den DHCP Server pool integrieren.

    Jetzt hat mein RaspberryPi nur eine von mir festgelegte IP die er vom dhcpcd zugewiesen bekommt, NFS zeigt auch diese (und nur diese) an und der Zugriff auf den Sambaserver über den Namen \\max2play funktioniert auch wieder.

    Es wäre schön wenn das max2play Team sich für die statische Vergabe von IP Adresse eine andere Lösung als die Vergabe über /etc/network/interfaces einfallen liese um solche Konflikte zu vermeiden.
    Hier http://sizious.com/2015/08/28/setting-a-static-ip-on-raspberry-pi-on-raspbian-20150505/ habe ich die Information dazu her, scheint also ein bekannte Sache zu sein.

    19. September 2017 at 11:19 #31399

    Hi hansi,

    Danke für die detailierte Rückmeldung. Wir werden diesen Umstand in Betracht ziehen und mögliche Alternativen oder Anpassungen untersuchen.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Register here