Statisch IP auf eth0 funktionieret nicht

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Statisch IP auf eth0 funktionieret nicht

This topic contains 4 replies, has 2 voices, and was last updated by  hansi9990 premium 7 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 30. March 2016 at 11:24 #19521

    Hallo

    Ich habe auf meinen RaspBerryPi das Image m2p_Jessie_wps_229.img installiert und möchte nun eine fest IP auf eth0 vergeben.
    Leider scheint noch ein Bug im System zu sein denn der RaspBerry erhält immer die Ip die nach dem ersten Start vergeben wurde (bei mir 192.168.178.57)
    Ich habe schon mehrfach versucht mit “Setze feste LAN IP-Adresse (eth0):” im WebIF das umzustellen (was soll das “Aktuelle IP-Adresse: ” bedeuten? die aktuelle ist doch die welche im moment vergeben ist, man möchte doch eine neue setzen) , wenn man das zwei mal hintereinander ausführt wird auch die IP aus dem Feld übernommen, aber nur bis zum nächsten Start.

    In der Interfacecs stehen die Einträge richtig:

    # interfaces(5) file used by ifup(8) and ifdown(8)
    auto lo
    iface lo inet loopback

    #auto eth0 # managed by ifplugd
    iface eth0 inet static
    address 192.168.178.32
    gateway 192.168.178.1
    dns-nameservers 8.8.8.8
    netmask 255.255.0.0

    Ein deaktivieren des dhcp client Dämon schaffte auch keine abhilfe denn dann wird kein IP mehr an die Interfaces vergeben.
    Auch das löschen der Netzwerkverbindungen in der FritzBox half nicht (natürlich nachdem ich den Raspberry abgeschaltet hatte, verbindene Geräte lassen sich nicht löschen)

    Wie kann ich eine richtig eine feste IP vergeben oder wo kann ich die vergebene Ip (192.168.178.57) löschen?

    30. March 2016 at 12:38 #19523

    Habe das Problem mit Hilfe eines Kollegen ermitteln können.
    So wie es aussieht kommt beim Booten der dhcp client dem ifplugd zuvor und setzt eine Adresse, wenn man das “auto eth” auskommentiert funktioniert es.
    Wäre gut wenn die Ersteller des Image sich da mal ansehen könnten sonst wird es da immer Probeleme geben. Ja schon klar das sehr wenige statisch IP’s verwenden aber es kann dennoch mal nötig sein ein zu vergeben und wenn man schon die Möglichkeit hat wäre es schön wenn es auch funktioniert.

    PS: Wäre auch ganz gut wenn man den Text “Aktuelle IP-Adresse” in ein einfaches “IP-Adresse” ändert, das “Aktuelle” suggeriert hier das Falsche.

    6. April 2016 at 17:50 #19678

    Hallo hansi9990,

    danke für die Info! Da fehlte noch ein Eintrag in der ifplugd Konfiguration für das neue Jessie Image! Ich werde das im nächsten Update korrigieren.

    Viele Grüße

    6. April 2016 at 18:32 #19682

    Aha, schön das ich etwas beitragen konnte.

    9. April 2016 at 11:42 #19721

    PS. Mir ist gerade aufgefallen das der RaspBerry Pi jetzt über zwei Adressen (.32 und .57) ansprechbar ist, das ist etwas verwirrend.
    Ich weiß auch nicht ob das jetzt am max2play Image oder an meiner FritzBox liegt.
    Hat jemand einen Tip wie ich das hin bekomme, oder würde es genügen die interfaces wieder auf urzustand zu setzen und den Eintrag in der ifplugd config zu ergänzen?
    Dazu müsste ich aber wissern welcher Eintrag das ist.

    PS: Habe eine Lösung gefunden, das hat dann geholfen:

    update-rc.d dhcpcd disable
    service dhcpcd stop
    ip addr del %YOURS-SECOND-IP% dev ethX

    in meinem Fall also

    update-rc.d dhcpcd disable
    service dhcpcd stop
    ip addr del 192.168.178.57/24 dev eth0

    anschließend den Pi neu starten.

    • This reply was modified 7 months, 4 weeks ago by  hansi9990.
    • This reply was modified 7 months, 4 weeks ago by  hansi9990.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here