Keine Verbindung zu Synology Diskstation

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions Keine Verbindung zu Synology Diskstation

This topic contains 5 replies, has 2 voices, and was last updated by  MarioM Moderator 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 20. Mai 2021 at 19:46 #51272

    Hallo.

    Ich bin am verzweifeln – sonst würde ich ja hier nicht fragen.

    Ich versuche vergeblich meine Synology DS zu mounten um sie als Quelle für den Squeezebox Server zu nutzen. Bisher läuft der LMS auf der DS. Aber wie bekannt ist, hat Synology den Support eingestellt.

    Ich habe max2play auf einem Raspberry 4 4gb installiert und meine Squeezebox Endgeräte finden den auch. Nur ist die Musik leer – klar ohne Verbindung.

    Ich habe einen Benutzer angelegt der Leserechte für den Musikordner hat. Habe nfs aktiviert und auch eine Regel für den Nutzer angelegt. Wie cifs erlaubt wird weiß ich nicht.

    Ich habe nun alle möglichen Kombinationen durchprobiert, aber bekomme immer die Meldung: No such file or directory Refer to the mount.cifs(8) manual page.

    Ich habe es mit //name/volume1, mit //IP/volume1 sowie die Kombinationen /Volume1/music oder nur /music versucht (und andere). Bei Mountpoint habe ich es mit /mnt/share, /mnt/share/music, /mnt/music und andere versucht.

    Ich habe cifs und nfs versucht.

    Im letzten Feld steht User=Benutzer, passwort=xxxx,,sec=ntlm,iocharset=utf8,vers=3.0 wie in den Hilfen beschrieben.

    Nichts, aber gar nichts funktioniert.

    Darum bitte ich dringend um eine Hilfestellung für nicht Linux Programmierer. Ich habe in der Vergangenheit viele Dinge lösen können, aber das macht mich ratlos.

    21. Mai 2021 at 16:15 #51279

    Hallo Houden,

    Bei nfs-Freigaben ist die Syntax anders: Du benötigst keinen Benutzerlogin und musst den Netzwerkpfad wie folgt angeben: IP-ADRESSE:PFAD oder *:PFAD

    Wenn du cifs angibst, erfolgt der Mount über Samba. In der Regel ist der Samba-Dienst bei einem NAS standardmäßig eingeschaltet. Trotzdem solltest du prüfen, ob das Verzeichnis wirklich freigegeben ist. Dann kannst du die Freigabe wie in dem Beispiel unter den Eingabefeldern einrichten:

    Netzwerkpfad: //192.168.1.100/share

    Internes Verzeichnis: /mnt/share

    Freigabetyp: cifs

    Optionen: user=name,password=pass,iocharset=utf8,_netdev

    Eventuell hilft dir auch nochmal unser Wiki weiter: https://www.max2play.com/en/wiki/mounting-an-external-drive/

    21. Mai 2021 at 19:20 #51288

    Hallo Mario.

    Super. Vielen Dank.

    Ich konnte zwischenzeitlich immer noch keine Verbindung herstellen. ABER.

    Ich habe dann mal bei den Squeezebox Einstellungen geschaut und dort zufällig meinen Musikordner gefunden. Warum der dort eingebunden ist kann ich mir nicht erklären, aber nachdem ich „durchsuchen“ laufen lassen habe, geht alles einwandfrei. Die Fehlermeldungen beim Mounten waren immer die Gleichen. Ich kann gerne mal eine Screenshot senden.

    Da ich nur meine Squeezebox Endgeräte weiternutzen möchte und das jetzt funktioniert, bin ich nur glücklich.

    Eine Frage noch. Ist es möglich die Einstellung zu sichern? Ich möchte den Raspi gerne wo anders aufstellen, traue mich aber nicht den Netzstecker zu ziehen.

    Und wie ist das Lizenzsystem? Ich würde gerne etwas „spenden“ oder „aktivieren“.

    25. Mai 2021 at 15:41 #51292

    Hallo Houden,

    super, dass es jetzt funktioniert. Die Einstellungen werden automatisch so gespeichert. Nach einem Neustart des Geräts sollte alles noch so funktionieren, wie bisher.

    Du kannst uns gerne unterstützen, indem du eine Max2Play Premium-Lizenz in unserem Shop erwirbst. Damit erhältst du auch Zugriff auf alle Max2Play Premium-Plugins. Mehr Informationen dazu findest du hier: https://shop.max2play.com/de/max2play-full-license.html

    25. Mai 2021 at 18:15 #51293

    Hallo Mario.

    danke für die Hilfe. Ich kann zwar immer noch keinen Ordner von der NAS mounten, aber die Squeezebox hat ja irgendwie einen Zugang gefunden.
    Ich hoffe dass ich das nie mehr „anschließen“ muss.

    Das mit der Unterstützung durch premium lizenz werde ich machen, obwohl ich nichts davon brauche ;-). Ich wollte ja nur meine Endgeräte weiterverwenden.

    Ein Frage noch. Meine ganzen Einstellungsversuche sind mit sichtbarem Passwort noch zu sehen. Wenn ich das manuell löschen will dauert das jedes Mal. Kann man das auch auf einen Rutsch entfernen?

    26. Mai 2021 at 14:49 #51295

    Hallo Houdon,

    Nein, das ist leider über das Webinterface nicht einfacher möglich. Ich vermute, dass man die Einträge theoretisch über Konsolenbefehle schneller löschen kann, aber um nicht zusätzliche Probleme heraufzubeschwören, würde ich beim Löschen über das Webinterface bleiben.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here