Justboom AMP HAT just problem with mute

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Justboom AMP HAT just problem with mute

This topic contains 12 replies, has 3 voices, and was last updated by  maxhome premium 3 years, 2 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 12. Mai 2018 at 17:30 #35652

    Hello,
    Sorry for my English, I don’t speak very good.
    I have a Justboom AMP HAT card and a KEYES rotary encoder.
    On the P2 connector I plugged :
    Rotary CLK -> pin 11
    Rotary DT -> pin 12
    Rotary SW -> pin 3
    Rotary + -> 3V3 (pin 10)
    Rotary GND -> GND (pin 4 or 9)

    The volume is ok.
    When i press the button, the sound does not mute.
    If i put the Rotary SW not pin 3 but on pin 6, if I press, the sound is cut, but if I release the button, the sound returns immediately.
    Do i need to add something Rotary Encoder Options?
    I use Squeezebox server.
    Thanks and sorry for my english Google

    • This topic was modified 3 years, 2 months ago by  maxhome.
    15. Mai 2018 at 7:50 #35693

    Hello,
    Thank you for the answer.
    But on the tutorial, it does not use the p2 connector of the Justboom AMP HAT.
    But i see:
    „For mounting on the Amp HAT, the pins need to be soldered a bit differently.The button needs to be soldered at (IR In) and (GND) of the U5 area.“
    I will test connect button on U5 and I will tell you if it works.
    Thanks

    19. Mai 2018 at 17:35 #35778

    Hello,
    If I connect the Rotary SW to IR In and GND in pin U5, it doesn’t work.
    The volume is ok but not the play / pause.
    My remote Justboom works perfectly.
    On my Justboom AMP HAT card, not like on the documentation.
    In U5:
    pin 1> IR in
    pin 2> GND
    pin 3> 3v3
    It’s marked on the circuit.
    On the Justboom documentation, he mentions pin 2> 3v3 ?!
    Thanks for your help
    Eric

    23. Mai 2018 at 9:19 #35824

    Hi Eric,

    Did this connection work for you?

    23. Mai 2018 at 13:30 #35836

    Hi, no don“t work.

    24. Mai 2018 at 14:17 #35858

    I checked and according to our documentation, it has to be 9,11 and 12 on the JustBoom chart in the P2 column.

    24. Mai 2018 at 17:34 #35864

    Hi Heiner,
    Yes in P2
    Rotary CLK -> pin 11 (GPIO 23)
    Rotary DT -> pin 12 (GPIO 24)
    Rotary GND -> GND (pin 4 or 9)
    Volume is ok
    But also, you forgot:
    Rotary + -> 3V3 (pin 10)

    The problem is just with Play/Stop when i push the encoder KEYES. Nothing

    I don’t know where to plug Rotary SW
    In IR in, it doesn’t work

    EDIT: i have update my older version of Squeezelite.
    But in Audioplayer > Squeezelite > advanced options
    i have :
    -o hw:CARD=sndrpijustboomd -V Digital -i /var/www/max2play/application/plugins/justboom/scripts/ir/my_lircsqueezelite
    For the play/Pause, if replace with
    -o hw:CARD=sndrpijustboomd -V Digital -Q -X 25 -i /var/www/max2play/application/plugins/justboom/scripts/ir/my_lircsqueezelite

    I have connect Rotary SW to IR In, no in GPIO 25. (The same as IR Rcv i suppose?)
    I am lost….

    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    • This reply was modified 3 years, 2 months ago by  maxhome.
    24. Mai 2018 at 20:27 #35877

    Hey,

    test connect button P2 Pin 4 + 6 with a switch. This is a Mute without any software.

    25. Mai 2018 at 18:05 #35887

    Hi Micha65,
    With button in P2, Pin 4+6, when I push the button, ok the sound is cut, but if I release button, the sound come back. It doesn’t stay cut.
    Thanks for your help

    25. Mai 2018 at 22:12 #35890

    Hi maxhome,

    you have to use a switch, not a button. It’s one more component, but it works.

    Du musst einen Schalter benutzen, nicht einen Taster. Es ist zwar ein Bauteil mehr, aber es funktioniert.

    26. Mai 2018 at 10:04 #35896

    Yes micha65, it works with a button.
    But I want a button all in one.
    Volume + mute function.
    I am not a pro of the script.
    Maybe add a script that detects when 4 and 6 (P2) touch themselves …
    Thank you to the people who participate in this discussion.

    3. Juni 2018 at 16:33 #36037

    Is it possible to use a single rotary encoder interrupter (button no switch)?
    And what model bought?
    thank you very much

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here