This topic contains 21 replies, has 3 voices, and was last updated by  Heiner Moderator 2 years, 2 months ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • 5. Juni 2017 at 11:40 #29234

    I’m a new user and I recently bought the raspberry pi/dac hat package from justboom.co.
    I had no issue putting it together, and have been able to access http://max2play with an ethernet cable plugged in, but when I try and set up wi-fi I do get a message saying ‚activated‘ but I always see ‚No IP! No Connection!‘. As well as this I get a debug message which can be seen in the imgur link below, which may or may not be the issue. I have made sure I am typing in my username and password correctly, but everytime I take out the ethernet cord after rebooting max2play as instructed there is no connection to http://max2play.

    What can I do to fix this?

    Imgur link of my issue:
    i.imgur.com/4AHQ0BY.jpg

    • This topic was modified 3 years, 3 months ago by  praz.
    6. Juni 2017 at 14:36 #29287

    Hi praz,
    Sorry about the inconvenience. The easiest solve would be to use the WPS feature of Max2Play: https://www.max2play.com/en/how-tos/how-to-wifi-configuration-with-wps-and-max2play/

    However, you can also try the following: After entering your credentials and saving, reboot the device and immediately after disconnect the ethernet. This way, you make sure that the WiFi is the preferred connection method.

    24. Juni 2018 at 17:57 #36339

    Hi,

    Recently, I am experiencing the same problem as Praz.

    Initially, I overcame my issues with m2p and finally got it working on both LAN and Wireless. However, after corrupting my sd card and doing a new installation, repeated attempts to get wireless working have failed.

    My router has recognised the hifiberry and has it’s IP address as well as MAC registered on the LAN setup page. But only recognises the pi as making an ethernet connection.
    I have checked my service provider credentials and passwords. There was an issue with the website continually inserting a capital although my sp name begins with a lower case as iiNet – m2p would correct the first i to capital I! After ensuring that was correctly entered, I am still faced with no wireless connection.

    25. Juni 2018 at 16:11 #36353

    Hi hd,

    Do you have WPS on your router? If so, please try setting it up with WPS and see if this problem persists.

    26. Juni 2018 at 4:04 #36366

    Hi Heiner,

    Thanks for the reply. Yes, my router has WPS on it has always been on. WPS was on during my first connection of pi3-Dac when it worked, until I corrupted my sd card due to incorrect power down and reboot.

    The wireless issue only started after I etched a new sd card, and ran the update and upgrade sudo commands on the new sd card.

    At first installation of M2P, I used the GUI to enter SSID and password. When I removed the wired connection and connected the pi to my stereo system, it worked well and I was impressed with my purchase of the pi+Dac-pro and M2P!!

    An update:

    Last night I ran some sudo commands (forgive me I am unable to recall the specific commands as I am at work), which scanned for wireless networks and successfully recognised my SSID. I then edited the SSID and my password into a file using a terminal window. The result did indicate that the pi was connected to the network, however, when I connected the pi to a monitor with usb keyboard and mouse, the Internet cannot be accessed.

    I also used my iphone and the „Fing“ app to scan my network and ping the pi, which also showed no connectivity to the network.

    26. Juni 2018 at 10:13 #36367

    Hi hd,

    Max2Play is usually not used with a connected screen. Screen output is only used by Jivelite and Kodi. You can check for internet connectivity on the Health Checker in Settings/Reboot.

    Also, I cannot recreate setups with a lot of manual adjustments, so if you burn a new image, you do not need to upgrade your packages (or do it from our web interface in the Raspberry Settings).

    27. Juni 2018 at 3:15 #36376

    Hi Heiner,

    Yes, I am aware of the limitations while hdmi is connected to a monitor.

    Progress;
    Last night I tried something different by going into ipad settings; networks; scanned and found max2play WAS recognised by the ipad.

    I then entered the password to access the max2play network ‚mypasscode‘. The ipad3 connected to the pi and the M2P GUI popped up. I chose my plugins but was unable to load LMS.

    The drop down box with available options was not working. Without LMS I was unable to load jivelite or any player for that matter.

    27. Juni 2018 at 9:53 #36381

    Hi hd,

    Have you checked some of our documentation, yet? We recommend using max2play in your local network. After connecting via WPS, the AP that’s automatically set up after no connection was made or ethernet cable. (Internet connection is necessary to install LMS or other new plugins)

    After that, you can control and access max2play from any device in your local network with the browser entering „max2play/“ in the url bar.

    Your system is currently in AP mode, you can scan, select and connect to your WiFi in the WiFi/LAN menu.

    27. Juni 2018 at 19:01 #36387

    Yeah. Thank you. Now I am being told that I am not a registered user and my email address is not recognised! So I cannot use all the features I have paid for!
    Thanks for the help.

    29. Juni 2018 at 9:38 #36403

    Please follow these steps:

    Make sure your Max2Play device is connected to the internet.
    Delete the license in the Max2Play interface and click „save“ with a blank field.
    Click on „Settings/Reboot“ again, reenter your license and click „save“.
    Check if the green „Activated“ field appears. If not, contact us again for further help.

    29. Juni 2018 at 9:53 #36405

    Hi Heiner,

    Update on progress:

    I tried again last night before receiving your response, and still using the Ethernet cable connection I managed to connect my ipad3 to the pi!

    Has the M2P website been down?

    The reason I ask is because late last night, after completely shutting down the pi, connecting to a monitor and rebooting the pi started to the M2P screen saver as expected. However, I shut down the pi and unplugged hdmi. Then I rebooted the pi, and the ipad!

    This time the pi started up normally and m2p was picked up in the ipad wireless scan and connected successfully!
    This was as simple as my first experience with M2P!!No hiccups and pretty straightforward.
    The m2p gui started, then changed from not registered to registered and an update alert was shown which I loaded, and completed successfully.
    Thereafter the plugins were loaded and updated as necessary, so has the Logitech Media Server, Squeezebox etc.

    The players are loading, but the music on the external usb drive that is connected to the pi has not being coming up in the media list. Although the share is shown as setup…reflecting on my actions, I think I might have overlooked adding max2play as a share …. I will try and fix that before moving to a wireless setup.
    Thanks for the prompt support suggestions.
    I will keep you updated.

    • This reply was modified 2 years, 2 months ago by  hd1200xlh.
    30. Juni 2018 at 5:19 #36413

    Response to your suggestions:

    Please follow these steps:

    Make sure your Max2Play device is connected to the internet.

    Max2Play is connected to the internet (ethernet) and is being broadcast to my ipad, iphone and macbook pro. All three devices are able to connect to Max2Play, however, none are able to access the GUI or connect using 10.1.1.212.
    …Could not open page as server could not be found.

    Delete the license in the Max2Play interface and click „save“ with a blank field.
    Click on „Settings/Reboot“ again, reenter your license and click „save“.
    Check if the green „Activated“ field appears. If not, contact us again for further help

    Unable to comply with your second request as I cannot access Max2Play interface on any of my devices.

    30. Juni 2018 at 5:32 #36414

    Response to your suggestions:

    Please follow these steps:

    Make sure your Max2Play device is connected to the internet.

    When Max2Play is connected to the internet wirelessly, and is being broadcast to my ipad, iphone and macbook pro. All three devices are able to connect to Max2Play, however, none are able to access the GUI or connect using 10.1.1.212.
    …Could not open page as server could not be found.
    But when I connect the ethernet cable all three device connect immediately – only the iphone 4s is unable to access max2play interface.

    Delete the license in the Max2Play interface and click „save“ with a blank field.
    Click on „Settings/Reboot“ again, reenter your license and click „save“.

    On accessing the interface – the license was blank so I entered details and was provided access.

    Check if the green „Activated“ field appears. If not, contact us again for further help

    The ‚activate‘ field appears.

    Currently configuring m2p.

    30. Juni 2018 at 9:34 #36415

    All the pages, were configured to suit my setup. Loaded successfully, updated etc. All with wired internet connection. After all the settings were done. I unplugged the pi and connected it to my stereo system and booted the pi.

    Pi is displayed as a wireless option on macbook, ipad and iphone scans.

    None of the above were able to access 10.1.1.212!

    Now, I am stuck with the pi connected to stereo – no display connected, and no way of actually safely shutting down the pi and corrupting my microsd AGAIN!!!

    • This reply was modified 2 years, 2 months ago by  hd1200xlh.
    1. Juli 2018 at 11:04 #36423

    Still connecting using lan cable. Tried a suggestion on the forum that using airplay plugin worked for some – didn’t work for me.

    Tried WPS setup,result:
    Successfully initialised wpa_supplicant
    Using Primi-2015 for WPS I have no idea why!??
    Error creating connection

    Primi-2015 is an unknown network that appears on iPad list of networks; probably a neighbour’s….

    I have included my home network details and password in the m2p GUI.

    • This reply was modified 2 years, 2 months ago by  hd1200xlh.
    3. Juli 2018 at 15:56 #36444

    Update on wireless issues with Max2Play.

    Today I tried something different, and installed XXXXaudio onto my spare microsd card! I have intentionally omitted the player name to avoid any issues. The disappointing part of this exercise is that I did not pay a cent for the player – it was freeware!!!!!!

    As I type this message, the Pi3+Dac-Pro are singing beautifully through my stereo system. Both Lan and WAN were scanned and locked in. USB mount was almost automatic and in less than 1/10th of the time it took to solve the issue with M2P! My initial start up time was just as fast.

    While I liked the M2P it just did not work for me! Hopefully, the wireless issues will be sorted out and I can use the player for the time I have access to the registered software.

    Thank you.

    10. Juli 2018 at 14:42 #36510

    Hi hd,

    Sorry about the late response, I was on holiday until yesterday.

    Your IP 10.1.1.212 might have been the issue, but it seems you found another solution somewhere else. While this is sad to hear, you did not get to enjoy Max2Play properly, I am glad you found a solution that fits your needs.

    10. Juli 2018 at 18:58 #36519

    Hi Heiner,

    I appreciate your response, as I am also on holiday as I type this message – so no problem :-)!

    Having found a simpler solution to the problem was helpful. However, I would still like to access and utilise the M2P option, and evaluate the wide range of tweaks and adjustments that are available, if I could get the wireless connectivity problem solved with M2P.

    Besides, having a year’s subscription to M2P, I really would like to know how the IP 10.1.1.212 can be the problem when, M2P worked perfectly at first installation with no connectivity problems.

    I do also realise that the problem could also be due to ‚pilot error‘ – or an oversight on my behalf!
    Either way, I will learn something from the experience.

    Kind regards,
    Roy

    12. Juli 2018 at 19:43 #36563

    Hi Heiner,

    I stumbled across this post while exploring wireless issues with pi3 and dac Pro
    and felt it was only fair to update my comments re: ma2play vs other software so other users make an informed choice!

    This was posted on official site:

    WLAN problems with RPI3

    1142Cz_R3_Auf_aufmWe received some reports of WLAN problems with the HiFiBerry DAC+ Pro. After several hours of testing a lot of different releases with different HiFiBerry sound cards, we can confirm that there is some kind of problem with the DAC+ Pro and the onboard WLAN. While it seems to work for some users it isn’t for others.

    The problem only affects the HiFiBerry DAC+ Pro and only the onboard WLAN module of the Raspberry Pi 3.

    You have can use the following workarounds:

    Use the Ethernet interface instead of the onboard WLAN
    Use an external USB WLAN stick
    Update December 2016:
    The problem seems to occur only on specific WiFi channels. As a fix you can set your WLAN to a fixed channel other than the channels 1, 6, 11 and 14.

    It explains a lot doesnt it?

    Kind regards,
    Roy

    13. Juli 2018 at 15:15 #36576

    Hi Roy,

    Thanks for digging this up. What do you mean by official site?

    13. Juli 2018 at 20:03 #36589

    The site carries the official hifiberry logo, and is accessible via this link.
    https://www.hifiberry.com/blog/wlan-driver-bug-in-raspberry-pi-kernel/

    Regards,
    Roy

    16. Juli 2018 at 17:14 #36620

    Thanks for sharing!

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Register here