Install M2P-244 w/o WPS

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Install M2P-244 w/o WPS

This topic contains 4 replies, has 2 voices, and was last updated by  Heiner Moderator 3 weeks, 3 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 3. September 2017 at 21:35 #31090

    I’ve been using M2P-232 for a year now in 2 RPi’s, but recently after switching to a Netgear Nighthawk R-7000 router and installing dd-WRT (no WPS), same SSID and password with WPA2/AES, all of my wifi devices automatically switched to the new router except for the M2P RPi’s.

    So I’ve downloaded M2P-244 and installed it in one of the 2 RPI’s.
    1. I’ve connected via “max2play” wifi using a phone and using a laptop, and tried to setup the wifi on the WiFi/LAN tab. I’ve tried quite a few times, unsuccessfully.
    2. I’ve also tried on the Settings/Reboot tab to change the device name, and to enter my email address thinking that is what is required to be authenticated for ?, I’m not sure what. But this info was not saved.

    Is there a way to get this working?

    4. September 2017 at 14:34 #31114

    Hi Mike,

    Have you tried Access Point Autostart yet? https://www.max2play.com/en/2017/08/access-point-autostart-mode/

    Also, saving your license only works with an active internet connection. Changing your device name should always work. What’s the error message there?

    19. September 2017 at 21:27 #31407

    Thanks Heiner,
    I typed this just now without referring to my previous post, so I hope that the story is the same.

    Sorry for the delay. A short vacation and more important projects.
    To review: I installed a new router, the Netgear Nighthawk AC1900,
    then quickly installed dd-WRT which does not do WPS. So the router
    security is WPA2/AES.

    Afterwards, all of my wifi devices automatically connected to the
    new router except that 2 Squeezeboxes needed to do “Network Setup”, and the 2 max2play rpi3’s that were dead-in-the-water.

    I started with the rpi that is the LMS server/squeezeplay. I downloaded the new max2play version 2.44 and installed it on the SD card. After bootup I connected a laptop to wifi “max2play” and the “Wifi/LAN” Tab. I checked the “Load Wifi Interface” box, entered my SSID and password, then clicked “Save all settings”. It didn’t work, I couldn’t get it to work.

    So I connected a monitor and a keyboard to the rpi, and booted to the
    raspbian login prompt. After logging in I edited /etc/wpa_supplicant.conf:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
    ssid=”myssid”
    psk=”mypasskey”
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    auth_alg=OPEN
    }

    It immediately connected and has been working ever since. For weeks now, and before I went on vacation.

    So yesterday I found time to try to get the other max2play rpi3 working. I had tried before, but was unable. So to start fresh, I fomatted the SD card and installed the version 2.44 image. Again I tried to get Autostart to work, but could not. So I again connected a monitor and keyboard to the rpi, but this time it booted through to a “primitive” max2play desktop GUI. I have no clue why it booted differently than the other one that booted to the raspbian
    login. So I found the Xterm in the desktop, and again edited the /etc/wpa_supplicant.conf file the same way. I then checked the router at 192.168.1.1, and it showed that “max2play” was connected at 192.168.1.8. I then did a “sudo halt” shutdown, and took the rpi “downstairs”. After plugging in and waiting for the boot, I looked at “squeezer” on my phone: max2play did not connect?!? Did max2play really override my wifi settings that worked, well maybe
    they would have worked? Then I used a laptop to check the router connections, max2play was,of course, missing.

    I then switched the laptop to the “max2play” ssid, and connected via browser to the Wifi/LAN tab.
    I entered the same info as before into the Wifi/LAN tab, and again got the same result, here are some specifics:
    When I clicked the “Save all settings” I would usually see the same rotating circle, and the screen would become translucent. After a short wait I would check the laptop’s wifi to find that it had
    somehow switched from “max2play” to my-home-network. That’s unusual!! When I switched back to “max2play” wifi the Wifi/LAN tab then displayed failure info which I copied, see attachment. (I don’t see a way to attach my photo, so I’m sending this before it gets lost.)

    I hope that I’ve been able to explain everything adequately, don’t be afraid to tell me that I didn’t follow directions.

    19. September 2017 at 21:40 #31408

    Here is status after Automatic Setup fails. It’s displayed on the Wifi/LAN tab after the laptop wifi connection is switched back to “max2play”:

    WiFi & Network configuration

    Setup WiFi Started
    2017-09-18 23:12:06|
    Disable Accesspoint
    insserv: Service dnsmasq has to be enabled to start service apache2
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    ifdown: interface wlan0 not configured
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    0
    OK
    OK
    FAIL
    OK
    OK
    OK
    No IP-Address could be received – WiFi NOT working correctly. Please check Network-ID and Passphrase!
    Ignoring unknown interface wlan0=wlan0.
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    FAIL
    OK
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    ioctl[SIOCSIWENCODEEXT]: Invalid argument
    WiFi detected
    insserv: Service dnsmasq has to be enabled to start service apache2
    insserv: exiting now!
    update-rc.d: error: insserv rejected the script header
    Restarting hostapd (via systemctl): hostapd.service.
    Restarting dnsmasq (via systemctl): dnsmasq.service.
    Finished Please Click here Reload Page!

    Status: WiFi USB adapter status is active. WiFi connection status is not active
    (Only WPA/WPA2-Encryption possible)

    Load WiFi Interface:
    Network SSID:
    Password:

    List of available networks:
    start scan

    • This reply was modified 3 weeks, 6 days ago by  Mike-97470.
    • This reply was modified 3 weeks, 5 days ago by  Mike-97470.
    22. September 2017 at 13:39 #31479

    Hi Mike,

    Sorry about the inconvenience.

    Please take into account and try to rule out the router’s distance as a source of error.

    Also, please do not edit the aforementioned wpa_suplicant, it is not the protocol in use by Max2Play.

    If you want to access it manually these are the paths:

    /etc/network/interfaces -> wlan0
    /opt/max2play/wpa_supplicant.conf

    Please also make sure that you properly reboot the device after entering your WiFi credentials and remove the ethernet cable during reboot to make sure it prioritizes WiFi and does not autoset the old ethernet connection.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here