How to transfer music files to Squeezebox Server on Pi4

Max2Play Home Forums Max2Play as Squeezebox (Player / Server) How to transfer music files to Squeezebox Server on Pi4

Viewing 8 posts - 1 through 8 (of 8 total)
  • 9. April 2020 at 6:24 #48426

    I’ve set up my Digi0ne signature with Pi4 and max2player. I followed the set up sequence with expanding file system, updating, activating squeezebox player and server. With reboots in between.

    I can access the Squeezebox server using the web interface on my PC. I now want to transfer music FLAC files from my PC to the Pi server. I can’t see the pi or squeezebox server on my PC network page – it sees my router, printer etc, but not the Pi or squeezebox.

    Suggestions please

    • This topic was modified 4 years, 1 month ago by jo308.
    9. April 2020 at 6:43 #48428

    PS..the squeeze app on my Ipad can see the max2player

    9. April 2020 at 7:00 #48429

    PPS…I created Samba share following the instructions…but the PC can’t find it when trying to map network drive

    9. April 2020 at 16:07 #48435

    Hi jo308,

    First, please make sure that you can play music on your Pi using the Squeezebox Server. The best thing how to test this, is playing a radio stream. If that works, you’ll need a network share to access your music files on your PC. In the system settings of your PC you should find a corresponding option for network sharing. Then, by right-clicking on the folder you want to share, you should find the option to grant access to the folder on the home network. Then you can connect a network path in the Filesystem/mount plugin. You can either display the available devices or enter the path manually. Via a Windows PC, file sharing is done via Samba by default. In this case you have to enter „cifs“ in the third input field. For a more detailed explanation, you can also click on the „Show help“ button.

    Here is the wiki page:

    23. Mai 2020 at 3:30 #48837

    I’m having a problem getting my music folder mounted on Max2Play squeezebox. It used to work perfectly when my PC was running Windows-7 but since upgrading in January, I get this error:
    mount error(112): Host is down Refer to the mount.cifs(8) manual page
    Here is the link to a screenshot:

    The Host is not down because my MacBook connects to it immediately and opens the Music folder.

    Version 2.45
    Raspberry PI 2

    I’d appreciate any advice you can offer.

    26. Mai 2020 at 14:59 #48857

    Hi Hilary,

    Does your PC appear under „Show Network Devices“ on the Filesystem/Mount page? If Windows 10 is now running on your PC, you may also have to reactivate Samba 1.0 there. Search for „Turn Windows Features on or off“ on your PC and activate „SMB 1.0/CIFS File Sharing Support“ there. Apart from that I can only recommend that you delete the file share and set it up again.

    29. Mai 2020 at 17:40 #48878

    Hi Mario,
    Thanks for your response.
    1. Yes, my screenshot shows my PC ( //HILARY10 ) under Network Devices. My /Music folder is the only shared folder on my PC and that is what my MacBook finds when I connect to the PC.
    2. I implemented your suggestion, and it did have an effect — the error message changed to:
    mount error(5): Input/output error Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    3. I have deleted and replaced the file share many times! Using both HilaryN and hnayl (the latter is what Windows puts in the filesystem path, e.g. C:/Users/hnayl/Downloads) as user.

    Any other ideas would be greatly appreciated!


    2. Juni 2020 at 14:19 #48910

    Hi Hilary,

    a few more suggestions:

    – Make sure file and printer sharing is activated in the advanced sharing settings at the control panel of the Windows PC (for the user you want to log in with).
    – Please search for the IP address of your Windows PC and enter it in the first input field instead of the name of the PC, like: //IP ADDRESS/PATH

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Register here