[SOLVED] How to get a stable M2P installation … TL/DR

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions [SOLVED] How to get a stable M2P installation … TL/DR

This topic contains 12 replies, has 2 voices, and was last updated by  Heiner Moderator 1 month ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • 4. September 2017 at 3:26 #31092

    Dear Max2Play developers,

    I have been using M2P for 10 months. For the first six months it was rock solid and stable. So much so, that I almost never ssh’d to the server in a terminal nor even loaded the M2P web UI. I simply connected with my device apps to the LMS installed via M2P and all was well. But …

    Recently (there is a thread about it on the Forum) LMS simply stopped responding and, in trouble-shooting the LMS issue, the M2P UI also stopped working — the tabs were at the top of the web pages, but the content was blank. In the end, I was advised to re-image M2P from the IMG and start over. Which I grudgingly did.

    But the resulting M2P/LMS “experience” was awful. The M2P UI would go into a cyclical “Reloading page every 3 seconds” while installing LMS. And it stayed in that mode until I grew weary and killed it. I re-imaged the SD card three times and that behavior never stopped. With a LOT LOT LOT of futzing I eventually got a stable, working LMS and all was mostly well (LMS is horribly slow) until this morning.

    And, again, LMS stopped showing UI elements it should show. For example, for my Logitech Classic 3, it would not show options for screensavers. There should be options. So, to get to a clean state, I restarted the Pi2. It all blew up. Seriously. Nothing on restart. No M2P. No LMS. No ssh.

    So, I go get my USB keyboard from my desktop computer, go find a wireless/usb mouse, unplug the HDMI cable from the Pioneer A/V system, to get terminal access to the Pi2 to see what the hell is going on. The screen shows a bloody CLI login prompt. WTF? How did that happen?

    With several hours of work I was able to get the X server to start and stay started on M2P/Pi2 restart. But though I’ve updated LMS with the .deb found in /var/lib/squeezeboxserver/cache/update AND I tried to reinstall LMS via the M2P web UI, I cannot get a fully functioning LMS. That pesky reloading-every-3-seconds thing again, which I had to kill. But an install of LMS seemed to have been successful. LMS loads. ps -ef shows it running. The M2P UI shows it running. But the LMS does not establish a service listening on port 9000. netstat -an | grep LISTEN shows no 9000 port. Nothing I can do will fix it.

    So, after FIVE hours of my life I will never get back I’ve had to give up. I’m now going to re-image the SD card with the latest M2P I just downloaded. And attempted yet again to get a working LMS that listens on port 9000.

    I must say that this is beyond frustrating. I actually had other plans for my day than spending hours trying to fix M2P/Pi2/LMS.

    As I image the SD card with the latest M2P IMG, are there concrete steps I can take to create a stable M2P/Pi2? No offense, but really, this shouldn’t be that hard. I’m running only LMS and no other software other than what M2P/Pi2 require to support LMS or what M2P installs for itself. In fact, I’d LOVE an option for M2P that sets up ONLY an LMS. I came to M2P from picoreplayer because updating PCP required starting over from scratch every damn time. Yet here I am 10 months after moving to M2P re-imaging the SD card yet again.

    • This topic was modified 6 months, 2 weeks ago by  gstalnaker.
    • This topic was modified 2 months ago by  Heiner.
    4. September 2017 at 14:48 #31117

    Hi gstalnaker,

    Recently (there is a thread about it on the Forum) LMS simply stopped responding and, in trouble-shooting the LMS issue, the M2P UI also stopped working — the tabs were at the top of the web pages, but the content was blank. In the end, I was advised to re-image M2P from the IMG and start over. Which I grudgingly did.

    For this reason, we built the image burner to make a back-up of your image within a few minutes and with a few clicks. Please consider creating one just in case.

    While we do encourage our users to do whatever they want with Max2Play, we also advise them to stick to the web interface in case they are not interested in any DIY “futzing”. A problem arising from manual inputs cannot easily be diagnosed or fixed as it is very individually created.

    But the resulting M2P/LMS “experience” was awful. The M2P UI would go into a cyclical “Reloading page every 3 seconds” while installing LMS. And it stayed in that mode until I grew weary and killed it. I re-imaged the SD card three times and that behavior never stopped. With a LOT LOT LOT of futzing I eventually got a stable, working LMS and all was mostly well (LMS is horribly slow) until this morning.

    Please make sure you do not do anything else while installing the LMS. The server does take a few minutes to install, as the yellow text alerts you. Please do not lose patience and let the sequence work itself out. Afterwards the LMS will be properly installed. If anything else happened during installation, please start a new installation and do not disturb it.
    The LMS should not be horribly slow, we have a Pi2 working here with LMS and no interference or significant latency. Please check whether your SD card is Class 10 or higher to rule it out as a possible source of error.

    The three second updates are part of the process, do not stop the installation due to them. Just keep it running.

    The other services of Max2Play can all be deactivated, removed from autostart or put into the inactive plugins section if you only want the LMS.

    4. September 2017 at 17:01 #31131


    I thank you for your reply. I realize that Max2Play has users/customers with a broad range of experience. I am one of those with much experience — 30 years in IT, over a decade of that as an ERP system administrator using Solaris systems for a large American public university. I used Linux as my primary home OS for 20 years (first Linux install was Slackware 1.0 and I’m using as I type LinuxMint 18.1). I know my way around a computer. When dpkg installs the LMS .deb package in 5 minutes, but a web-based process doing the same is not concluded in 30 minutes, then I “grow weary” of the process. There can be many underlying issues that seem to prevent the installation conclusion I know, but nonetheless it seems that 30 minutes is, well, not right.

    I say this not to brag (there are certainly people who have greater knowledge than I do — kernel developers are astounding!) or find blame (truly–I know you and your colleagues at Max2Play do your best at a difficult task), but to show that my comments are not random or simply those of an impatient person. I really did work for five hours trying to “fix” the M2P/Pi2/LMS systematically looking through config files to see if I could discover anything relevant.

    I understand, from your perspective, that a customer who does such things poses a support nightmare — you cannot know what I’ve done and thus cannot begin to offer real help. I know that what I did presents difficulties for remote support (god knows I’ve had to deal with similar things in my own career). That is why I did not ask for such help — I asked for any approaches I can take to provide stability *after* I had re-imaged my M2P/Pi2 install.

    But you do give me a hint of how apps like M2P should be considered–simply backup and when there are issues re-image the system and restore the backup (and from now on forget any thought of “fixing” or “trouble-shooting”). Which I shall do from now on because when M2P is working well it is a very, very nice application (which I why I had no issue paying for it).

    And, after all that, I’m quite happy to say that the new 2.44 image is already better than the 2.43 image. The LMS install completed in less than 10 minutes, as I’d expect. The 3-minute install loop that did not conclude, that I mentioned above, did not occur with the 2.44 M2P version. Also, though M2P/Pi2 is connecting to the same USB drive, the LMS library scan only took 2.5 hours and not 4+ hours. LMS already seems more responsive (could just be me happy to have it working again).

    Thanks to the M2P developers who worked on this new M2P version!

    5. September 2017 at 13:34 #31139

    Hi gstalnaker,

    Thanks for your detailed, nice and thoughtful response.

    The better performance of the LMS might be due to the new version 7.9 (without nightly) that mherger recently released. Here is the post on it:

    Indeed, a backup of your Max2Play image, especially if you are tinkering with it and try to optimize your system, is always a good idea and very easy with our Image Burner Plugin.

    5. September 2017 at 22:45 #31142


    Do you know what “Remove SlimService specific code. 7.9 will never be run on mysqueezebox.com.” from the SlimServer 7.0 change log means?

    Just asking.


    6. September 2017 at 8:25 #31145

    From mherger (who released this version):

    Ok, that comment might be a bit misleading. LMS is part of the software stack we run on mysb.com. Some of the code in LMS < =7.8 was specific to when it's running in our data centers. That's code which should never be executed on a customer's computers, aka. unused code. This code I have removed in 7.9, as I don't expect LMS 7.9 ever to be run on our infrastructure.

    19. December 2017 at 4:15 #33041

    Heiner … an update, sad to say. I have had to reimage my m2p 2.44 sd card again. I cannot help you with any kind of data other than to tell you what happened because, well, it would not successfully boot. All I did was use the m2p webui to restart the RPi. That’s it. But nothing on reboot. No anything … no networking, no ui, no video output, no ssh. Well, no boot output. I did have a multi-colored square on my TV (hdmi input), but nothing else, no kernel load, etc.

    The only recourse available was to reimage the sd card, which worked. It’s now back up and I’ve reinstalled LMS, etc.

    It seems impossible this can happen. No tweaks on my part — this was a stock install with only LMS and SqueezeLite. Yet somehow a simple reboot, or something else (?), hosed the system to the extent it could not complete a boot. Only reimaging the sd card worked.


    19. December 2017 at 13:17 #33049

    Hi gstalnaker,

    I am sorry you had such a bad experience. Please consider checking your SD card (should be at least Class 10 or higher) and your power supply (the rainbow square indicates insufficient power; UNDER-VOLTAGE WARNING) most of all. 2,5A should be the minimum for RPi 2 or 3.

    19. December 2017 at 17:08 #33053


    I know these are man-made objects, but do power supplies and sd cards go bad? The power supply is the one purchased from HiFiBerry when I bought the RPiB+, as is the sd card, part of a bundled purchase. Too, if everything worked before the reboot and then *works after reimaging the sd card* logic would lead me to conclude whatever goes awry can’t be the supply/card since they remain the same before and after.

    That said, how does one check supply and card for problems? Or, if that’s too difficult (requires specialized testing equipment, etc.) what does Max2Play recommend as an acceptable power supply?


    19. December 2017 at 17:32 #33055

    Hi gstalnaker,

    As mentioned, the card should be Class 10 speed or higher. There should be a symbol on the card that indicates the speed class: https://www.sdcard.org/developers/overview/speed_class/

    With power supply, it really depends on the setup. We generally send 2,5A power supplies for most bundles (excluding Amps), so 2,A 5V by which the 2,5A is the important factor. But obviously any and all periphery that drains power can be problematic, so all USB without its own PS.

    19. December 2017 at 18:11 #33056

    Heiner — Thanks for your suggestions.

    HiFiBerry DAC+ bundle

    That’s the bundle I bought though at the time the Pi3 wasn’t sold, so I bought a PiB+. It comes with the 2.5A 5V power supply you recommend.

    I will consider this the price of using this type of system. It is not, after all, a $2000 Apple MacBook Pro. I will also get another hdmi cable, and keyboard, and set them to be permanently attached to the Pi so the aggravation of dealing with any future issues is lessened.

    Thanks again.

    15. February 2018 at 2:44 #34015

    Heiner – I’m very sorry to have to tell you that today I have redone my RaspberryPi installation and moved to a stock Raspbian and I’ve done the work to install LMS, SqueezeLite, and configure it for using my HiFiBerry audio hardware by hand. Thankfully I have long experience in *nix operating systems (having been an ERP app admin for half my career at my current employer) and I know my way around Google and forums. I’m listening to an audio stream now as LMS scanning my music collection.

    I did want to tell what happened because it’s been 8 weeks since my last post and, again, the Max2Play system somehow, magically, was hosed over night. LMS was working last evening. I listened to a playlist as I went to bed. Today I worked from home after a dentist appointment and when I tried to use the SqueezeBoxServer web UI to create a playlist, the UI was missing elements!

    So, I opened http://max2play and restarted SqueezeBoxServer. I got a “restart successful” message, but could not connect to <host>:9000. I restarted again. No SqueezeBoxServer on port 9000. So, I rebooted the RPi. On reboot the Max2Play Admin UI said SqueezeBoxServer was not installed.


    I know you and your colleagues do excellent work–the M2P UI is really nice and it’s easy to use. But this is now the FOURTH time my SqueezeBoxServerinstall has mysteriously become hosed. I’ve done nothing to the install; it’s been working flawlessly since I reinstalled it. And this time it’s with a brand new RPi3 that I bought after our last interactions (see above). I’ve since bought a NAS so there is no issue with USB or power, etc. (which required only a mount in the M2P config and a rescan). And yet, again, SqueezeBoxServer becomes unusable and … well, I’m done.

    I know ditching M2P won’t help you figure out what’s going on, but I’m not willing to wait until something could be figured out. I just want it to work and not fail when I’m not doing anything to it except listening and occasionally adding new music (and the rescan that requires). Max2Play isn’t giving me that. Wish it did.

    15. February 2018 at 15:48 #34023

    Hi gstalnaker,

    I am sorry to hear that. We wish you would have been able to experience Max2Play in a similar to fashion to most other users here and really wish to have found out what caused the issues with your LMS install as this has not been reproducible with any other device or user thus far. However, we do wish that you will find your ideal setup and we also very much appreciate your kind words on our UI.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here