[SOLVED] How do I uncheck "Load WiFi Interface ?

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions [SOLVED] How do I uncheck "Load WiFi Interface ?

This topic contains 14 replies, has 3 voices, and was last updated by  Raymond Day premium 8 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • 20. February 2017 at 21:17 #27065

    I got this on a NanoPi NEO Air. So only has RS-232 and WiFi to connect to it. But looks like Max2play will mess it up.

    I did do a apt install network-manager but running it with nmtui It just shows blank! Like this:

                                ┌────────────────────────┐
                                │                        │
                                │ ┌──────────┐           │
                                │ │        ↑ │ <Add>     │
                                │ │        ▮ │           │
                                │ │        ▒ │ <Edit...> │
                                │ │        ▒ │           │
                                │ │        ▒ │ <Delete>  │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ▒ │           │
                                │ │        ↓ │ <Quit>    │
                                │ └──────────┘           │
                                │                        │
                                └────────────────────────┘
    
    

    It all so looks like Max2Play can’t use the WiFi too and a lot of times I can’t connect to it and have to edit the WiFi setting and reboot.

    I wanted to turn off the “Load WiFi Interface:” But it just keeps like timing and never can Finnish I guess because it breaks the WiFi.

    Is there a command line to do the same as unchecking the Load WiFi Interface?

    -Raymond Day

    21. February 2017 at 12:30 #27079

    Dear Raymond Day,

    Please note that we do not support NanoPi NEO Air at the moment.

    Regards,
    Mohammad

    22. February 2017 at 1:16 #27104

    How can I do the same thing on the command line because when I unclick this on the web page it just does dims it with a circle and never comes back! I think because it don’t have the IP address any more. I have to edit the nano /etc/network/interfaces it looks like it puts # at the start of some lines and I remove them and then /etc/init.d/networking restart then it goes it’s IP back. Here is the check I am talking about in this photo.

    I want to uncheck the Load WiFi Interface but it never comes back after that.

    This only has WiFi and RS-232 and it seems Max2play will mass it up on a reboot so I have to fix the WiFi all the time. I think if I can uncheck the Load WiFi Interface: It will keep it’s WiFi on a reboot then.

    So how can I do the same on the command line like uncheck that?

    -Raymond Day

    • This reply was modified 9 months ago by  Raymond Day.
    22. February 2017 at 15:16 #27123

    Dear Raymond Day,

    Please try to connect directly to the LAN via cable, then you could unchecked this box. Max2Play always needs an IP to operate.

    Regards,
    Mohammad Mbydeen

    23. February 2017 at 2:17 #27155

    It don’t have a LAN or Ethernet port on it. It’s name Nano Pi Neo Air because only WiFi.

    Maybe if I hook a USB to Ethernet on it. I have to wire up a USB to it’s pins to do that.

    But there is no command line way to do the same?

    -Raymond Day

    23. February 2017 at 13:34 #27168

    Dear Raymond Day,

    Once again,please note that we do not provide technical support for Nano Pi Neo Air, Max2Play image has been developed mainly for Raspberry Pi and ODROID.

    Regards,
    Mohammad Mbydeen

    24. February 2017 at 2:54 #27183

    I know it’s only support for the Raspberry Pi. I did now know for the ODROID because a wile ago I posted about it locking up after some time. But then you said the same thing only support the Raspberry Pi. So I have not been using my Odroid as a Max2Play for a wile.

    But any way I am sure the same command would work on the Raspberry Pi. So say you could not hook it up to Ethernet and it do that same thing disconnects the Wifi before can set it. How could you do the same on the command line to like Uncheck the Load WiFi Interface but with the command line on a Raspberry Pi. I am sure it be the same on this unit.

    -Raymond Day

    • This reply was modified 9 months ago by  Raymond Day.
    24. February 2017 at 5:13 #27186

    I solder up some wires to a USB and plug in a USB to Ethernet. Got it connected to that and unchecked the Load WiFi Interface rebooted and it stayed unchecked. Then switch it back to WiFi just copied my backup with cp /etc/network/interfaces~~ /etc/network/interfaces but after that reboot on WiFi again the Load WiFi Interface is checked again.

    But looks like it’s working any way from this reboot it did get a WiFi IP.

    I think it’s fixed now.

    It’s neat to have this small NanoPi NEO Air with NanoHat PCM5102A working good with Max2play. No display on this so just a music server.

    -Raymond Day

    25. February 2017 at 17:31 #27224

    Hey Raymond

    I would love to hear more about how you use the NanoPi Neo air.
    It seems like I can’t send a pm???

    I would like to use the NanoPi Neo air battery powered and on the go.
    Do you think this is possible?

    I use an Odroid C0 with Volumio 2 that way. In this setup the Odroid/Volumio creates a hotspot for playback of locally stored files or I can go to configuration and I can then enter the network data of my phones hotspot.

    Hope you can tell me a bit about a similar setup with NanoPi Neo Air.

    Cheers

    26. February 2017 at 12:40 #27238

    I order a NanoPi NEO $7.99 not a air one with the NanoHat PCM5102A $9.99 waiting for it. But I guess the set up will be close to the same.

    Posted on the board how to set up the air. I think it will work.

    But have not tested that out yet.

    My NanoPi NEO Air is working good with Max2Play. No display on it but though the WiFi can play music real good. I have had phones on it with the volume all the way up and it’s a good volume on the head phones.

    Will test this out with a battery later walking around with no wires to see how it works.

    -Raymond Day

    • This reply was modified 8 months, 4 weeks ago by  Raymond Day.
    • This reply was modified 8 months, 4 weeks ago by  Raymond Day.
    27. February 2017 at 3:49 #27250

    I just tested this with a battery! It worked! I had a song repeat playing and I went out side but in the dark and took a video and I went to fair I am sure for my WiFi. But it was still playing. I guess hold the song in it’s buffer. But when the song ended it did not start over. But it did when I got close to the house it started back up.

    I will take another video tomorrow morning when it’s light out. But it is working real good.

    Neat to just hold it and walk around no wires to hold it in one place.

    -Raymond Day

    • This reply was modified 8 months, 4 weeks ago by  Raymond Day.
    27. February 2017 at 14:01 #27262

    Hi Raymond Day

    Thank you to share your experience with NanoPi Neo Air in our forum, and we are happy that you solved your problem.

    Best Regards,
    Mohammad Mbydeen

    27. February 2017 at 16:31 #27283

    Just uploaded a video on YouTube of me using this out side to walk away from WiFi till it quit playing. Then back to the WiFi and it started up.

    So this does work good. Running on a cell phone charger battery.

    Here is the YouTube video link.

    It is working real good now. Took a little wile to set it up.

    But it connects to the WiFi now on power up and down.

    -Raymond Day

    28. February 2017 at 13:27 #27318

    Hi Raymond Day

    Thank you for sharing your video link 🙂

    Regards,
    Mohammad Mbydeen

    28. February 2017 at 13:37 #27321

    Yes wanted to show how good this works. I guess it would go about a full day on the battery I had on it.

    I thought the song quit because in the playlist some times it don’t go to the next song. But it just started the last song were it left off.

    -Raymond Day

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Register here