[SOLVED] Status: Squeezelite not running

Max2Play Home 2016 (en) Forums General Questions on Hardware and Max2Play Versions [SOLVED] Status: Squeezelite not running

This topic contains 10 replies, has 3 voices, and was last updated by  Raymond Day premium 9 months, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • 20. Februar 2017 at 12:28 #27033

    Got Max2Play running on a NanoPi Neo Air with a NanoHat PCM5102A

    Looked like it my have the same audio chip as in the HiFiBerry. So I installed that plug in. Picked every „Your installed HiFiBerry Card:“ and rebooted and still get „Status: Squeezelite not running

    I can play music with it on the command line like this:

    Screen shot of my command line and Max2play on a NanoPi NEO Air

    If I do a command aplay -l is shows this:

    [email protected]:~# aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: Pcm5102a [Pcm5102a], device 0: Playback pcm5102a-hifi-0 []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: sndhdmi [sndhdmi], device 0: SUNXI-HDMIAUDIO sndhdmi-0 []
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    [email protected]:~#

    If that helps any. It be neat if can get this NanoPi NEO Air to work with Max2play and the NanoHat PCM5102A

    Max2Play seems to be working on it good. Just have to get it to work wit the NanoHat now. If any one knows what I could do to fix this please let me know here.

    -Raymond Day

    20. Februar 2017 at 14:38 #27040

    Dear Raymond Day,

    Unfortunately, we do not provide technical support for NanoPi Neo Air neither NanoHat PCM5102A at the moment.

    Regards,
    Mohammad

    20. Februar 2017 at 14:48 #27041

    Thanks for letting me know.

    How about a buy this for you so you can look at getting it working. I can send it to you. It’s a neat little WiFi server. That don’t cost a lot.

    -Raymond Day

    20. Februar 2017 at 15:09 #27045

    Dear Raymond Day,

    Thank you for your offer 🙂

    But we mainly provide technical support mainly for Raspberry pi.

    Regards,
    Mohammad

    20. Februar 2017 at 19:29 #27055

    I got it working! Took so long. All I did what this command:

    apt install squeezelite

    Then could list the sound card it sees with this:

    [email protected]:~# /usr/bin/squeezelite -l
    Output devices:
      null                           - Discard all samples (playback) or generate zero samples (capture)
      sysdefault:CARD=Pcm5102a       - Pcm5102a,  - Default Audio Device
      dmix:CARD=Pcm5102a,DEV=0       - Pcm5102a,  - Direct sample mixing device
      dsnoop:CARD=Pcm5102a,DEV=0     - Pcm5102a,  - Direct sample snooping device
      hw:CARD=Pcm5102a,DEV=0         - Pcm5102a,  - Direct hardware device without any conversions
      plughw:CARD=Pcm5102a,DEV=0     - Pcm5102a,  - Hardware device with all software conversions
      sysdefault:CARD=sndhdmi        - sndhdmi,  - Default Audio Device
      dmix:CARD=sndhdmi,DEV=0        - sndhdmi,  - Direct sample mixing device
      dsnoop:CARD=sndhdmi,DEV=0      - sndhdmi,  - Direct sample snooping device
      hw:CARD=sndhdmi,DEV=0          - sndhdmi,  - Direct hardware device without any conversions
      plughw:CARD=sndhdmi,DEV=0      - sndhdmi,  - Hardware device with all software conversions
    
    [email protected]:~#
    
    

    Then did:

    chmod +X /etc/init.d/squeezelite

    Then started it with:

    /etc/init.d/squeezelite start

    Not sure if I need to do all that. But went to it’s IP and it shows this:

    Status: Squeezelite is running with processID 10006

    Playing some songs on it now it works good. Playing though that small sound card too.

    I thought Max2play all ready installed the Squeezelite but I guess me installing it with the apt install squeezelite config it for the hat card.

    Can even do the Volume up and down but I could do that on the command line with a + or – on the keyboard too.

    Seems like it’s working real good. No one could help so I guess if any one else wants to do this can now.

    -Raymond Day

    • This reply was modified 1 year, 7 months ago by  Raymond Day.
    • This reply was modified 1 year, 7 months ago by  Raymond Day.
    20. Februar 2017 at 20:05 #27059

    So I guess all I had to do once installing the OS, Setup WiFi, and updating it just had to do this:

    wget https://raw.githubusercontent.com/max2play/webinterface/master/install_max2play.sh
    chmod 777 install_max2play.sh
    ./install_max2play.sh
    apt install squeezelite 

    Been working on this for 3 days. Happy got it working.

    Did order just today a NanoPi with Ethernet and the hat board for it. So I will do this again on this one should be the same and then I can show a step-by-step way to do it.

    -Raymond Day

    21. Februar 2017 at 11:55 #27075

    Dear Raymond Day,

    We are happy that your problem has been solved 🙂 and thank you for sharing the solution on the forum.

    Regards,
    Mohammad

    13. Mai 2017 at 18:36 #28831

    How did you install MAxplay on the Nano Pi? Did you use an image? If so, which? Or did you install it manuelly? Is there a guide for this.

    12. Dezember 2017 at 6:13 #32875

    From what I remember just downloaded a image for it 1st and put that on a SD card and set it up so I could log in to it and updated it.

    Then did the commands to install Max2Play.

    Can find images for the NanoPi Neo Air here.

    http://www.mediafire.com/file/m7ag71w1ntj17gq/nanopi-neo-air_debian-nas-jessie_4.11.2_20171102.img.zip

    I still have to run a „squeezelite -o hw:CARD=Pcm5102a,DEV=0“ on the command line to get it to play music with Logitech Media Server. It will say then that Status: Squeezelite is running with processID XXXX

    I can try all the soundcard Select Audio output it list and start but it still don’t run! Just have to do that command on the command line and then in Max2play web page it says its running.

    -Raymond Day

    • This reply was modified 9 months, 1 week ago by  Raymond Day.
    12. Dezember 2017 at 17:04 #32901

    I got it to auto start Squeezelite and work on boot by putting this in /opt/max2play/custom_autostart.sh The hole file looks like this now.

    #!/bin/bash
    #Custom Autostart File
    
    #Start squeezelite so Max2Play works on NanoPi NEO Air with NanoHat PCM5102A
    sudo -u root -H -s squeezelite -o hw:CARD=Pcm5102a,DEV=0 > /dev/null 2>&1 &

    Rebooted it and went to it’s web page and says Status: Squeezelite is running with processID 1175 Your processID will be some other number.

    All problems that I know of fix on this now!

    -Raymond Day

    • This reply was modified 9 months, 1 week ago by  Raymond Day.
    12. Dezember 2017 at 17:10 #32905

    How did I install Max2play on it. I said it before this post. Mostly this line:

    wget https://raw.githubusercontent.com/max2play/webinterface/master/install_max2play.sh

    Then chmod that install_max2play.sh and run it with:

    ./install_max2play.sh

    Chmod it like this „chmod 766 install_max2play.sh“. That makes it so you have permissions to run it.

    -Raymond Day

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Register here