HIfiberry image – EQ not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI HIfiberry image – EQ not working

This topic contains 6 replies, has 2 voices, and was last updated by  Atinkler premium 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • 27. July 2015 at 11:22 #15213

    Hi there

    Posting on Hifiberry and Squeeze forums haven’t gained any replies so trying here

    I installed the latest Hifiberry image and all works except the EQ

    I’ve looked at the asound.conf and also the ALSA folders but not sure what to look for (and if I’m looking at the right ones for Max2play!)

    Can someone please advise me on the best way to fault find and also what files/folder locations I need to look at?

    Happy to get my hands dirty but if this isnt working at the moment on this image I’d like to know so I will then re install the PI image and set up the hifiberry card … just liked the simplicity of this image!

    Cheers

    27. July 2015 at 14:41 #15214

    Hi Atinkler,

    the current equalizer on the audioplayer tab is only working with squeezelite. As the MPD-Player needs the user “mpd” and not the system user “pi” to control the equalizer, we have to add the equalizer feature to the “Music Player MPD” tab with slightly different settings to get it working. Besides that, you need to set the Sound Device in the soundcard settings of the MPD player to “plug:plugequal”. If you do not want to wait until our next release you may run this on the console as root to change the equalizer settings:
    “usermod -aG audio mpd”
    “sudo -H -u mpd alsamixer -D equal”

    Cheers,
    Stefan

    27. July 2015 at 15:23 #15216

    Thanks for the reply Flysurfer

    Sorry if I’ve got the wrong end of the stick but I thought I had connected using Squeezelite? I am playing my music through a LMS set up and synced to other LMS systems?

    27. July 2015 at 15:51 #15217

    Hi Atinkler,

    did you change the soundcard setting for squeezelite to “plugequal – Equalizer for plughw:0,0” in advanced settings?

    Just tested this with the HiFiBerry Amp and it is working for me.

    Cheers,
    Stefan

    27. July 2015 at 15:57 #15218

    No I didnt.. I set up the card as per the step by step instructions (very simple and intuitive by the way!) .. I didnt do anything else.

    So, if I didn’t change the card in the squeezelite setting what is the default that I’m currently using?

    I will change when I get home – hopefully that’s going to be the problem (maybe worth a note in the instructions for setting up the EQ?)

    27. July 2015 at 16:08 #15219

    Ok – yeah, you need to change the soundcard output on the audioplayer tab, if you want to use the equalizer. By default the soundcard setting points directly to the hifiberry amp, if you choose this setting initially. I will think about how to explain that setting a little further in the equalizer menu. Thanks for your feedback on this!

    27. July 2015 at 16:18 #15220

    Great – I’ll give it a whirl – all in all very good work though!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Register here