[SOLVED] Equalizer

This topic contains 15 replies, has 6 voices, and was last updated by  Marcoof premium 1 month, 2 weeks ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • 2. June 2016 at 1:14 #20427

    Hi !

    I have juste receive an Pi-DigiAMP+ from max2play shop 🙂

    All working great, but i cant use equalizer with squeezelite.

    My squeezelite settings -> soundcard: plugequal
    Command line option : -o hw:CARD=IQaudIODAC -V Digital

    Any idea?
    Best regards,
    Marc

    • This topic was modified 1 year ago by  Marcoof.
    • This topic was modified 1 month, 2 weeks ago by  Mbydeen.
    8. June 2016 at 11:20 #20547

    Hi Marc,
    Please try only entering “-o plug:plugequal” in the command line.

    19. June 2016 at 1:01 #20735

    SOLVED!

    I was having the same problem as many: the equalizer just would not work with my HiFiBerry AMP+. After much web research and testing, I found the problem is in the alsa config file (/etc/asound.conf). Here’s how to fix the problem:

    To find out what sound cards you have on your system, display the contents of /proc/asound/cards:

    `$ cat /proc/asound/cards
    0 [ALSA ]: bcm2835 – bcm2835 ALSA
    bcm2835 ALSA
    1 [sndrpihifiberry]: snd_rpi_hifiber – snd_rpi_hifiberry_amp
    snd_rpi_hifiberry_amp`

    Here you can see my HifiBerry Amp+ is seen as card 1. However the ALSA configuration file (/etc/asound.conf) is pointing to card 0, the default card:

    $ cat /etc/asound.conf
    ctl.!default {
        type hw
        card 0
    }
    pcm.equal {
        type plug;
        slave.pcm plugequal;
    }
    ctl.equal {
       type equal;
       module "Eq10";
    }
    
    pcm.plugequal {
       type equal;
       module "Eq10";
       slave {
         pcm "plughw:0,0";
       }
       hint {show on;description "Equalizer for plughw:0,0"}
    

    To fix the problem, you need to change all references in /etc/asound.conf from card 0 to your card (1, in my case). Here is my corrected /etc/asound.conf:

    $ cat /etc/asound.conf
    ctl.!default {
        type hw
        card 1
    }
    pcm.equal {
        type plug;
        slave.pcm plugequal;
    }
    ctl.equal {
       type equal;
       module "Eq10";
    }
    
    pcm.plugequal {
       type equal;
       module "Eq10";
       slave {
         pcm "plughw:1,0";
       }
       hint {show on;description "Equalizer for plughw:1,0"}

    Now reboot your machine, then go into the Max2Play Audio Player->Advanced Configuration. Change the Sound Card to “plugequal – Equalizer for plughw:1,0”. I also changed my ALSA Parameters to “80:::” and the Command Line Options to “-r 44100-48000 -u hL::::”.

    Save everything, reboot again, and you should be good to go.

    Warning: I have a very basic system; just a stock RPi2 and a HiFiBerry AMP+. If your system has additional hardware or a different amp/DAC, your mileage may vary, but the basic approach should get you where you need to go.

    Hope this works as well for everyone!

    • This reply was modified 1 year ago by  HandyGuy.
    20. June 2016 at 23:58 #20774

    Hi !
    Thank to Heiner and HandyGuy for your help!
    I’ll try when i’m back to home…
    Best regards,
    Marc

    12. March 2017 at 14:10 #27599

    Marc, did you manage to get the equalizer to work? Ive tried all sorts but with no success.

    cheers
    Peter

    12. March 2017 at 14:14 #27600

    Marc, did you manage to get the equalizer to work? Ive tried all I can find from the forum but with no success.

    cheers

    Peter

    12. March 2017 at 19:22 #27606

    @petefilltir

    try to erase anything entered in the commandline and try the use the equalizer.

    Regards,
    Mohammad Mbydeen

    12. March 2017 at 19:36 #27607

    thanks for the reply, tried what you said but didn’t work if I select “plugequal” soundcard the player will start and music will play but there is no sound at all and if I select the “equal-equal” card the player wont start

    13. March 2017 at 13:13 #27649

    @ petefilltir

    Have you tried to burn new image, which sound card do you have?

    Regards,
    Mohammad Mbydeen

    13. March 2017 at 14:31 #27670

    I’ve got the iqaudio pi-digiamp+

    14. March 2017 at 18:59 #27736

    Hi petefilltir !
    I havent found the time to test … i’m finishing to build my new house 🙂
    I will try next month !

    Regards,
    Marc

    14. April 2017 at 22:47 #28258

    still havnt found an answer. Ive now got a new setup of a rpi zero w with a just boom amp zero and cant get the equalizer to work on that either seems to me its just for show! nobody seems to have it working on any setup!!!!

    23. April 2017 at 2:13 #28411

    HandyGuy …

    Thanks – perfect solution!

    I have 4 Raspi w/HiFiBerry cards of different types and your solution worked for them all.
    So simple … the solution is independent of sound card type. I wonder if it works for bluetooth speakers as well?????

    Again, thank you for taking the time to post and help others.

    Bob

    24. April 2017 at 22:54 #28451

    No problem, Bob. Happy to help. I saw some others on this thread were still having problems, but no idea if they were able to solve them. Hopefully they were able to get it working.

    Your mention of the BT speakers is interesting. I’ve tried several variants of BT configuration with M2P but never got it to work properly. My goal (slightly different than yours) is to set up the RPi/HFB to act as a Bluetooth sink so I can stream from my phone/tablet into M2P and have it play through the connected speakers. That would allow me to listen to music other than what is on my home media server.

    The last time a poked at this was around a year ago and never got it to work right or consistently. But, the tech has changed in the past year so I may pick this up again with a new RPI3 and see if that makes any difference.

    25. April 2017 at 11:23 #28464

    Hi HandyGuy

    Thank you for your information and we appreciate your willingness to help others on this forum.

    Best Regards,
    Mohammad Mbydeen

    12. May 2017 at 18:38 #28826

    Thank HandyGuy & Heiner !!!

    Working now with your instruction for asound.conf and the commandline from heiner

    Marc

    • This reply was modified 1 month, 2 weeks ago by  Marcoof.
    • This reply was modified 1 month, 2 weeks ago by  Marcoof.
Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.

Register here